KA auto mute

BagNDrag

Premium Plus
Lifetime Premium
Advanced User
Joined
Feb 22, 2012
Messages
776
Reaction score
2,593
@mswlogo - I love what this app does for the V1! Great job! I have a question. For some reason, V1 driver is auto muting Ka immediately after detection. I have even gone in and turned off all muting for all bands and all savvy settings and it still does it. Any idea what could be doing this? I have the V1G2 and iOS 13. Thanks in advance!
 

mswlogo

Software Developer
Premium Plus
Lifetime Premium
Advanced User
Software Developer
Joined
Nov 1, 2014
Messages
4,167
Reaction score
4,495
Location
MA
@mswlogo - I love what this app does for the V1! Great job! I have a question. For some reason, V1 driver is auto muting Ka immediately after detection. I have even gone in and turned off all muting for all bands and all savvy settings and it still does it. Any idea what could be doing this? I have the V1G2 and iOS 13. Thanks in advance!

That sounds pretty out there.

Please send me a log from V1Driver

Enable the Logging First under Debug Settings.
Let the problem occur then send the log when you get a chance, also under Debug Settings.

Please redescribed the problem and your RDS Handle name to refresh my memory along with the log.

Also let me know how you have configured you V1. Your not using custom frequencies are you?

Thanks
 

BagNDrag

Premium Plus
Lifetime Premium
Advanced User
Joined
Feb 22, 2012
Messages
776
Reaction score
2,593
That sounds pretty out there.

Please send me a log from V1Driver

Enable the Logging First under Debug Settings.
Let the problem occur then send the log when you get a chance, also under Debug Settings.

Please redescribed the problem and your RDS Handle name to refresh my memory along with the log.

Also let me know how you have configured you V1. Your not using custom frequencies are you?

Thanks
Thanks for the quick reply. I am using custom frequencies to avoid some ghosting I’ve been seeing. Is that a no-no? I will do some logging.

-Mark
 

mswlogo

Software Developer
Premium Plus
Lifetime Premium
Advanced User
Software Developer
Joined
Nov 1, 2014
Messages
4,167
Reaction score
4,495
Location
MA
Thanks for the quick reply. I am using custom frequencies to avoid some ghosting I’ve been seeing. Is that a no-no? I will do some logging.

-Mark

Check you're work, test it without custom frequencies.
 

BagNDrag

Premium Plus
Lifetime Premium
Advanced User
Joined
Feb 22, 2012
Messages
776
Reaction score
2,593
Will do!
Post automatically merged:

@mswlogo - here are my Cfs
8A1F6559-B27B-41A4-90C9-55AB204606A6.jpeg
 
Last edited:

mswlogo

Software Developer
Premium Plus
Lifetime Premium
Advanced User
Software Developer
Joined
Nov 1, 2014
Messages
4,167
Reaction score
4,495
Location
MA

BagNDrag

Premium Plus
Lifetime Premium
Advanced User
Joined
Feb 22, 2012
Messages
776
Reaction score
2,593
As @johnboy00 eloquently just put it.

Please ask V1 questions in V1 section.

I really have no idea what the implication of those settings are.
No worries, I didn’t know if it was helpful info to debug. That’s all.

-Mark
 

mswlogo

Software Developer
Premium Plus
Lifetime Premium
Advanced User
Software Developer
Joined
Nov 1, 2014
Messages
4,167
Reaction score
4,495
Location
MA
No worries, I didn’t know if it was helpful info to debug. That’s all.

-Mark

Fair enough.

I've never had V1Driver do anything like what you described and why I asked if you had them set.

Very little is known how these behave. I do know if it's out of the custom frequency it will stay silent.
But if it's on the edge it might alert and then mute. I don't know. But I'd really be surprised V1Driver muted Ka with all those options off. It's possible packets are coming in differently than what V1Driver expects with those on, but I doubt it.

I did test Customer frequencies to understand them a little but after that I factory reset and don't run them.
 

BagNDrag

Premium Plus
Lifetime Premium
Advanced User
Joined
Feb 22, 2012
Messages
776
Reaction score
2,593
I’ll turn them off and see how V1Driver behaves. I’ll keep you posted. Thanks again for all of your replies to this thread.

-Mark
Post automatically merged:

I just sent you the log file. I turned off the custom frequencies and it still occurred. Let me know if you need additional info and/or testing. I’m running in little l logic mode.

-Mark
 
Last edited:

Deacon

TXCTG
Banned User
VIP
Premium Plus
Lifetime Premium
Advanced User
Joined
Nov 13, 2016
Messages
13,266
Reaction score
18,395
Location
Hill Country, TX
In the meantime, the tech support person in me wants to ask:

1) Does it happen every time you get a Ka alert?
2) Does it happen even when V1Driver isn't running?
3) Post screenshots of your V1Connection app settings and your V1Driver settings.

1 and 2 might be tough if you don't have a Ka gun to test against or have a hard time finding someone running Ka C/O while doing paperwork on the side of the road or a parking lot or something (or don't have time in the moment).
 

mswlogo

Software Developer
Premium Plus
Lifetime Premium
Advanced User
Software Developer
Joined
Nov 1, 2014
Messages
4,167
Reaction score
4,495
Location
MA
In the meantime, the tech support person in me wants to ask:

1) Does it happen every time you get a Ka alert?
2) Does it happen even when V1Driver isn't running?
3) Post screenshots of your V1Connection app settings and your V1Driver settings.

1 and 2 might be tough if you don't have a Ka gun to test against or have a hard time finding someone running Ka C/O while doing paperwork on the side of the road or a parking lot or something (or don't have time in the moment).

He sent me a log.

At first glance it looks like he has an Apple Watch and there is a feature that if you raise your wrist to view the alert on your watch it will send a mute to V1Driver.

Mutes from Watch, Notifications or Siri Shortcuts all come in the same and look the same in the log. It’s one if those. So it’s not his custom frequencies.
 

BagNDrag

Premium Plus
Lifetime Premium
Advanced User
Joined
Feb 22, 2012
Messages
776
Reaction score
2,593
Thanks for the additional information. I'll run a bunch of tests today and post the results as well as the answers to @Deacon . I'll be trying various setups (with and without watch) etc.

-Mark
Post automatically merged:

@Deacon @mswlogo - Ok, I have completed my rounds of testing. :) I ran multiple tests against Ka in "All Bogey", "l" and "L" and with and without the watch, notifications to the watch turned on and off, custom frequencies, all frequencies etc.

Everything in the app works as expected in all V1 modes and app settings with mute and Savvy settings when I have the watch notifications turned OFF in the watch app notifications section. As soon as I turn ON notifications in the apple watch app, Ka is immediately muted ALL the time regardless of other settings and it does NOT require me to raise to mute. I did several runs keeping my arm lowered and it would still immediately mute.

If this turns out to be difficult to fix, could you please add an Apple Watch option in V1 Driver to "Not mute" on raise? I love getting the visual notification on my watch but don't want it to mute as it currently does.

For the mean time, I've disabled notifications to my watch and everything is working as expected. I've gone in and set all my Savvy mute settings and GPS mute settings and everything is working flawlessly. You guys have made a great app!

Let me know what I can do for you to help fix this issue. I'll be glad to beta test any new versions you come up with. I've have a LOT of testing experience and have my CS degree and have been a programmer for the past 30 years in my career.

Thanks again for a great app and making the V1 even a better experience to own!

-Mark
 
Last edited:

mswlogo

Software Developer
Premium Plus
Lifetime Premium
Advanced User
Software Developer
Joined
Nov 1, 2014
Messages
4,167
Reaction score
4,495
Location
MA
Thanks for the additional information. I'll run a bunch of tests today and post the results as well as the answers to @Deacon . I'll be trying various setups (with and without watch) etc.

-Mark
Post automatically merged:

@Deacon @mswlogo - Ok, I have completed my rounds of testing. :) I ran multiple tests against Ka in "All Bogey", "l" and "L" and with and without the watch, notifications to the watch turned on and off, custom frequencies, all frequencies etc.

Everything in the app works as expected in all V1 modes and app settings with mute and Savvy settings when I have the watch notifications turned OFF in the watch app notifications section. As soon as I turn ON notifications in the apple watch app, Ka is immediately muted ALL the time regardless of other settings and it does NOT require me to raise to mute. I did several runs keeping my arm lowered and it would still immediately mute.

If this turns out to be difficult to fix, could you please add an Apple Watch option in V1 Driver to "Not mute" on raise? I love getting the visual notification on my watch but don't want it to mute as it currently does.

For the mean time, I've disabled notifications to my watch and everything is working as expected. I've gone in and set all my Savvy mute settings and GPS mute settings and everything is working flawlessly. You guys have made a great app!

Let me know what I can do for you to help fix this issue. I'll be glad to beta test any new versions you come up with. I've have a LOT of testing experience and have my CS degree and have been a programmer for the past 30 years in my career.

Thanks again for a great app and making the V1 even a better experience to own!

-Mark

Very strange the Watch Notifications are immediately muting.
That is completely separate from raise wrist to mute.

The Notidication have a Replay option to Mute and for some reason that is immediately getting getting "Clicked".

I was just gonna ask which Gen watch and I saw you email just come in.
 

BagNDrag

Premium Plus
Lifetime Premium
Advanced User
Joined
Feb 22, 2012
Messages
776
Reaction score
2,593
Very strange the Watch Notifications are immediately muting.
That is completely separate from raise wrist to mute.

The Notidication have a Replay option to Mute and for some reason that is immediately getting getting "Clicked".

I was just gonna ask which Gen watch and I saw you email just come in.
That is interesting. Let me know if there are any tests you want me to do. I’ll look around for any other watch settings that may be coming into play.

-Mark
 

Up All Night

Premium Plus
Lifetime Premium
Advanced User
Joined
Nov 27, 2015
Messages
3,818
Reaction score
4,093
Location
Cleveland, OH
Since the tittles got Ka in it thought I could jump in. Driving home to day it appears the covid leave people alone philosophy in Cleveland is over. Two Great saves on the way home.
But I don’t understand ignored’?
IMG_6715.JPG

@mswlogo

Posted from my iPhone using the RDF Mobile App!
 
Last edited:

Discord Server

Latest threads

Forum statistics

Threads
92,090
Messages
1,403,349
Members
23,377
Latest member
Ducaiti999
Top