Back to Back defective R7's

wooki3

Learning to Drive
General User
Joined
Dec 28, 2019
Messages
19
Reaction score
62
Figured I'd double check with some people on here to insure im not missing something. I purchased an R7 from amazon ~2 weeks ago and returned Monday due to not getting an rear detection even when sitting next to a K band source (front would detect fine) spoke with uniden support, explained all the testing I had done, and they agreed there appeared to be an issue. Got my replacement yesterday and now a cannot get any front detection but the rear is fine (tested in the same areas as before). Am I missing something here that could be causing this. The units were mounted in the same area of the car so its not anything to do with something blocking the signal. I factory reset both units to ensure there was not a setting or anything I might have messed with and tested both units under highway mode to ensure all signals were at 100% and firmware was updated. Uniden support also agreed that the second unit sounded bad. I really want to like this unit but unless someone here has a miracle suggestion I will be switching to a different brand. Thanks!
 

1move

PSL +5
Intermediate User
Joined
Apr 3, 2019
Messages
215
Reaction score
338
Location
Alberta, Canada
Hopefully third time is the charm. I love mine although I wish for better MRCD detection.
 

Too3zln

Learning to Fly
Beginner User
Joined
Jun 27, 2019
Messages
179
Reaction score
208
Location
Nebraska
I'd return it again, go with the good ol' r3 for now until they figure out the issues.
 

Vortex

Making Videos
Observer
Corgi Lovers
Advanced User
Lifetime Premium Member
Joined
Jul 19, 2012
Messages
20,945
Reaction score
53,522
Location
Washington State
That is strange. Did you try multiple different situations? Maybe a speed sign driving towards it then running around and driving away? Was this consistent with multiple encounters over time and you never seeing the other arrow?
 

Tallyho

Advanced User
Premium Member
Joined
Mar 21, 2013
Messages
3,340
Reaction score
6,642
No rear detection for K and you returned it? Some people would love that feature!

Did you physically try flipping the unit around from forward to backward to see what happens regarding which antenna it displays for the signal?
 

wooki3

Learning to Drive
General User
Joined
Dec 28, 2019
Messages
19
Reaction score
62
That is strange. Did you try multiple different situations? Maybe a speed sign driving towards it then running around and driving away? Was this consistent with multiple encounters over time and you never seeing the other arrow?
Yes tried this with a sign a few minutes from my house and have tried physically flipping it in hand, nothing just complete loss of signal.

Hopefully third time is the charm. I love mine although I wish for better MRCD detection.
There isn't going to be a third time lol, I understand having a defective product but 2 times on a 600$ product is a bit ridiculous in my book. Returning for good, going to order radenso probably.


Also this happens on all bands just incase anyone was curious.
 

Vortex

Making Videos
Observer
Corgi Lovers
Advanced User
Lifetime Premium Member
Joined
Jul 19, 2012
Messages
20,945
Reaction score
53,522
Location
Washington State
There isn't going to be a third time lol, I understand having a defective product but 2 times on a 600$ product is a bit ridiculous in my book. Returning for good, going to order radenso probably.
I hear ya. We all definitely want our radar detectors to be reliable, and for the money we spend on them, they should be.

Speaking of Radenso, that's one thing that I'm really hopeful for with Theia. Assuming it lives up to the hype, and I think that it will, I also hope that it's reliable and doesn't run into some of the same QC issues we've seen with other detectors.
 

TeamQuack

s\/\/er\/e
Advanced User
Premium Member
Joined
May 8, 2014
Messages
2,307
Reaction score
2,591
Location
NYC
I bet theres nothing wrong with either r7 you had.

There are members here who will test your r7 for you. We’ve been thru this before and had it proven to people their detectors are fine who otherwise think it wasn’t working for whatever reason.

Also, could you post video of your findings or details of your testing so we could take a deeper look into it! Thanks!
 

wooki3

Learning to Drive
General User
Joined
Dec 28, 2019
Messages
19
Reaction score
62
I bet theres nothing wrong with either r7 you had.

There are members here who will test your r7 for you. We’ve been thru this before and had it proven to people their detectors are fine who otherwise think it wasn’t working for whatever reason.

Also, could you post video of your findings or details of your testing so we could take a deeper look into it! Thanks!
Yea I was going to try and get a video, and I did make sure to call uniden before just going it's broke to confirm with them and get their opinion, but they were in agreement with me. I'm more than down for a proper test tho if there is someone that can help.
 

BMW rider

Learning to Fly
Beginner User
Joined
Sep 4, 2019
Messages
96
Reaction score
124
Location
Midwest
I purchased my first R7 from Best Buy and had to return it within 48 hours because the display was defective ... it had a blue vertical line through it at all times. I returned it and bought another one a few days later from a different BB. This one has performed flawlessly so far.


Sent from my iPhone using Tapatalk Pro
 

wooki3

Learning to Drive
General User
Joined
Dec 28, 2019
Messages
19
Reaction score
62
I bet theres nothing wrong with either r7 you had.

There are members here who will test your r7 for you. We’ve been thru this before and had it proven to people their detectors are fine who otherwise think it wasn’t working for whatever reason.

Also, could you post video of your findings or details of your testing so we could take a deeper look into it! Thanks!
@TeamQuack Video, Building to the right is the main source of K and have also had the same happen with Ka and X Detector was also freshly factory reset, arrows never reflected the change in direction, and as was mentioned by Vortex I get no detection when going towards a speed sign from the front. I also did turn on multi threat display after this and while multiple sources of K were picked up, they were again only from the rear. I get the same result while holding the unit and with it mounted. My car does NOT have any sort of solar blocking glass or anything like that either, The first unit I returned had the same issue but reversed (only detected from front) and was mounted/placed in the same areas, tested at the same building/speed sign which should rule out any sort of signal block from the car.
Post automatically merged:

Speed sign
 
Last edited:

wellfleetion

Learning to Fly
Beginner User
Joined
May 6, 2018
Messages
205
Reaction score
195
Location
MassHole
I have an early R7 since new with an extended BB warranty and it's been great.
I drive about 25k plus a year. No issues.
I also had a R3 for 2 years without any issues as well.
My things are secure and never get dropped ever.
 
Last edited:

fitz4321

Running With Scissors
Advanced User
Premium Member
Joined
Dec 12, 2015
Messages
2,425
Reaction score
4,567
Location
Bay Area, CA
Yes tried this with a sign a few minutes from my house and have tried physically flipping it in hand, nothing just complete loss of signal.


There isn't going to be a third time lol, I understand having a defective product but 2 times on a 600$ product is a bit ridiculous in my book. Returning for good, going to order radenso probably.


Also this happens on all bands just incase anyone was curious.
Sorry, can’t help the thread jack... If you paid $600 now for an R7, you need to shop a little more. If you set alerts on Slickdeals, you can do better then Amazon ($469 as of this post) with patience.
 
Last edited:

r3MI

Learning to Fly
Beginner User
Lifetime Premium Member
Joined
Dec 6, 2017
Messages
476
Reaction score
551
Location
Michigan
There was a factory here in town that I had several friends working at, They built Refrigerators the units that went to Sears, Home Depot, Lowes ect would have certain compressors that would be installed with specific part number,

The units that were built for BB and other low price warehouses had a lower quality compressor installed to save on build cost.

Could Uniden be selling Tier 1 and Tier 2 Units based on the sellers and price points ?
 

9C1Driver

Learning to Fly
Beginner User
Joined
Jun 9, 2017
Messages
473
Reaction score
444
There was a factory here in town that I had several friends working at, They built Refrigerators the units that went to Sears, Home Depot, Lowes ect would have certain compressors that would be installed with specific part number,

The units that were built for BB and other low price warehouses had a lower quality compressor installed to save on build cost.

Could Uniden be selling Tier 1 and Tier 2 Units based on the sellers and price points ?
No, I don't see that happening at all with any of the major detector brands.
 

wooki3

Learning to Drive
General User
Joined
Dec 28, 2019
Messages
19
Reaction score
62
ad jack... If you paid $600 now for an R7, you need to shop a little more. If you set alerts on Slickdeals, you can do better then Amazon ($469 as of this post) with patience.
I paid 469 But I meant that it retails normally for 600 when not on sale

But anyways, As it turns out bestbuy put the unit on sale in store for basically what I paid on amazon so I went and picked up a third one for shits and giggles. It works terrific, I took a picture of both units side by side, Top one is the new (working) unit.
20200116_191401.jpg
 

oversteer325

PSL +5
Intermediate User
Joined
May 7, 2019
Messages
731
Reaction score
1,478
Location
NC/SC
I paid 469 But I meant that it retails normally for 600 when not on sale

But anyways, As it turns out bestbuy put the unit on sale in store for basically what I paid on amazon so I went and picked up a third one for shits and giggles. It works terrific, I took a picture of both units side by side, Top one is the new (working) unit.View attachment 138086
Glad to hear you finally got a good one! Keep us updated with your thoughts as you use it.
 

TechnoRave

PSL +5
Intermediate User
Joined
Jan 5, 2019
Messages
591
Reaction score
810
Location
#850Strong - Gulf Coast of Florida
I paid 469 But I meant that it retails normally for 600 when not on sale

But anyways, As it turns out bestbuy put the unit on sale in store for basically what I paid on amazon so I went and picked up a third one for shits and giggles. It works terrific, I took a picture of both units side by side, Top one is the new (working) unit.View attachment 138086
Send the defected one back and get the replacement and run “Double Ghetto” arrows. See if the rear facing R7 falses in the rear. Lol


Sent from my iPhone using Tapatalk
 

knight_man

I wanna go fast
Intermediate User
Joined
Aug 12, 2018
Messages
781
Reaction score
1,078
My R7 is funky and will probably need replaced too. I had suspicions early on that I had a problematic unit, I was seriously thinking Uniden was going to have both of my detectors. First firmware update I thought the firmware made it better, but the longer I use it I realize it might be just me reflashing and resetting it. Basically mine starts reporting on signals out of the functional specs of the unit at random, range starts to seriously suffer, seems like more false alerts. I notice a pretty significant performance hit when it is hot out- like 90s and up. Like most of the summer...

My R1 had similar behavior, although different, and eventually had to be sent in. I started seeing very poor range in all weather, false alerts disappeared from locations other detectors were still getting. They sent me a warranty replacement, refurbished R1.

Both my replacement R1 and a freshly reflashed R7 are seriously killer on range. I suspect they are both better than my M3 Redline... (BLASPHEMY!) BUT only when they are working properly.

It seems pretty well established on the forum that there are some QC concerns with these detectors. There are a lot of posts where users are reporting a variety of issues with these detectors. I have a special love/hate relationship with mine. For now.
 

leesrt

Mature Speeder
Intermediate User
Joined
Feb 3, 2015
Messages
771
Reaction score
1,131
Location
Florida
I think there may have been a batch made with defective rear antennas because mine was the same. The only difference is I sent mine directly back to uniden instead of to where I bought it because I didn't want to take a chance of getting another defective unit from the same place. They sent me a replacement and it worked as advertised.
 

Discord Server

Latest threads

Forum statistics

Threads
89,204
Messages
1,356,775
Members
22,456
Latest member
Easterntg
Top