Beltronics GT-360 Update

FunkyDoc

Learning to Fly
Beginner User
Joined
Sep 19, 2018
Messages
161
Reaction score
326
Location
NJ
Version 1.3 firmware update is out as of today. Escort rep on this site noted in a prior discussion that it would address several issues across the 360 line, including the silent sleeping detector issue reported here. First updated the firmware, then realized it's recommended to do the Update All function. So did that, and then updated Defender DB. Only issue I had with the install is that Escort Live hung while trying to connect to the RD via BT. iOS could see it and connect to it in the System Preferences app, but the app itself was stuck on trying to connect. Thought maybe that pairing was affected by the Update All feature, so deleted it from System Preferences, and lo and behold it was able to then re-pair. All was good after that.

Credit where credit is due to Escort. The rep on this site promised it'd be up in a day or two and that timeline was met. Moreover, the update was released across the 360 line, so no second class Beltronics citizens getting the update weeks later- or not at all. Here's to hoping it fixes the issues reported here once and for all. Would be a perfect detector for many if that were to be the case.
Post automatically merged:
Hopefully I didn't speak too soon, but the listing of what the update covers does NOT include the sleepy RD issue. Instead, it lists the following changes here:

Gt-350 has been updated to v1.2 with the following changes:
-Resolved issue causing rear false alerts under certain conditions
-Reduced laser false alerts

Have not had any of those issues, but want to make sure my RD isn't falling asleep on me so really hoping the Escort rep was true to his/her word when they referenced this FW update in this discussion.
 
Last edited:

samq45

Advanced User
Lifetime Premium Member
Joined
Jul 5, 2011
Messages
1,550
Reaction score
2,242
Location
Saratoga, NY
Thanks!!

Updating now for the ride home later. I was getting the rear false alerts. Laser seemed to be fine.

Hoping none of us ever see the sleeping issue again, but I am sure if someone experiences it again, they will report it.
 

FunkyDoc

Learning to Fly
Beginner User
Joined
Sep 19, 2018
Messages
161
Reaction score
326
Location
NJ
I've got my Pocket Radar for just such a test ; ) Updated last night, so far so good FWIW- but full confidence will take time to build.
 

Up All Night

Advanced User
Lifetime Premium Member
Joined
Nov 27, 2015
Messages
3,619
Reaction score
3,747
Location
Cleveland, OH
Updated this morning and drove off into the sunrise.
First impression was it connected faster to the phone. Watching the scan bar it looked like it had slowed down. Highway mode filters off.
Scary quiet. No BSM on freeway.
Concerning. Then upon exiting the freeway reached the first place I normally get a blip. Have locked site out long ago. Nothing happened. Continued on trek to work. There are about 5 other alarms / door openers I’ve locked out. Two of them gave very short weak blips which came in late and disappeared. I’m thinking, This is Bad but, tried to keep a open mind.
On the way home, silence. No lock outs no BSM. So I went up to my favorite drug store where it locked up about two weeks ago. Soon as I approached it went crazy.
Thinking I need more time to observe and may need to dip into the V2 savings to get a pocket radar. The other thing I noted was there are long periods on the freeway where the scanbar stops.
The one consistent thing is it remains really good at yelling over speed. Also, EL keeps crashing on the iPhone. Gave up on it and switched to escargot.
Waiting to see what others are finding.
IMG_5507.JPG

Posted from my iPhone using the RDF Mobile App!
 
Last edited:

InsipidMonkey

Essential Monkey
Security
Corgi Lovers
Advanced User
Premium Member
Joined
Mar 22, 2017
Messages
7,435
Reaction score
16,670
Location
New England
Thinking I need more time to observe and may need to dip into the V2 savings to get a pocket radar
I can send you a Stalker Basic handheld K band gun for testing if you want. PM me if interested.
 

goblin

Learning to Fly
Beginner User
Joined
Jun 17, 2019
Messages
392
Reaction score
425
So we confirm Escargot works with the GT-360 ?
 

Up All Night

Advanced User
Lifetime Premium Member
Joined
Nov 27, 2015
Messages
3,619
Reaction score
3,747
Location
Cleveland, OH
Last edited:

FunkyDoc

Learning to Fly
Beginner User
Joined
Sep 19, 2018
Messages
161
Reaction score
326
Location
NJ
Do you have it on Highway mode? I started off in Auto, and it was eerily quiet. Turned on Highway mode and got occasional BSM and known X & K alerts. Still quiet though. And tested it with Pocket Radar. Fingers crossed.
 

Up All Night

Advanced User
Lifetime Premium Member
Joined
Nov 27, 2015
Messages
3,619
Reaction score
3,747
Location
Cleveland, OH
Last edited:

FunkyDoc

Learning to Fly
Beginner User
Joined
Sep 19, 2018
Messages
161
Reaction score
326
Location
NJ
Thinking I need more time to observe and may need to dip into the V2 savings to get a pocket radar.
It's why I got my PocketRadar. Good to test while on the road to ensure all's good with the RD. Just hoping this update means this precautionary measure becomes moot.
 

Up All Night

Advanced User
Lifetime Premium Member
Joined
Nov 27, 2015
Messages
3,619
Reaction score
3,747
Location
Cleveland, OH
Took GT360 on the road. Worked about 75 mi south of cleveland today in a medium sized city that does have a OSP post. The entire town was blanketed with constant X band. Some K band and a couple of Ka blasts. One laser tag w/o confirmation - didn’t see any LEO.
No apparent lock up, it never shut up LOL. Getting pizza and heading home. Aprox 1 1/2 hr drive. Maybe some action on freeway?
Go Browns
Update: Home in time for half time.
Two laser tags on way home. One confirmed OSP. The other 20 min later - Didn’t see source. Few low lever X band blips.
Car - Avis loaned me a 2020 Kia Optima.
The almost constant X band stopped when I left the city I was working in... so it wasn’t the car.
Posted from my iPhone using the RDF Mobile App!
 
Last edited:

FunkyDoc

Learning to Fly
Beginner User
Joined
Sep 19, 2018
Messages
161
Reaction score
326
Location
NJ
Promising. I've been checking daily and no sleeping issues so far. Haven't had any laser falses and RD hasn't been any chattier. Fingers crossed.
 

Up All Night

Advanced User
Lifetime Premium Member
Joined
Nov 27, 2015
Messages
3,619
Reaction score
3,747
Location
Cleveland, OH
And it did occur to me that with all the X band low level noise that it was misinterpreting K as X? Anyone seeing a lot of Low Level X too? Have often thought the ProSe does that after the last update but, no point beating a dead horse... don’t have the luxury of using no X here in Ohio.
Posted from my iPhone using the RDF Mobile App!
 
Last edited:

FunkyDoc

Learning to Fly
Beginner User
Joined
Sep 19, 2018
Messages
161
Reaction score
326
Location
NJ
Has not been my experience. Have one spot where there's X band on commute to/from work, but no new spots to report.
 

DrHow

Going “Plaid” ASAP (Tesla S) RDT refugee
Banned User
Advanced User
Lifetime Premium Member
Joined
May 18, 2018
Messages
3,376
Reaction score
5,576
And it did occur to me that with all the X band low level noise that it was misinterpreting K as X? Anyone seeing a lot of Low Level X too? Have often thought the ProSe does that after the last update but, no point beating a dead horse... don’t have the luxury of using no X here in Ohio.
Posted from my iPhone using the RDF Mobile App!
To answer your question to anyone.. No. works well when X is on (mostly when running in Ohio).
 

Up All Night

Advanced User
Lifetime Premium Member
Joined
Nov 27, 2015
Messages
3,619
Reaction score
3,747
Location
Cleveland, OH
Been watching this thing like a Hawk.
Really want to say Bye Golly - They fixed it.
But, then there are a lot of times escargot is sending it the speed limit and it’s just displaying the b.t. logo. When this happens it ‘s quiet, really quiet.

And the few minutes later, works like a Dream.
Jury is still Out...
 

Attachments

FunkyDoc

Learning to Fly
Beginner User
Joined
Sep 19, 2018
Messages
161
Reaction score
326
Location
NJ
FWIW, my unit has been working perfectly thus far- fingers crossed that I didn't just jinx myself. It's alerted me to all the usual local fixed X and K band, and gave me two legit 3/4 mile Ka alerts two days in a row on a long downward hill- guess it's that time of the month for the local PD in that town. Also, this may just be related to the positioning of the satellites or may be weather-related, but my GPS acquisition is also faster now. It has been bad for me since I attached the M1 dashcam together with the blendmount in my particular car.
 

FunkyDoc

Learning to Fly
Beginner User
Joined
Sep 19, 2018
Messages
161
Reaction score
326
Location
NJ
Well, my unit has the sleep issue. Was working great for a long time mostly on Highway mode, with regular pickups of the fixed spots I mentioned above on my daily commutes. Until two days ago. Have had 3 (THREE) separate sleeping episodes since then:

1. 2 days ago, started car in parking lot. Have automation set up so that Waze and EL automatically start up with Waze on CarPlay head unit and EL on the iPhone. This time, though all was good on the phone, the RD was not hooking up with the phone. System Preferences and EL both showed GT-360 as not connected. Tried usual of turning BT off and back on on phone, manually connecting, no dice- though that had worked before. While I'm doing this I drive by a known K spot and nothing. Hit it with the PocketRadar (PR), and nothing. Let it go for 5 min, still nothing to PR or anything else. Unplugged power and replugged it back in, and still nothing with PR. Had never seen that before. Gave it 5 minutes, then it was working. Weird. And FWIW, I point the RD straight out towards the back window to try to only get reflections. When RD is not sleeping it consistently alerts, albeit sometimes by a half second delay.
2. Yesterday on long series of drives for me, cumulative ~120 miles. Passed a speed sign on the Belt Parkway and it reported my speed- but the RD was silent. Noticed it had been quiet for some time, so brought out the PR and again nada. Left it that way for another 15 minutes and it was silent the entire way. Tried a few more times with PR, still a silent. Tried toggling between Highway, Autoscan modes etc to wake it up, nothing. Had to restart. Then it alerted to PR.
3. Another episode on same drive home, about half an hour later.

Real bummer. Had been very happy with the RD until this stretch and thought at least for my unit that the latest FW had licked the issue. Apparently not. Will have to call ER to get it fixed, and now looking at other options. Maybe installed unit. Damnit.
 

InsipidMonkey

Essential Monkey
Security
Corgi Lovers
Advanced User
Premium Member
Joined
Mar 22, 2017
Messages
7,435
Reaction score
16,670
Location
New England
Sorry to hear that @FunkyDoc. Consider reporting the issue on ERF and/or Beltronics Radar Forum - Powered by vBulletin as well for increased visibility, as Escort tends to deny problems exist (or claim they've solved them) until faced with overwhelming evidence to the contrary. Good luck getting it sorted out.
 

DrHow

Going “Plaid” ASAP (Tesla S) RDT refugee
Banned User
Advanced User
Lifetime Premium Member
Joined
May 18, 2018
Messages
3,376
Reaction score
5,576
Well, my unit has the sleep issue. Was working great for a long time mostly on Highway mode, with regular pickups of the fixed spots I mentioned above on my daily commutes. Until two days ago. Have had 3 (THREE) separate sleeping episodes since then:

1. 2 days ago, started car in parking lot. Have automation set up so that Waze and EL automatically start up with Waze on CarPlay head unit and EL on the iPhone. This time, though all was good on the phone, the RD was not hooking up with the phone. System Preferences and EL both showed GT-360 as not connected. Tried usual of turning BT off and back on on phone, manually connecting, no dice- though that had worked before. While I'm doing this I drive by a known K spot and nothing. Hit it with the PocketRadar (PR), and nothing. Let it go for 5 min, still nothing to PR or anything else. Unplugged power and replugged it back in, and still nothing with PR. Had never seen that before. Gave it 5 minutes, then it was working. Weird. And FWIW, I point the RD straight out towards the back window to try to only get reflections. When RD is not sleeping it consistently alerts, albeit sometimes by a half second delay.
2. Yesterday on long series of drives for me, cumulative ~120 miles. Passed a speed sign on the Belt Parkway and it reported my speed- but the RD was silent. Noticed it had been quiet for some time, so brought out the PR and again nada. Left it that way for another 15 minutes and it was silent the entire way. Tried a few more times with PR, still a silent. Tried toggling between Highway, Autoscan modes etc to wake it up, nothing. Had to restart. Then it alerted to PR.
3. Another episode on same drive home, about half an hour later.

Real bummer. Had been very happy with the RD until this stretch and thought at least for my unit that the latest FW had licked the issue. Apparently not. Will have to call ER to get it fixed, and now looking at other options. Maybe installed unit. Damnit.
Glad I have never updated the GT360 from its 1.0 FW. Never seen this or anything else dealing with sleeping, or lock up. 360c on other hand, with latest FW went from being almost perfect, to a sleeping lug at random occasional times.
Post automatically merged:

Next week testing on 360 platforms will be exclusive Stalker 34.7 and Falcon HR in car to test sleeping. In case the Bushnell has messy transmitter and is getting filtered out.
 
Last edited:

Discord Server

Latest threads

Latest posts

Forum statistics

Threads
85,345
Messages
1,297,281
Members
21,524
Latest member
jesus359
Top