R3 Issue

larrymz3

Learning to Fly
Beginner User
Joined
Jun 22, 2014
Messages
110
Reaction score
85
Anyone else have an issue where neither mounts lock in place? Both the big suction cup and standard windshield mount don't lock into place on my R3.

The button on top seems to work fine but the mounts don't seem to be engaging whatever inside is supposed to go into the mount hole.




Sent from my iPad using Tapatalk
 

drtoddw

Always driving at a safe and prudent speed
Advanced User
Lifetime Premium Member
Joined
Nov 3, 2016
Messages
3,816
Reaction score
5,070
Location
Behind the wheel
I had that one time only but was easily fixed by removing the detector and putting it back on the mount a few times until it locked. I haven't had the issue since that time.
 

larrymz3

Learning to Fly
Beginner User
Joined
Jun 22, 2014
Messages
110
Reaction score
85
Yep I've tried that. There is definitely an issue inside my unit where it won't lock in place properly.


Sent from my iPad using Tapatalk
 

larrymz3

Learning to Fly
Beginner User
Joined
Jun 22, 2014
Messages
110
Reaction score
85
Any other suggestions? I'd hate to have to send it back to uniden for warranty repair and have it take a month. I bet it's some kind kind of catch inside the unit that is the culprit.

The button still pushes down and pops back up, so, I doubt it's anything too serious.


Sent from my iPad using Tapatalk
 

westwind77

Advanced User
Lifetime Premium Member
Joined
Dec 7, 2016
Messages
2,992
Reaction score
5,808
Anyone else have an issue where neither mounts lock in place? Both the big suction cup and standard windshield mount don't lock into place on my R3.
The button on top seems to work fine but the mounts don't seem to be engaging whatever inside is supposed to go into the mount hole.
YES!! I have been meaning to post about it. You can watch the button move just a bit as you slide it in the mount but it will not lock into place. You can pull it right off without any resistance, or maybe 5% more than you would with pressing the button. Mine was just received a couple weeks ago. Wonder if there is a faulty batch. Not the end of the world as I plan to get the blendmount clip when it is released which usually 'pins' it from the top too.
 

Bbonez

PSL +5
Intermediate User
Joined
May 11, 2017
Messages
204
Reaction score
252
I got my R3 in the 2nd shipment SN#4XX, No issues locking the unit to the mount.
 

catch1147

PSL +5
Intermediate User
Joined
Jan 18, 2017
Messages
258
Reaction score
254
Location
Onalaska, Wi.
Yep I've tried that. There is definitely an issue inside my unit where it won't lock in place properly.


Sent from my iPad using Tapatalk
Maybe the button that pops up doesn't align with the hole in the mount. Try filing the opening to make it a little bigger. I doubt if the R3 would fall out as I use mine in an XP mount occasionally and it doesn't lock into that mount, and I've never had a problem.

Posted from my SM-N910P using the RDF Mobile App!
 

catch1147

PSL +5
Intermediate User
Joined
Jan 18, 2017
Messages
258
Reaction score
254
Location
Onalaska, Wi.
Maybe the button that pops up doesn't align with the hole in the mount. Try filing the opening to make it a little bigger. I doubt if the R3 would fall out as I use mine in an XP mount occasionally and it doesn't lock into that mount, and I've never had a problem.

Posted from my SM-N910P using the RDF Mobile App!
Edit: I see that neither mount works so it probably is a problem with the R3, it wouldn't have to be off much for it not to lock in.

Posted from my SM-N910P using the RDF Mobile App!
 

Anton Chigurh

Learning to Drive
General User
Joined
May 24, 2017
Messages
21
Reaction score
4
YES!! I have been meaning to post about it. You can watch the button move just a bit as you slide it in the mount but it will not lock into place. You can pull it right off without any resistance, or maybe 5% more than you would with pressing the button. Mine was just received a couple weeks ago. Wonder if there is a faulty batch. Not the end of the world as I plan to get the blendmount clip when it is released which usually 'pins' it from the top too.
There are existing Blendmount clips that work perfectly. Here is a video from [MENTION=2404]Vortex[/MENTION]:
https://www.youtube.com/watch?v=8CnxKg0pfYk
 

Discord Server

Latest threads

Forum statistics

Threads
89,348
Messages
1,358,773
Members
22,490
Latest member
radarhead
Top