New Redline 360c Defective (SOLVED)

LoveRenee

Radar/Lidar Addiction MD
Premium Plus
Lifetime Premium
Advanced User
Joined
Sep 24, 2016
Messages
449
Reaction score
708
Location
Moreland, Georgia
Well, I finally got it delivered. It paired flawlessly and updated to firmware 1.60 without a hitch. With my first K band detection, it beeped and displayed the alert, however, after the initial alert it completely muted. No sound whatsoever after. I checked the volume settings. All good. I checked automute settings: off. I turned it off and back on -- passed by the same alert and it did the same thing (it did not lock it out).
Well, it happened again tonight with another K band alert. After I got home, I fired up the Stalker DSR2x and again, initial alert but went straight to full mute. I tried a factory reset and reinstalled the FW. No change.
In short, unless anyone has any other ideas, I plan on getting a RMA to send it back to ABT. There is no reason to call Escort in my opinion. Regardless, it looks like a new replacement wouldn't be available anytime soon. I am very disappointed.
 
Last edited:

GregTec5

PSL +5
Intermediate User
Joined
Jun 10, 2020
Messages
674
Reaction score
1,793
Location
Georgia
...And I was looking forward to your thoughts on it too.
 

westwind77

Premium Plus
Lifetime Premium
Advanced User
Joined
Dec 7, 2016
Messages
3,536
Reaction score
8,028
Well, I finally got it delivered. It paired flawlessly and updated to firmware 1.60 without a hitch. With my first K band detection, it beeped and displayed the alert, however, after the initial alert it completely muted. No sound whatsoever after. I checked the volume settings. All good. I checked automute settings: off. I turned it off and back on -- passed by the same alert and it did the same thing (it did not lock it out).
Well, it happened again tonight with another K band alert. After I got home, I fired up the Stalker DSR2x and again, initial alert but went straight to full mute. I tried a factory reset and reinstalled the FW. No change.
In short, unless anyone has any other ideas, I plan on getting a RMA to send it back to ABT. There is no reason to call Escort in my opinion. Regardless, it looks like a new replacement wouldn't be available anytime soon. I am very disappointed.
Sounds like you are running Escort Live either over BT or Wi-Fi and you are traveling below the PSL for that road. It is Escorts version of 'quiet ride' where if you are traveling below the register PSL database the unit will give you one alert to get your attention but mute anything further as it is not a threat as you are not speeding.

This is an optional setting, which I turn off myself to get all alerts with it muting. Also, if the PSL is wrong you could be at risk of getting a ticket as well.
 

LoveRenee

Radar/Lidar Addiction MD
Premium Plus
Lifetime Premium
Advanced User
Joined
Sep 24, 2016
Messages
449
Reaction score
708
Location
Moreland, Georgia
Thank you! You are correct! My bad. This is one of the many reasons why I love RDF. Sorry for my rant.
 

GregTec5

PSL +5
Intermediate User
Joined
Jun 10, 2020
Messages
674
Reaction score
1,793
Location
Georgia
So this is not a defect? I just purchased mine today from Best Buy, still have time cancel!
No. Sounds like the EL application and the RD caused confusion for the OP.
 

GregTec5

PSL +5
Intermediate User
Joined
Jun 10, 2020
Messages
674
Reaction score
1,793
Location
Georgia
Alright thank you! I’m new to this scene so I just wanted to make sure ok is alright to buy
Yeah honestly I’ve never heard of any issues out of the box with these. With any new device there is a learning curve. Especially if you aren’t familiar with Escort.
 

Kennyc56

Ford Lover-I/O hater!
Premium Plus
Lifetime Premium
Advanced User
Joined
Feb 22, 2018
Messages
5,256
Reaction score
19,289
Location
I/O Hell, Aka Eastern N.C.
Thank you! You are correct! My bad. This is one of the many reasons why I love RDF. Sorry for my rant.
Great job @westwind77 ! I hope this solves your problem @LoveRenee ! BTW, we all rant when our $500.00 plus detectors don't do what we want! You should have heard me when my V1G2 quit and I had to send it back! It's worked flawlessly ever since however!
 

LoveRenee

Radar/Lidar Addiction MD
Premium Plus
Lifetime Premium
Advanced User
Joined
Sep 24, 2016
Messages
449
Reaction score
708
Location
Moreland, Georgia
No. Sounds like the EL application and the RD caused confusion for the OP.
Looks like the OP overreacted:). If I have any doubts, I'll have @GregTec5 hit me with his Genesis while I am over the speed limit.
 

GregTec5

PSL +5
Intermediate User
Joined
Jun 10, 2020
Messages
674
Reaction score
1,793
Location
Georgia
Great job @westwind77 ! I hope this solves your problem @LoveRenee ! BTW, we all rant when our $500.00 plus detectors don't do what we want! You should have heard me when my V1G2 quit and I had to send it back! It's worked flawlessly ever since however!
Yeah @LoveRenee and I need to meet up soon so I can show him the basics. I hope to be half as good as @westwind77 teaching him though.
 

RoadDogg

Premium Plus
Lifetime Premium
Advanced User
Joined
May 10, 2018
Messages
2,091
Reaction score
7,676
Location
Tennessee
@LoveRenee , Congrats on the new RL360c. I am glad @westwind77 had the answer to the problem. Enjoy your new RL360c and let us know how you like it after you have some driving time with it.
 

MurrayB

PSL +5
Premium Plus
Lifetime Premium
Intermediate User
Joined
Aug 20, 2013
Messages
1,410
Reaction score
2,160
Location
Eastern PA/South Jersey
Enjoy the RL360c I have been running mine since it was launched in June 2020. Good Luck and please be active here on the forum.
 

DifferentialT

Learning to Fly
Premium Plus
Beginner User
Joined
Jan 9, 2021
Messages
632
Reaction score
2,022
Location
Western Colorado
Well it is just great that @westwind77 was able to diagnose the problem and set you straight. The people on this Forum are awesome. I haven't been running EL with my RL360c. For my purposes I really haven't needed it other than running through the menu.
 

jestric

Go Gators!
Premium Plus
Intermediate User
Joined
Sep 4, 2020
Messages
2,531
Reaction score
9,646
Location
Florida
Well it is just great that @westwind77 was able to diagnose the problem and set you straight. The people on this Forum are awesome. I haven't been running EL with my RL360c. For my purposes I really haven't needed it other than running through the menu.

Absolutely! @westwind77 rocked the problem solving for @LoveRenee.

FWIW, I run EL all the time with my RL360C so that I can mute any radar alerts or BSM false alerts, adjust the brightness and the sensitivity if desired. It makes everything so much easier. :cool:
 
Last edited:

DC Fluid

RDF Addicts Anonymous Member
Corgi Lovers
Advanced User
Joined
Jun 7, 2019
Messages
4,606
Reaction score
14,772
Age
55
Location
Prince George, B.C. Canada
I noticed a few issues with Escort Live on my 3 detectors, and have resigned myself to disabling the apps and only using them for easy change of settings.
Now that I have the detectors the way I want, even that isn't being used.
Highway Radar app all day though!
 

jestric

Go Gators!
Premium Plus
Intermediate User
Joined
Sep 4, 2020
Messages
2,531
Reaction score
9,646
Location
Florida
I noticed a few issues with Escort Live on my 3 detectors, and have resigned myself to disabling the apps and only using them for easy change of settings.
Now that I have the detectors the way I want, even that isn't being used.
Highway Radar app all day though!

Agreed!

I personally use JBV1 in standalone mode. Although I still run EL on my iPhone to give me easy muting of my RL360C and one more CM.
 

TonyPHX

PSL +5
Premium Plus
Intermediate User
Joined
May 31, 2020
Messages
911
Reaction score
2,858
Location
Waddell, Arizona
This is a win all the way around and a good reminder of how these features interact. Easy to forget or get confused when these things keep getting more complex.
 

Discord Server

Latest threads

Forum statistics

Threads
94,719
Messages
1,442,350
Members
24,256
Latest member
Cajuncwby30
Top