Head is Blowing Fuse...Troubleshooting/Repair advice?

butterman

PSL +5
Intermediate User
Joined
Jan 14, 2019
Messages
213
Reaction score
309
Hey guys,

I've narrowed down the issue to my right head. The controller boots fine with the head disconnected but as soon as I reconnect it the the blue power light on the controller blinks a couple times and then blows the 1 amp fuse in the the included cigarette plug power cable.

Has anyone experienced this before? These are gen 1 heads btw.

I had been procrastinating on this for a while but I I got nailed by laser the other day. Coincidentally, this was the first time I've been hit with laser in the last 2 years that I've had these installed :eek:'

Edit: found a couple other posts about this so I messaged Jag about it
 
Last edited:

TurboDriver

One foot on the brake, one on the gas...
Premium Plus
Lifetime Premium
Advanced User
Joined
Sep 14, 2012
Messages
2,405
Reaction score
3,577
Location
Michigan
I see you found some info, so yes, it is a known Gen1 head issue. I have had this happen a couple times, you need to replace the head.
 

Vortex

Making Videos
Observer
VIP
Premium Plus
Lifetime Premium
Corgi Lovers
Advanced User
Joined
Jul 19, 2012
Messages
21,484
Reaction score
56,758
Location
Washington State
Interesting. Yeah I've had issues with my Gen 1 TMG as well. Luckily @Jag42 is available to help take care of you.
 

Discord Server

Latest threads

Latest posts

Forum statistics

Threads
93,178
Messages
1,420,624
Members
23,714
Latest member
BadBundy
Top