R7 Ka sensitivity after 1.33 firmware upgrade

Rammstein

Learning to Drive
General User
Joined
Feb 21, 2019
Messages
7
Reaction score
7
I upgraded my R7's firmware and while I love how much quieter it is for BSM, the sensitivity for Ka has also gone down significantly. Did anyone else experience that?

Message #general
 

DU5T3R

Learning to Fly
Beginner User
Joined
Jun 10, 2020
Messages
334
Reaction score
774
Location
NW Louisiana
I don't recall noticing any difference in Ka sensitivity after I upgraded to firmware 1.33.
 

Brainstorm69

TXCTG - 2016 MOTY
Premium Plus
Lifetime Premium
Advanced User
Joined
May 23, 2015
Messages
11,953
Reaction score
31,022
Location
Lone Star State
I upgraded my R7's firmware and while I love how much quieter it is for BSM, the sensitivity for Ka has also gone down significantly. Did anyone else experience that?

Message #general
What are you basing your statement on?

I'm not sure there's been a lot of testing specifically of 1.29 vs. 1.33, but here is some by @VariableWave and @Kennyc56 that seem to indicate perhaps the opposite, or least 1.33 isn't causing a Ka sensitivity problem.

 

Gabby

Learning to Drive
General User
Joined
Sep 20, 2020
Messages
33
Reaction score
55
Age
63
Location
Sask.
No change in Ka sensitivity noticed on my R7.
The biggest difference is the noticeable reduction to K band BSM and other false signals.
Just a thought, check to see if you accidentally enabled Ka filter?
 

G39x

Huntin' Rabbits
Intermediate User
Joined
Nov 1, 2016
Messages
764
Reaction score
942
Location
Nashville, TN
Only reduction lately I have noticed on my R7 is the lack of LEO activity in my instance. Otherwise, the sensitivity is great
 

RadarScout

Premium Plus
Lifetime Premium
Advanced User
Joined
Sep 4, 2015
Messages
7,005
Reaction score
12,202
Location
Land of Crimson Tide!
I upgraded my R7's firmware and while I love how much quieter it is for BSM, the sensitivity for Ka has also gone down significantly. Did anyone else experience that?

Message #general
I too like the newest update. I haven't noticed any reduction in Ka at all. Like @Gabby said, check your settings and make sure the Ka filter isn't turned on. Also, make sure you haven't adjusted you percentage down in Advanced mode.
 

Discord Server

Latest threads

Forum statistics

Threads
94,703
Messages
1,441,983
Members
24,248
Latest member
AvoidanceInGA
Top