New v1 gen2 button sticking?

kaotik78

PSL +5
Intermediate User
Joined
Nov 23, 2011
Messages
174
Reaction score
38
Location
New Hampshire
My v1 gen2 arrived yesterday and I took it out for a while and the only issue I noticed was the button sticks then slowly releases or pops back if I sometimes do not press it perfectly in the center.

Is this something that others have experienced. Not being picky cause of the loss of the old knob on the gen 1 but it doesn’t seem to work like it should.
 

Rags

Tumbleweed
Advanced User
Joined
Oct 26, 2011
Messages
2,117
Reaction score
1,897
My v1 gen2 arrived yesterday and I took it out for a while and the only issue I noticed was the button sticks then slowly releases or pops back if I sometimes do not press it perfectly in the center.

Is this something that others have experienced. Not being picky cause of the loss of the old knob on the gen 1 but it doesn’t seem to work like it should.
This is definitely not normal. I would call them up and ask them if they can fix it for you. I am sure they will take care of it.
 

benzr

Been there done that !! Original V1 user !!
Advanced User
Joined
Apr 23, 2012
Messages
6,020
Reaction score
8,381
Location
FLA
Shouldn't do that at All.

My guess is they assembler assembled a little too hasty. If you have the EXACT screwdriver
Search here RDF for type snd size.
You can carefully disassemble the unit (4 screws) are more carefully reassemble.
NOTE This will invalidate your warranty if tampering is evident !!!! 🤬🤬🤬🤬🤬

SOME PEOPLE have taken a black sharpie to the screws inside the torx indent to make the
The crews look OEM again.

I DO NOT REVOMMEND OR CONDONE this action if chosen.

It is this, live w it, or back to mothership it goes.

B
 

OBeerWANKenobi

This is not the car you're looking for......
ModSec
VIP
Premium Plus
Lifetime Premium
Corgi Lovers
Advanced User
Joined
Mar 20, 2018
Messages
7,617
Reaction score
22,977
Location
Outer Rim - Hiding from 35.5 I/O
My v1 gen2 arrived yesterday and I took it out for a while and the only issue I noticed was the button sticks then slowly releases or pops back if I sometimes do not press it perfectly in the center.

Is this something that others have experienced. Not being picky cause of the loss of the old knob on the gen 1 but it doesn’t seem to work like it should.
If you are talking about the main power button, this was been reported here before by one or two users on the very early units. IIRC, @Vortex had this issue initially and it was the faceplate being slightly off-center to the button that caused it. Check and see if your faceplate in the cutout area for the button is interfering.

In any case, if it keep happening, call VR and let them know. They'll most likely send you a return label and tend to take care of these issues very quickly.
 

NorEaster18

Bad Actor / Difficult RDF Member
Premium Plus
Advanced User
Joined
Sep 5, 2018
Messages
2,220
Reaction score
6,407
Location
The North Shore
Mine was a little sticky when it first arrived (about a month ago), but seemed to loosen up as I've been using the detector. I don't notice it anymore. If it continues, I would call them up.
 

kaotik78

PSL +5
Intermediate User
Joined
Nov 23, 2011
Messages
174
Reaction score
38
Location
New Hampshire
I tried to upload a video but was mobile so here is a snippet of what is happening. Uploading from an iPhone here doesn’t have the right extension apparently. Here’s a link I uploaded to if anyone wants to see.

 

kaotik78

PSL +5
Intermediate User
Joined
Nov 23, 2011
Messages
174
Reaction score
38
Location
New Hampshire
If you are talking about the main power button, this was been reported here before by one or two users on the very early units. IIRC, @Vortex had this issue initially and it was the faceplate being slightly off-center to the button that caused it. Check and see if your faceplate in the cutout area for the button is interfering.

In any case, if it keep happening, call VR and let them know. They'll most likely send you a return label and tend to take care of these issues very quickly.
I rang up Valentine today and they are sending a return label for the unit.

The faceplate did seem to not be 100% lined up with the button but the tolerance for that is like ( let me get my magnifying glass )! It honestly seems like the button itself is just sticky and not rubbing or getting hung up on anything.

I miss my V1 gen 1 already :) j/k
 

kaotik78

PSL +5
Intermediate User
Joined
Nov 23, 2011
Messages
174
Reaction score
38
Location
New Hampshire
So from talking with one of the techs today at Valentine One I found out that the display sits a bit higher than the button and causes the sticking. They said they could try to get it to work a little better and send it back to me. Also make sure you write a note when you ship your unit back for the tech to know what to troubleshoot. They don't internally link any service calls to shipping ID's or tracking numbers. Just hope it helps someone else if they get a stuck button and have to return for service.
 
Last edited:

SwankPeRFection

Corgi Lovers
Beginner User
Joined
Mar 31, 2020
Messages
1,606
Reaction score
1,701
So from talking with one of the techs today at Valentine One I found out that the display sits a bit higher than the button and causes the sticking. They said they could try to get it to work a little better and send it back to me. Also make sure you write a note when you ship your unit back for the tech to know what to troubleshoot. They don't internally link any service calls to shipping ID's or tracking numbers. Just hope it helps someone else if they get a stuck button and have to return for service.
Wow, Mike really needs to fix that shit. Would make such a difference to have an internal system to see what’s been done with a customer before someone sends the unit in and also all documented issues. How do these people function with such bad disconnects between depts? 🤦‍♂️
 

kaotik78

PSL +5
Intermediate User
Joined
Nov 23, 2011
Messages
174
Reaction score
38
Location
New Hampshire
I'll admit I was taken aback when I got the call from the tech asking me what problem was with the unit as there was no note provided in the return. Still, they reached out quickly rather than push it off to the side and moving on. The part about "trying" to get it to work a little better, did give me pause.

While many would say it's easy to create a basic database and ticketing system, thinking about it a bit more, a small shop like Valentine Research may not see the need for such a system, while others do.

It certainly would make their techs jobs a bit easier I would imagine. As during my call I did ask about any access to customer calls or notes but was told that the techs were not allowed access to customer database records.

Honestly I'm happy they got back to me so fast, as I have dealt with larger companies that have a ticket system in place and everything is logged and it makes it a tad harder to figure out what's going on or even to talk to a human being, engineer or not :)
 

LouG

PSL +5
Intermediate User
Joined
Jan 2, 2014
Messages
4,962
Reaction score
7,603
Based on several reports from people that returned early Gen 2's and had very rapid turn around, I'd say VR's system works and works well.
 

SwankPeRFection

Corgi Lovers
Beginner User
Joined
Mar 31, 2020
Messages
1,606
Reaction score
1,701
It certainly would make their techs jobs a bit easier I would imagine. As during my call I did ask about any access to customer calls or notes but was told that the techs were not allowed access to customer database records.
🤣 Either Mike has serious trust issues or this is just a bad joke wrapped in ridiculousness. Seriously... they’ll have you write down your CC# on a paper form that you send in with an upgrade but restrict this access? 🙄

Glad you got your NEW detector fixed but it was still ridiculous to have to run into it. QC still seems to be missing things.
 

Discord Server

Latest threads

Latest posts

Forum statistics

Threads
92,266
Messages
1,406,164
Members
23,420
Latest member
BuckmanNZ
Top