4.1021 Now Available

midd

Premium Plus
Lifetime Premium
Advanced User
Joined
Sep 18, 2011
Messages
2,818
Reaction score
2,388
Location
First and First, the Nexus of the Universe
I am experiencing the same thing. This afternoon I came to the Jersey shore and it was non-stop K band/BSM falsing with various cars. Never had this issue with last update (I was actually glad with the occasional chirp.) I am actually regretting updating to this version as it won't shut up. Very frustrated here in NJ. Any help would be appreciated. I am an "A" full time all the time guy as NJ has all bands. Thanks in advance!
@outbackray74 I'm from the same area as you. I updated mine but haven't seen anything that you have experienced. I'll be on 55 tomorrow and will let you know.
 

MarvC

Learning to Fly
Beginner User
Joined
Mar 10, 2018
Messages
103
Reaction score
319
This is driving me absolutely crazy....Before the update a quiet detector. now BSM K band alarms sometimes 10 at a time,
I'm not in a congested city just moderate traffic, I never had issues in the same locations at the same times prior to this update. I've checked and rechecked setup, nothing has changed from the previous settings. Don't know whats going on.
 
Last edited:

IcePick74

Learning to Fly
Premium Plus
Lifetime Premium
Beginner User
Joined
Oct 20, 2017
Messages
98
Reaction score
143
I am experiencing the same thing. This afternoon I came to the Jersey shore and it was non-stop K band/BSM falsing with various cars. Never had this issue with last update (I was actually glad with the occasional chirp.) I am actually regretting updating to this version as it won't shut up. Very frustrated here in NJ. Any help would be appreciated. I am an "A" full time all the time guy as NJ has all bands. Thanks in advance!
I had a BSM burst after passing a Honda minivan, I dont recall that happening before the update.
 

Vortex

Making Videos
Observer
VIP
Premium Plus
Lifetime Premium
Corgi Lovers
Advanced User
Joined
Jul 19, 2012
Messages
21,333
Reaction score
55,805
Location
Washington State
Interesting... I took it for a spin earlier today too and got a few Honda BSM's as well, more than usual. I figured it was because I was running in l instead of L, that I hadn't run the V1 Gen2 in 2-3 weeks and so I wasn't as familiar with it, or maybe just luck of the draw, but it seemed chattier to me too. Maybe coincidental, but maybe not if several of us are reporting that?
 

Kennyc56

Ford Lover-I/O hater!
Premium Plus
Lifetime Premium
Advanced User
Joined
Feb 22, 2018
Messages
4,934
Reaction score
17,394
Location
I/O Hell, Aka Eastern N.C.
This is very strange! What you guys are describing is just like what happens when I try mine with K verifier off, although I know you all say it's still on. I always run A mode and I go past the same K falses everyday with no lockouts and it acted exactly like it does every day with no more falses or BSM's than ever. I also wonder why the update turned X band back on for me but not for most of you, not that it matters just wondering why.
 

beanland

Learning to Drive
General User
Joined
Oct 25, 2020
Messages
20
Reaction score
14
I know this update is suppose to fix the Bluetooth disconnect and power flicker. I take the same 3 hour drive every Friday and my Bluetooth would lose connection 3 to 5 times during this period. The display would also flicker. I took the same drive today after the update and mine still lost connection 1 time. Just something to watch to see if it’s completely fixed.
 

Deadhead1971

Rock, rock, roll, Plymouth Rock, rollover
Advanced User
Joined
Dec 7, 2014
Messages
4,427
Reaction score
8,972
Location
Central NC
The update is broke for me also. I'm getting flooded with K signals also at times.

Update took about 25 minutes for me.
I would try a few things

- try switching K verifyer OFF and let the profile reset and then go back and flip it back ON
- go to profiles and then select “factory default” and let it set and then go back and reload your profile

ill keep an eye out this weekend on the road
 

westwind77

Premium Plus
Lifetime Premium
Advanced User
Joined
Dec 7, 2016
Messages
3,294
Reaction score
7,038
Is there a way to factory reset these? I could not find it anywhere.
 

Brainstorm69

TXCTG - 2016 MOTY
Premium Plus
Lifetime Premium
Advanced User
Joined
May 23, 2015
Messages
11,654
Reaction score
29,518
Location
Lone Star State
Is there a way to factory reset these? I could not find it anywhere.
If you want to do it without an app, see below. Note you will need to start with step C.

1605321931876.png
 

cihkal

Let there be light!
Premium Plus
Lifetime Premium
Corgi Lovers
Advanced User
Joined
Apr 21, 2014
Messages
4,339
Reaction score
8,466
Had a nice Ka showing today in what I would say is a cluster of a driving setting! Traffic and a lot of noise I'm sure, but it was being filtered out. Driving up through the West Loop on 90, before you go underneath Halsted, I pick up one Ka signal. Shortly after, another!

The Priority signal is weak starting at one bar, but I now notice the V1 ramp-up appears a little tweaked. It seems a bit less dampened... could just be me. So anyway, the second signal goes away, and eventually comes back. I get closer and closer to the first source which is a LEO, with a customer, on the side of the highway.

Ouch! I was happy to learn though, that the ramp-up remains linear and informative! You can tell based on the ramp-up if you're getting painted by the radar gun, and also of course which direction it's facing. In this case, the LEO was shooting rearward.

The next source was a little ways up, also with a customer! Damn! This LEO had his radar gun facing forward.

This was the first time I was absolutely stunned by the G2 on Ka, knowing the second LEO was also picked up near where I first got a whiff of Ka!!! Both LEOs were right around 34.7, which is common for my routes.

No funny business with Ka and no memory clears thus far. Just giving my recent experience!

Edit: I drive with the factory default settings and was using the V1 Connecton app to monitor things.
 
Last edited:

Deadhead1971

Rock, rock, roll, Plymouth Rock, rollover
Advanced User
Joined
Dec 7, 2014
Messages
4,427
Reaction score
8,972
Location
Central NC
I know this update is suppose to fix the Bluetooth disconnect and power flicker. I take the same 3 hour drive every Friday and my Bluetooth would lose connection 3 to 5 times during this period. The display would also flicker. I took the same drive today after the update and mine still lost connection 1 time. Just something to watch to see if it’s completely fixed.
Mine “clicked and flicked” with both 4.1018 and 4.1019. It did it a lot.:) I won’t have to wait long to find out if things are improved. 4.1021 has only been out 1 day. I would need several days to maybe a week before coming to any conclusions. There have been times when I’ve been in the perfect BSM storm - Arcadias, town n’ country, Lincolns all at one time, and the CX-5s. I will be interested in hearing more from those reporting issues today as the days go on- to see if today was a chance, random fluke.
 

Rags

Tumbleweed
Advanced User
Joined
Oct 26, 2011
Messages
2,117
Reaction score
1,899
Mine has been very quiet, the power issue appears resolved, certain BSM would cause it that now don't. I have over 17 hours of running this 7 of which were in heavy metro traffic.

I do get a double bogey count with instant on at times, though.
 

HamSolo

Learning to Fly
Beginner User
Joined
May 5, 2019
Messages
539
Reaction score
863
Location
Chicago, Illinois
Stumbled across the new update for the V1G2 with the V1 connection app.

Fixes are:

"Power flicker "and Bluetooth disconnect issue is fixed.

Ka instant on ramp up is fixed.

Incorrect J out of Ka signals is fixed.

Muting issues with accessories is fixed.

High bogey counts with single Ka sources is fixed.

Ku muting and unmuting is improved.
Just updated mine as well, and it only took roughly 10 minutes. So far the detector is acting better, no more high bogey counts when it detects KA, and the ramp ups for Ka are spot on. Thanks again for bringing this update to my attention, as it really made a major noticeable difference.
 

Discord Server

Latest threads

Forum statistics

Threads
92,296
Messages
1,406,741
Members
23,427
Latest member
Grandy745
Top