Escort Redline 360C (RL360C) Open Issues and Feature Requests

jestric

Go Gators!
Premium Plus
Intermediate User
Joined
Sep 4, 2020
Messages
2,531
Reaction score
9,646
Location
Florida
RDF Escort RD360C owners, I'll start the ball rolling on a separate thread that deals exclusively with open issues and feature requests for the RL360C. This thread will be managed by @croup (who graciously volunteered his time) and it should be a real help to @JSherbondy and others at Cedar Electronics/Escort as well.

To start off @croup has mentioned the following as suggested topics and known issues (and I slightly edited/refined 2. a)):

1. Mechanical problems (hardware related)
2. Possible firmware fixes to known issues (examples below)
a) Improved responsiveness and reactivity to quick trigger shots
b) Better K band ramp up
c) Fixing MRCD detection


@spanky also mentioned:

1. Better arrow response. The arrows seem to become confused /overloaded at times
2. Quicker response to I/O radar of Ka and K band..


I know there are many others with concerns, please weigh in with any mechanical problems (hardware related) or any issues or additional feature requests that could be addressed through possible firmware fixes to make the RL360C an even better RD.

Finally, remember that this is not a thread to bash Escort or complain about customer service. Let's all work to keep it on topic.

Thank you and let the discussions begin!
 

sdrawkcaB

Defender of Light 📶
ModSec
VIP
Premium Plus
Lifetime Premium
Corgi Lovers
Advanced User
Joined
Mar 6, 2018
Messages
6,921
Reaction score
15,904
Location
Here
FYI if you intend to keep post #1 updated, you'll have to do it as croup won't be able to edit your post.
 

OBeerWANKenobi

This is not the car you're looking for......
ModSec
VIP
Premium Plus
Lifetime Premium
Corgi Lovers
Advanced User
Joined
Mar 20, 2018
Messages
8,103
Reaction score
25,160
Location
Outer Rim - Hiding from 35.5 I/O
FYI if you intend to keep post #1 updated, you'll have to do it as croup won't be able to edit your post.
Neither will @jestric after any amount of time which is why I was asking for Advanced volunteers to make the open issues thread.

@croup if you actually are volunteering to do this let us know and we'll get things straightened out for you. @jestric can definately help keep you up to date in your thread.
 

JumpTiger

Learning to Drive
General User
Joined
Mar 2, 2020
Messages
8
Reaction score
3
I found that the iOS EL app may not connect to my RL360c successfully some times. I had to terminate and re-launch the app in order to get the Bluetooth connecting to the RL360c. I have noticed the Bluetooth may connect to other devices with higher priority than the RL360c has, so that no remembered devices on my iPhone 11 besides my watch and the RL360c. It doesn't matter if the app already working in the background prior to the RL360c power-up, or I just launch the app while RL360c powered up already.
I'm not quite sure if this is an issue that only associates with RL360c or it's something that has to be solved on the app side. I just kindly leave it here, and hopefully, you and your team can handle it or transfer it to the appropriate team.

Thanks,
JumpTiger
 

westwind77

Premium Plus
Lifetime Premium
Advanced User
Joined
Dec 7, 2016
Messages
3,536
Reaction score
8,028
I found that the iOS EL app may not connect to my RL360c successfully some times. I had to terminate and re-launch the app in order to get the Bluetooth connecting to the RL360c. I have noticed the Bluetooth may connect to other devices with higher priority than the RL360c has, so that no remembered devices on my iPhone 11 besides my watch and the RL360c. It doesn't matter if the app already working in the background prior to the RL360c power-up, or I just launch the app while RL360c powered up already.
I'm not quite sure if this is an issue that only associates with RL360c or it's something that has to be solved on the app side. I just kindly leave it here, and hopefully, you and your team can handle it or transfer it to the appropriate team.

Thanks,
JumpTiger
I have noticed when my tries to connect the BT symbol on the app flashing irradicably and it take a fair bit for it to finally connect. When using the M360 it connects quickly with none of the issues mentioned above. (iPhone 1 Pro iOS 14.0.1 & 14.1)
 

jestric

Go Gators!
Premium Plus
Intermediate User
Joined
Sep 4, 2020
Messages
2,531
Reaction score
9,646
Location
Florida
Here's a quick shout-out to see if there is any Advanced User who would like to take on the role of managing this (or a new) Escort RL360C thread to capture open issues and feature requests for the RL360C.
 

jestric

Go Gators!
Premium Plus
Intermediate User
Joined
Sep 4, 2020
Messages
2,531
Reaction score
9,646
Location
Florida
Cedar Electronics released firmware 1.6 today. However, one of the great takeaways for me was that they want us to keep the feedback coming.

Per @JSherbondy, they really do want to keep hearing from us! If you have feedback or suggestions on how to make the Redline 360c even better, please don't hesitate to send an email to [email protected]
 

L4D44

Learning to Fly
Beginner User
Joined
Dec 15, 2012
Messages
897
Reaction score
2,472
Here's a quick shout-out to see if there is any Advanced User who would like to take on the role of managing this (or a new) Escort RL360C thread to capture open issues and feature requests for the RL360C.
While I’m no admin and unsure of the requirements to move up in ranking - but I think you should definitely be bumped up in the “advanced” tier. You’re a great, knowledgeable RDF member who contributes daily to this community in the rather short time you’ve been registered.

Thanks for creating this thread! 👍
 

jestric

Go Gators!
Premium Plus
Intermediate User
Joined
Sep 4, 2020
Messages
2,531
Reaction score
9,646
Location
Florida
Thank you @L4D44. I am sincerely humbled by your post.

I'm content to just follow the requirements that the community has layed out and promote when (and if) they ever deem it appropriate. Like everyone else, I really admire the "family" that we have here on RDF and enjoy being able to contribute in some small way.

On a related note, I read in another thread that @OBeerWANKenobi said that whenever anyone said someone should be promoted it delays it for one year. ;) :eek:

Thank you again my friend for the kind words.
 
Last edited:

Karston

Learning to Drive
General User
Joined
Oct 28, 2020
Messages
29
Reaction score
54
Location
Plano, TX
Just updated my RL360c to 1.6 and now my unit is not turning on.

Verified the power cord is functional.
Re attempted the software update 2x.

Unit is not powering on. I'm very upset.
 

L4D44

Learning to Fly
Beginner User
Joined
Dec 15, 2012
Messages
897
Reaction score
2,472
Just updated my RL360c to 1.6 and now my unit is not turning on.

Verified the power cord is functional.
Re attempted the software update 2x.

Unit is not powering on. I'm very upset.
(800) 543-1608

Option 2 (customer service) when promoted. Sorry to hear that.
 

jestric

Go Gators!
Premium Plus
Intermediate User
Joined
Sep 4, 2020
Messages
2,531
Reaction score
9,646
Location
Florida
Just updated my RL360c to 1.6 and now my unit is not turning on.

Verified the power cord is functional.
Re attempted the software update 2x.

Unit is not powering on. I'm very upset.

Did you verify that you're getting power to the power connection jack?
 

Karston

Learning to Drive
General User
Joined
Oct 28, 2020
Messages
29
Reaction score
54
Location
Plano, TX

BMBSALES

Learning to Drive
General User
Joined
Jan 20, 2021
Messages
31
Reaction score
38
other than what's already listed, i can't believe more people aren't talking about BSM filtering. that is by far my biggest complaint, before the 1.6 update. going to drive it some and see if there's a change
 

Karston

Learning to Drive
General User
Joined
Oct 28, 2020
Messages
29
Reaction score
54
Location
Plano, TX
other than what's already listed, i can't believe more people aren't talking about BSM filtering. that is by far my biggest complaint, before the 1.6 update. going to drive it some and see if there's a change
My BSM filtering on 1.4 was amazing. All K band segments
Auto loK
K notch on.

I live in an area where most of the cars are new and have BSM, and it very rarely falsed. It did happen on occasion when the signal was full tilt but that’s to be expected.
 

BMBSALES

Learning to Drive
General User
Joined
Jan 20, 2021
Messages
31
Reaction score
38
My BSM filtering on 1.4 was amazing. All K band segments
Auto loK
K notch on.

I live in an area where most of the cars are new and have BSM, and it very rarely falsed. It did happen on occasion when the signal was full tilt but that’s to be expected.
yeah...i'm quiet in auto lowK as well, but not nearly so in auto. still alot of K around me, so i hate to reduce it like that.
 

02Crewman

Learning to Drive
General User
Joined
Jan 5, 2021
Messages
45
Reaction score
116
I utilized the e-mail address to notify them of the issues that a few people are seeing with the Ka falses on the Max 3. I didn't notice that it said RL360c issues until after I sent it, but Ka falses on a Max 3 is technically an issue with the RL360c as they will pollute Escort Live and cause false reporting to RL360c users running the app.

Here is the thread that details the detector apparently falsing on signals that it may be producing. https://www.rdforum.org/threads/106768/
 

Discord Server

Latest threads

Forum statistics

Threads
94,718
Messages
1,442,348
Members
24,254
Latest member
garlandbob
Top