Escort RL 360 repaired - Need someone to read attached repair report...

cruiser66

PSL +5
Intermediate User
Joined
Jun 14, 2011
Messages
418
Reaction score
483
I got my Redline 360c back from repair today for my KA falsing issue (great turnaround).
It says 'reported issue': 'FKA, CU'. I guess FKA is for falsing Ka, but I am not sure what the 'CU' means.

Some questions:
1) I am trying to read the repair note handwriting (see photo below)... : It says "Tightened antenna _ _ _ _ _ _ _ hardware, updated software."
I am trying to figure out the word after "antenna" and before "hardware"? Anyone have any idea?

2) I wonder if "updated software" means they reinstalled the 1.4 firmware OR if they just updated the Defender DB (I had not updated the Defender DB).
I assume it means the former?
I had already updated to v1.4 (via wifi) before sending it in...

3) (Not sure what the 'S', 'D' and 'R' mean.
The S (service???) portion which is followed by 'FKA' above the line and 'SW' below line might be falsing KA and software respectively.
Not sure about the D and R... Any ideas?
RL360c repair.jpg
 
Last edited:

RoadDogg

Advanced User
Lifetime Premium Member
Joined
May 10, 2018
Messages
1,092
Reaction score
3,389
Location
Tennessee
@cruiser66 , is that the only form they sent back with your RL360c? All three services for my Max360c, they sent the Escort Customer Repair Information Report with the handwritten notes in the middle, and the first two services (pre Covid 19) they also sent a type written Customer Repair Report. This last trip to the service department, I didn’t get the type written report.

I think the word is casting. I think it says tightened antenna casting hardware. All three of my trips for my Max360c included the sleeping issue, and trip number two also included increased laser falsing and increased Ka falsing but they mistakenly indicated I was complaining about increased K band falsing which I was not.

Trip number 1 included “repairing antenna” and trip number 2 included “tightening of antenna casting screws” according to the report. I thought I would share that. Trip number two didn’t improve the Ka false alarms.

I have to segment my Max360c to significantly reduce the Ka false alarms. I cannot run all Ka segments on the Max360c without quite a bit of Ka falsing. I used to just use 2,5,8, but I have turned on 4 and 6 too, and I have not had any Ka false alarms.

Good luck, and I hope Escort fixed the problems that you were experiencing. Keep us updated.


Sent from my iPhone using Tapatalk
 
Last edited:

cruiser66

PSL +5
Intermediate User
Joined
Jun 14, 2011
Messages
418
Reaction score
483
@cruiser66 , is that the only form they sent back with your RL360c? All three services for my Max360c, they sent the Escort Customer Repair Information Report with the handwritten notes in the middle, and the first two services (pre Covid 19) they also sent a type written Customer Repair Report. This last trip to the service department, I didn’t get the type written report.

I think the word is casting. I think it says tightened antenna casting hardware. All three of my trips for my Max360c included the sleeping issue, and trip number two also included increased laser falsing and increased Ka falsing but they mistakenly indicated I was complaining about increased K band falsing which I was not.

Trip number 1 included “repairing antenna” and trip number 2 included “tightening of antenna casting screws” according to the report. I thought I would share that. Trip number two didn’t improve the Ka false alarms.

I have to segment my Max360c to significantly reduce the Ka false alarms. I cannot run all Ka segments on the Max360c without quite a bit of Ka falsing. I used to just use 2,5,8, but I have turned on 4 and 6 too, and I have not had any Ka false alarms.

Good luck, and I hope Escort fixed the problems that you were experiencing. Keep us updated.


Sent from my iPhone using Tapatalk

Thanks a lot RoadDogg regarding it being "casting"!

To answer your question regarding my RL360c repair:
The one with handwritten notes I shared is the only form, other than an invoice-like printed form (with my address, date and service order # etc.), without any specific notes about the repair - I did not receive any typewritten 'customer repair report'.

Side note - I also did not get a new lens or accessories (recall I had gotten a new power cord in the past, I believe, when my Max was "repaired" for either the lock-up issue and / or for Ka performance). Will have to dig up old PMs from years ago). I do recall that I did a "hot one" on Ka per Larry.

Back to my Redline 360c:
Thanks for the info re. your Max 360c Ka falsing. What did trip #3 do? (You gave details about trip #1 and #2 and about trip #2 not helping the Ka falsing). I am asking because it looks like even trip #3 did not help and you had to segment it to get it to stop?

On those of my Escort detectors (in my signature) that support it, I already use Ka segments 2/4/5/6/8 only. With my Redline 360c the Ka falsing was occurring with it segmented.
Anyway, I am taking some time off this week (good timing) and will see how my 'repaired' Redline 360c does during some long drives; fingers crossed that the issue is resolved now.
Thanks again for the wishes and info! Good luck with your Max 360c.

I will keep everyone posted; perhaps / hopefully my experience / findings will help others who have been experiencing Ka falsing with their RL 360c detectors...

Similar post and fix below from another RL 360c owner (he had to get four RL 360c repairs before the falsing was finally resolved!! Unlucky...
I am hoping my ONE repair is enough in my case... However, I did not have the "re-solder connections" though that the poster had happen.
 
Last edited:

RoadDogg

Advanced User
Lifetime Premium Member
Joined
May 10, 2018
Messages
1,092
Reaction score
3,389
Location
Tennessee
On repair the recent repair #3, @Cruiser 66, I wasn’t having the Ka false issue on this last service repair (primarily because I had Ka segmented to 2,5,8), but when it was repaired, they updated the firmware to 1.12 from 1.11, and they replaced the circuit board. They also indicated plastic repair on the written note, but I have no idea what that was.

I had sent it in again for the sleeping issue. Fortunately the sleeping issue was not as frequent as before with only one known sleeping issue in 2020. I thought everything was fixed on the second service, but I had an incident in May of 2020.

I waited until August to send it in to see if it would sleep again, but it didn’t. I plan on selling it soon as I plan on buying another detector, so I wanted Escort to examine it again because the Escort Service Plan will not transfer to the new owner.

When I got it back this time, all of Ka was on, so I segmented it to 2,4,5,6,8 this time, and I haven’t had any problems with Ka false alarms. Hopefully your one service repair on your RL360c will resolve the issues you were having. It looks like you have already segmented your RL360c on Ka, so hopefully Escort service fixed the the Ka false alarm issue.


Sent from my iPhone using Tapatalk
 
Last edited:

cruiser66

PSL +5
Intermediate User
Joined
Jun 14, 2011
Messages
418
Reaction score
483
Bad news: The Ka falsing issue is still there even after the 'repair'. :(

I posted in Gail's thread to ask her what can be done under the circumstances:
 
Last edited:

fishing66

Advanced User
Joined
Sep 1, 2012
Messages
3,788
Reaction score
6,657
Bad news: The Ka falsing issue is still there even after the 'repair'. :(

I posted in Gail's thread to ask her what can be done under the circumstances:

Sorry to hear of this. Not sure if it has been asked before, however, possible that your phone or vehicle are causing the Ka falsing? Have you used the detector in another vehicle without your phone?
 

cruiser66

PSL +5
Intermediate User
Joined
Jun 14, 2011
Messages
418
Reaction score
483
Sorry to hear of this. Not sure if it has been asked before, however, possible that your phone or vehicle are causing the Ka falsing? Have you used the detector in another vehicle without your phone?

Thanks!
I had already thought about that interestingly, but it cant be the phones since we never had any off frequency Ka falses for the first 6 drives (entire first month of ownership) and we always had the same cell phones with us.
It did start on the 2nd drive after installing firmware 1.4 and see a lot of Ka falsing reports by other owners since 1.4 came out, but since it appears many are not impacted, it appears to either be a hardware issue (fingers crossed) or only occurs under very specific circumstances...

Hopefully Gail can help get me a new detector since I am not confident of sending it in for 'repair' again given that the first repair did nothing to address the issue, which cost me both time (no detector during that time) and money (shipping to them); while the latter was not a lot, I still want to avoid paying for it again since the issue was not fixed the first time.
We also passed a LEO just pulling someone over on the highway and the detector stayed silent (not the first time).
 

mtime

Learning to Drive
General User
Joined
Jul 20, 2020
Messages
43
Reaction score
61
I had this issue with my first R360c and it was within the 30 day window, so I Immediately replaced it with a different unit, which has worked fine. By chance ...are you still in the 30 day window? If so, you can return/replace it. If it were me, I would not wait for a reply from Gail but instead contact Escort CS on the phone and tell them their repair has not worked and you want a different unit.
 

cruiser66

PSL +5
Intermediate User
Joined
Jun 14, 2011
Messages
418
Reaction score
483
I had this issue with my first R360c and it was within the 30 day window, so I Immediately replaced it with a different unit, which has worked fine. By chance ...are you still in the 30 day window? If so, you can return/replace it. If it were me, I would not wait for a reply from Gail but instead contact Escort CS on the phone and tell them their repair has not worked and you want a different unit.

Thanks. I am beyond the 30 day mark. The Ka falsing started ~ a few days after the 30 day mark, but at that time I was not sure if it was an issue with the 1.4 firmware which I had installed shortly before it started.
Customer support is helping to now resolve the issue based on an exchange with them today. So that is great news...
 

cruiser66

PSL +5
Intermediate User
Joined
Jun 14, 2011
Messages
418
Reaction score
483
I received a replacement Redline 360c today (long story how it came so quickly).

Anyway, I will put the new R360c through its paces tomorrow and confirm the Ka falsing is, hopefully, now gone.
In the meantime, the rep who has been helping me throughout this has been great and always very quick to respond!
 
Last edited:

jestric

Learning to Fly
Beginner User
Joined
Sep 4, 2020
Messages
392
Reaction score
662
Location
Florida
I received a replacement Redline 360c today (long story how it came so quickly).

Anyway, I will put the new R360c through its paces tomorrow and confirm the Ka falsing is, hopefully, now gone.
In the meantime, the rep who has been helping me throughout this has been great and always very quick to respond!

That's great news on both accounts! Here's hoping your issues are a thing of the past.
 

mtime

Learning to Drive
General User
Joined
Jul 20, 2020
Messages
43
Reaction score
61
Thanks. I am beyond the 30 day mark. The Ka falsing started ~ a few days after the 30 day mark, but at that time I was not sure if it was an issue with the 1.4 firmware which I had installed shortly before it started.
Customer support is helping to now resolve the issue based on an exchange with them today. So that is great news...
Glad things worked out and Escort was able to get you a replacement R360c. Hopefully you will have solid replacement. It did take a while for my replacement to settle down (I wish marked locations could once again be transferred)....but give it a little time; I've been pleased with my replacement
 

cruiser66

PSL +5
Intermediate User
Joined
Jun 14, 2011
Messages
418
Reaction score
483
That's great news on both accounts! Here's hoping your issues are a thing of the past.
Glad things worked out and Escort was able to get you a replacement R360c. Hopefully you will have solid replacement. It did take a while for my replacement to settle down (I wish marked locations could once again be transferred)....but give it a little time; I've been pleased with my replacement

Thanks guys!
Well, only a short drive so far today with my new (replacement( Redline 360c) to pick up some groceries curbside.
The good news is my detector picked up two confirmed LEOs running Stalker radar guns (both LEOs sighted) despite it being a short drive - 34.709 and 34.728.
No Ka falses so far, knock on wood.
My old one also started fine (for first month), but at least we're off to a great start!
(The old one did not even seem to be picking up real radar anymore).

One K band false got locked out which was a bit odd since it was my first time in that location.

Will post more after the drive on 287 coming up shortly... That will be the true test.
 
Last edited:

HZ360C

Learning to Fly
Beginner User
Joined
Feb 19, 2020
Messages
174
Reaction score
285
Same here. My second RL360c had some strange K/Ka false, especially in rear. I called and got my replacement out yesterday and be delivering next Monday. My first RL360c has been rock solid in terms of performance. My experiences with CS has been nothing but present. Recent calls to CS had been right into the queue. I have also noticed the pre recorded message has changed to normal as well. Definitely some positive changes and improvements.
 

HZ360C

Learning to Fly
Beginner User
Joined
Feb 19, 2020
Messages
174
Reaction score
285
Same here. My second RL360c had some strange K/Ka false, especially in rear. I called and got my replacement out yesterday and be delivering next Monday. My first RL360c has been rock solid in terms of performance. My experiences with CS has been nothing but present. Recent calls to CS had been right into the queue. I have also noticed the pre recorded message has changed to normal as well. Definitely some positive changes and improvements.
Surprisingly, the replacement showed up today :cool:
 

cruiser66

PSL +5
Intermediate User
Joined
Jun 14, 2011
Messages
418
Reaction score
483
Well, the good news is that the replacement RL360c worked great, picking up 3 additional LEOs on Ka 34.7 during the drives this afternoon, including NJ 287.
Today's 5 Ka alerts, all actual police radar signals:
34.709
34.728
34.729
34.730
34.732

However, I cannot, yet at least, rule software out as a cause of the Ka falsing issue with my prior RL 360c since the new detector came with firmware version 1.3... My last one started having the falsing issues suddenly after one month, on the 2nd drive after upgrading to firmware v1.4...

Given this, I may stick with 1.3 for a while since I will not be able to downgrade to 1.3 if I upgrade to 1.4 and the constant Ka falsing issues start to occur with the new RL 360c as well...
 

HZ360C

Learning to Fly
Beginner User
Joined
Feb 19, 2020
Messages
174
Reaction score
285
Well, the good news is that the replacement RL360c worked great, picking up 3 additional LEOs on Ka 34.7 during the drives this afternoon, including NJ 287.
Today's 5 Ka alerts, all actual police radar signals:
34.709
34.728
34.729
34.730
34.732

However, I cannot, yet at least, rule software out as a cause of the Ka falsing issue with my prior RL 360c since the new detector came with firmware version 1.3... My last one started having the falsing issues suddenly after one month, on the 2nd drive after upgrading to firmware v1.4...

Given this, I may stick with 1.3 for a while since I will not be able to downgrade to 1.3 if I upgrade to 1.4 and the constant Ka falsing issues start to occur with the new RL 360c as well...
Did your replacement come with 1.3 firmware? My new order and replacement are all come with 1.4
 

cruiser66

PSL +5
Intermediate User
Joined
Jun 14, 2011
Messages
418
Reaction score
483
Did your replacement come with 1.3 firmware? My new order and replacement are all come with 1.4
Yes, as mentioned above, the replacement came with 1.3 and, to be safe, I will probably leave it on 1.3 for a little while at least.
Like my original one, the replacement is brand new (came in the usual shrink-wrapped box); the date code is 3420 (manufactured between Aug 17 and 23).
 

tbny025

Learning to Drive
General User
Joined
Jul 12, 2020
Messages
14
Reaction score
35
Yeah, just stick with 1.3 until new firmware release. To be safe, don't hurry to update new firmware when it becomes available. I would recommend you to wait a few more days to see if anyone report any kind of issues with new firmware update. I think your first detector KA false issues maybe hardware related. My RL360c performs very well with v1.4 update. It does not have any KA or laser false issues. When it kick off a KA signal, it always a real legitimate police radar source. The two minor issues for my detector are arrows still have slightly lagging response when passing Leo source(s) and slightly lagging reactivity. I believe these two issues will get fixed with the next firmware update
 

Discord Server

Latest threads

Forum statistics

Threads
89,905
Messages
1,367,344
Members
22,611
Latest member
i90don90
Top