Dropping Android 4.4 support

ferius

More arrows please
Premium Plus
Lifetime Premium
Advanced User
Software Developer
Joined
Jan 27, 2019
Messages
519
Reaction score
1,984
Location
Seattle area, WA
The title explains everything. Starting from v2.4.3, the minimum required Android version for running Highway Radar is Android 5.0.

Supporting Android 4.4 was quite a hassle for me starting from the beginning of Highway Radar. HTTPS security issues, lack of vector graphics support, lack of cool APIs, and so on. By this time, I did my best to ensure that Highway Radar works well with that old version -- some features were stripped out based on version, some had different behavior on older Android. However, the amount of work required to support these versions was only growing. Almost every new feature I try to implement faces some challenges because of continuing Android 4.4 support. I made a decision that I don't want to spend my time on this anymore.

Android 5.0 was released six years ago. Also, for many old phones, there are unofficial builds of new Android firmwares. Currently, Google Play reports only 12 installations on devices running Android 4.4.

I believe that if I drop the Android 4.4 support, I'll be able to spend less time on new features, which means more new features get released. In my opinion, this is quite a reasonable tradeoff.
 
Last edited:

NVR2FST

Premium Plus
Lifetime Premium
Advanced User
Joined
Aug 1, 2011
Messages
1,666
Reaction score
1,504
Location
Somewhere in cyberspace.
Just curious, will older builds of HwR be available for download for those few people running old phones?
 

ferius

More arrows please
Premium Plus
Lifetime Premium
Advanced User
Software Developer
Joined
Jan 27, 2019
Messages
519
Reaction score
1,984
Location
Seattle area, WA
Just curious, will older builds of HwR be available for download for those few people running old phones?

I think I'll be a able to publish an APK for the last supported version here. However, it will start loosing features soon. The first will be aircraft alerting - I'm expecting to shut down the old server by the end of this year (check https://www.rdforum.org/threads/104787/ for details on then new aircraft server). Also, if I decide to switch heat map, road graph, risk scores, or camera internal protocols, they'll also soon become unavailable on old versions. So, despite the version will remain usable, the amount of available features may start reducing over time.
 

mswlogo

Software Developer
Premium Plus
Lifetime Premium
Advanced User
Software Developer
Joined
Nov 1, 2014
Messages
4,106
Reaction score
4,380
Location
MA
I think I'll be a able to publish an APK for the last supported version here. However, it will start loosing features soon. The first will be aircraft alerting - I'm expecting to shut down the old server by the end of this year (check https://www.rdforum.org/threads/104787/ for details on then new aircraft server). Also, if I decide to switch heat map, road graph, risk scores, or camera internal protocols, they'll also soon become unavailable on old versions. So, despite the version will remain usable, the amount of available features may start reducing over time.
It should be automatic that they will only (and continue to) see the last supported build for their version of Android.
 

Discord Server

Latest threads

Latest posts

Forum statistics

Threads
90,145
Messages
1,371,505
Members
22,684
Latest member
hugolau1
Top