A129 Pro Duo Quality Control Questions

2018GTI

PSL +5
Intermediate User
Joined
Oct 29, 2018
Messages
842
Reaction score
855
Location
Oregon
I purchased this thing about two months ago and had it hardwired in. It worked fine for a while, then got inconsistent or buggy in my opinion. It would not record on multiple occasions, the screen would freeze on, wifi would not work, the big yellow triangle with with an exclamation point appeared once and took over the screen. I reformatted multiple times, and reset numerous times. Then, resetting would not get the unit working either. The retailer suggested (and I did) updating the firmware--no difference, and questioned the SD card(Samsung 256), and then suggested it is a power problem. So, I powered via cig lighter adapter and the unit still misbehaved. I hooked the hardwire back up and the unit works fine for now, except the wifi function is gone. After 18 back and forth emails, 2 phone calls and basically a charge back threat, the retailer approved a warranty for the front camera. I have 30 days to act.

My question is, on a $200 piece of consumer electronics, is the replacement gonna work any better? Some members have mentioned low quality control on inexpensive dash cams.

Thanks in advance for your thoughts!
 

InsipidMonkey

Essential Monkey
Security
Corgi Lovers
Advanced User
Premium Member
Joined
Mar 22, 2017
Messages
7,994
Reaction score
18,390
Location
New England
I've had no issues with mine. Try reaching out to Viofo support if you still have issues, they were very helpful and responsive when I had trouble with my A119 microphone.
 

Maz3

Don't hate me just because I'm beautiful 🤣
Beginner User
Joined
Oct 25, 2014
Messages
429
Reaction score
720
Location
Vancouver, BC
Mine has been fine as well. I know @Jdem is running run the same one too, so perhaps he'll chime in on his experiences.
 

Trinity

Learning to Fly
Beginner User
Joined
Sep 10, 2019
Messages
347
Reaction score
589
I would try another sd card first. If the problem follows onto your new camera with the old sd card then get a new sd card for sure.



I had a few issue of mine turning itself off on very hot days when I was trying to use wifi while parked. The camera was super hot. I disabled wifi and still had issues with it turning off that same hot day while driving.

I also have times when it's not even powered on with the car and I notice it while driving and have to manually boot it.

Yea I think it can be buggy at times, but it's been good lately.
 
Last edited:

2018GTI

PSL +5
Intermediate User
Joined
Oct 29, 2018
Messages
842
Reaction score
855
Location
Oregon
Thank you, sounds about like mine! I sent a message to Viofo, I may just return through them. Otherwise, I have to send it to Canada via UPS on my dime.
 

Jdem

PSL +5
Intermediate User
Joined
Jan 8, 2017
Messages
372
Reaction score
597
Location
Vancouver, British Columbia
No issues with mine, have been running it for many months with a good quality 256gb card.
 

Discord Server

Latest threads

Forum statistics

Threads
89,061
Messages
1,354,687
Members
22,422
Latest member
Gabby
Top