BSM spike after reinstall 1.3 on R360c?

F15

No radar/lidar tickets, 25+ years
Premium Plus
Lifetime Premium
Advanced User
Joined
Sep 18, 2011
Messages
1,456
Reaction score
606
During my initial use of the R360c (i.e. 2 weeks ago), I thought it did very well in terms of rejecting BSMs.
However, I have noticed a significant difference since reinstalling 1.3. The R360c came with 1.3, but I read a thread where a reinstall might improve some minor issue that I no longer remember.
My settings (starting with Vortex profile) are the same including K Notch. My reaction is from both driving around the local metro, but also logging 600 miles on the open road.
Is it good/bad to reinstall 1.3 again? I hesitate to send it in as I am not sure how that impacts the 30 day return policy. On the other hand, I start 3K driving miles in three weeks.
I have tested the R360c in my wife's car where it is the only CM while in mine I also run the V1G2 which has a much better record regarding BSM issues than the R360c at this point. BTW, the first version of my R360c beat the V1G2 on Ka alerts. For now, this version of the R360c reminds me of my R7 on terms of BSM chatter.
How might I unpack whatever is in play? Do I surrender the R360c now and hope that next firmware for the R7 will carry me through 6 states next month?
 

samq45

Premium Plus
Lifetime Premium
Advanced User
Joined
Jul 5, 2011
Messages
1,979
Reaction score
3,419
Location
Saratoga, NY
I had a similar issue where my first load on 1.3 the BSMs seemed worse and the reactivity was not good.

After Reloading the software, it was very quiet and the reactivity was a lot better. After I enabled the K notch it really quieted it down on the Hondas.

I am sort of on the fence for which detector is quieter at the moment - V1G2 or RL360C. They are both very close and I drove over 600 miles last week splitting the duty between the 2 and I has 2 BSM falses on both of them, so either choice works for BSMs.

I hope it is not bad to reinstall firmware, I have done it quite a bit on the Uniden and Escort Detectors. When I had a problem with sleeping on the Escorts, I probably reloaded the software 10 times each on the GT360 and EX.
 

poolmon

Premium Plus
Lifetime Premium
Advanced User
Joined
Oct 26, 2013
Messages
1,321
Reaction score
2,637
Others have reported that doing a factory reset after an update might help operations.
 

F15

No radar/lidar tickets, 25+ years
Premium Plus
Lifetime Premium
Advanced User
Joined
Sep 18, 2011
Messages
1,456
Reaction score
606
Just to clarify these two posts. It is okay to do a second reinstall of 1.3, but then do a factor reset of the detector?
 

poolmon

Premium Plus
Lifetime Premium
Advanced User
Joined
Oct 26, 2013
Messages
1,321
Reaction score
2,637
If it does not seem to be working as well as it was, and you are considering sending it in to be looked at, if it were me I'd perform an Update All Software under the Device Tab using DT Pro, then power it up to complete the install, then turn it off and restart to perform a factory reset to see if it helps. If not, then I'd consider sending it in. Traditionally factory resets are not necessary with Escort RD updates but some report that doing so cleared up issues they had.
 
Last edited:

Discord Server

Latest threads

Latest posts

Forum statistics

Threads
94,763
Messages
1,442,943
Members
24,268
Latest member
Kidnapper49
Top