R360C - no bluetooth pairing with iP11 Pro

F15

No radar/lidar tickets, 25+ years
Advanced User
Premium Member
Joined
Sep 18, 2011
Messages
1,389
Reaction score
535
I just received the R360c this morning. I wanted to use EL to customize my settings.
However, I could not get a BT connection to work with my iP11 Pro

IMG_6136.PNG
. See the image below.
I know there are many other threads here about other Escort devices, but did not see one specific to the R360c.
I saw one post that said to disconnect other BT connections so would that mean my car, my Oura ring, and my iW?
 

HZ360C

Learning to Fly
Beginner User
Joined
Feb 19, 2020
Messages
92
Reaction score
157
You need to go to iPhone settings, under Privacy setting to enable EL to use Bluetooth. From your screen shoot, your EL is disabled for using Bluetooth.
 

F15

No radar/lidar tickets, 25+ years
Advanced User
Premium Member
Joined
Sep 18, 2011
Messages
1,389
Reaction score
535
You need to go to iPhone settings, under Privacy setting to enable EL to use Bluetooth. From your screen shoot, your EL is disabled for using Bluetooth.
Thanks, that should do it.
I thought I had used EL on this phone with my 360c with driving my wife's car. The only difference with the R360c is that I had to create a new EL account to link to the R360c.
 

A Dee

Learning to Fly
Beginner User
Joined
Mar 1, 2018
Messages
107
Reaction score
175
I haven't been able to connect with WiFi. I switched off the 5g on router and it still won't pair. I guess I have to create a new account, RL 360c.
 

HZ360C

Learning to Fly
Beginner User
Joined
Feb 19, 2020
Messages
92
Reaction score
157
Unless RL360c had something so special, would require a new account in order to either pair Bluetooth or connecting with Wi-Fi, I have no issues to pair multiple Max360c with my iPhone XS, now have any issue to connect Wi-Fi (I am using a Verizon MiFi hotspot device).

if you are using the similar MiFi device to connect your RL360c, make sure that you didn’t exceed your MiFi connection limits. Most of those mobile MiFi can only accept either 5 or 10 Connected devices. If have have multiple phones or other portable devices in the car, you may also want to check that. Just look at your hotspot to see how many devices are active. You already eliminated 5GHz issue, just to make sure the 2.4GHz is working properly.
 

SoulPatch

Learning to Fly
Beginner User
Joined
Jun 23, 2020
Messages
65
Reaction score
86
I haven't been able to connect with WiFi. I switched off the 5g on router and it still won't pair. I guess I have to create a new account, RL 360c.
This was addressed in an earlier thread. I'm searching for it. I'll help you look for it.
Post automatically merged:

I haven't been able to connect with WiFi. I switched off the 5g on router and it still won't pair. I guess I have to create a new account, RL 360c.
Try this. I can't take credit for the original post.

As Vortex mentioned in the other R360c new firmware thread, the iOS version of Escort Live didn't connect to the R360c after updating its firmware to Version 1.3. jdong suggested deleting the iOS Bluetooth pairing for the R360c in iOS settings. I tried that, and the app correctly connects to the R360c now.
 
Last edited:

A Dee

Learning to Fly
Beginner User
Joined
Mar 1, 2018
Messages
107
Reaction score
175
When I pulled into driveway this morning. The detector asked to update even though it always failed to connect to my home WiFi. I remember this happened with my Max 360c. Strange..
 

F15

No radar/lidar tickets, 25+ years
Advanced User
Premium Member
Joined
Sep 18, 2011
Messages
1,389
Reaction score
535
When I pulled into driveway this morning. The detector asked to update even though it always failed to connect to my home WiFi. I remember this happened with my Max 360c. Strange..
Could you unpack this for me? What do you mean by "update"? Did you not already have 1.3?
Did you still have 5g disabled on your router?
I have two Wifis on my home network, but EL will only try to connect to the one that is 5g.
 

jfr0317

PSL +5
Intermediate User
Premium Member
Joined
May 10, 2011
Messages
339
Reaction score
709
Location
Houston
Could you unpack this for me? What do you mean by "update"? Did you not already have 1.3?
Did you still have 5g disabled on your router?
I have two Wifis on my home network, but EL will only try to connect to the one that is 5g.
When my R360c was on Firmware Version 1.2, I could connect to both my home wifi network and in-car hotspot after having once connected using Escort Live from my phone on a given wifi network. After the update to 1.3, I can only connect to the last network I had connected to. To connect to a different one, I have to go into my phone's settings and forget the R360c bluetooth and into Escort Live to forget the R360c. After that, I can go through the initial conection process for a different network.

As to updates, Escort Live does a relight camera, speed camera, etc. database update weekly, so that's probably the update he saw.
 

F15

No radar/lidar tickets, 25+ years
Advanced User
Premium Member
Joined
Sep 18, 2011
Messages
1,389
Reaction score
535
Thanks. Is it the case that the R360c will not connect to 5G?
I do not want to disable 5g on my router, but apparently the iOS EL app will not give me a choice on my home network. I suppose I could connect to my office Wifi, but I am starting driving trips next week and would prefer to manage things when I am home.
 

jfr0317

PSL +5
Intermediate User
Premium Member
Joined
May 10, 2011
Messages
339
Reaction score
709
Location
Houston
Thanks. Is it the case that the R360c will not connect to 5G?
I do not want to disable 5g on my router, but apparently the iOS EL app will not give me a choice on my home network. I suppose I could connect to my office Wifi, but I am starting driving trips next week and would prefer to manage things when I am home.
The R360c is only capable of connecting on a 2.4 GHz wifi network.
Post automatically merged:

What's happening is that your phone is connecting to the 5 GHz portion of your home network which I assume has both 5 GHz and 2.4 GHz available on the same SSID (the name that shows up for your wifi network). I have separate SSID's for 2.4 GHz and for 5 GHz, so I put my phone on the 2.4 GHz network and connect to Escort Live. The phone running Escort Live and the R360c need to both be on the same 2.4 GHz network.

Hope this helps.
 
Last edited:

A Dee

Learning to Fly
Beginner User
Joined
Mar 1, 2018
Messages
107
Reaction score
175
Could you unpack this for me? What do you mean by "update"? Did you not already have 1.3?
Did you still have 5g disabled on your router?
I have two Wifis on my home network, but EL will only try to connect to the one that is 5g.
I had 1.3 already. It updated 2 of 2 then rebooted so I assume it was data base updates. I'm stayed on the 2.4 band of my router. So maybe leaving and coming home triggered it to connect.
 

SoulPatch

Learning to Fly
Beginner User
Joined
Jun 23, 2020
Messages
65
Reaction score
86
I had 1.3 already. It updated 2 of 2 then rebooted so I assume it was data base updates. I'm stayed on the 2.4 band of my router. So maybe leaving and coming home triggered it to connect.
So, your good now?👍🏻
 

F15

No radar/lidar tickets, 25+ years
Advanced User
Premium Member
Joined
Sep 18, 2011
Messages
1,389
Reaction score
535
The R360c is only capable of connecting on a 2.4 GHz wifi network.
Post automatically merged:

What's happening is that your phone is connecting to the 5 GHz portion of your home network which I assume has both 5 GHz and 2.4 GHz available on the same SSID (the name that shows up for your wifi network). I have separate SSID's for 2.4 GHz and for 5 GHz, so I put my phone on the 2.4 GHz network and connect to Escort Live. The phone running Escort Live and the R360c need to both be on the same 2.4 GHz network.

Hope this helps.
I have separate SSIDs for 5 ghz and 2.4 ghz so I will go at this again when I return home from work today. Thank you.
 

SoulPatch

Learning to Fly
Beginner User
Joined
Jun 23, 2020
Messages
65
Reaction score
86
I have separate SSIDs for 5 ghz and 2.4 ghz so I will go at this again when I return home from work today. Thank you.
Seems like your going in the right direction. Enjoy your ride to work with R360c. It make for a boring riding companion, it doesn't say much. Which is a good thing 🤔
 

HZ360C

Learning to Fly
Beginner User
Joined
Feb 19, 2020
Messages
92
Reaction score
157
There are lots of confusion in today’s ”wireless” world when dealing with the “connection”. In this case, Let’s make sure that we all standing on the same ground point in order to gain better success for helping each other. For any “c” series Escort radar detectors, Max 360C, RL360C, for Detector itself, there are two connections available to use: Bluetooth and Wi-Fi, and BOTH DOES NOT have to be connected at same time!

Here are some key points to understand and remember in order to utilize those feature successfully:

1. Bluetooth is REQUIRED for configure your detector to be connected to a Wi-Fi network, as well as provide a easy way for detector setting/configuration. If you choose not to using Wi-Fi function, you will need the Bluetooth connection for all the EL function to get community based alerts, as well as the visual display on the EL maps and alerts on the phone. And Bluetooth connection has nothing to do with your Wi-Fi connection after configuration.

2. If you have configured Wi-Fi for your detector, and such Wi-Fi connectivity is always available while traveling (mobile hotspot or in-car Wi-Fi spot), you do not need to connect phone with Bluetooth in order to get community based alerts, the EL will be running on the detector via wifi, the community based alerts will be displayed on the detector. such as “live Ka in 2000 ft.” Etc. Wi-Fi connection will also provide the firmware and database update on the fly. But you always have the option to run the update via computer.

3. Detector Wi-Fi connectivity is limited to 2.4GHz network, in which has nothing to do with how your phone is connected, either 2.4GHz or 5GHz. The only requirement during the configuration is: your phone needs to be on the same network that you wanted for your detector. For most of users, 2.4GHz and 5GHz often share the same network name (SSID) by default to provide stable coverage for various devices and situations. Unless you have separate SSIDs for your network setup, then you need to make sure that your phone needs to be on the 2.4GHz network before configuring your detector’s Wi-Fi.

With those basic points in mind before you dive into the “connectivity” configuration, you will be getting much better and successful results.

Hope that helps and without creating more confusions.
 

jfr0317

PSL +5
Intermediate User
Premium Member
Joined
May 10, 2011
Messages
339
Reaction score
709
Location
Houston
That's interesting to know about how the phone can be connected via 5 GHz as long as the 5 GHz and 2.4 GHz are on the same SSID. I was unaware of that since my home network uses separate SSID's for each band. Thanks for pointing that out.
 

HZ360C

Learning to Fly
Beginner User
Joined
Feb 19, 2020
Messages
92
Reaction score
157
That's interesting to know about how the phone can be connected via 5 GHz as long as the 5 GHz and 2.4 GHz are on the same SSID. I was unaware of that since my home network uses separate SSID's for each band. Thanks for pointing that out.
The wifi configuration tool in EL only pass the current hone connected Wi-Fi network SSID to the detector, and detector completes the setup include the authentication (where you supplied passcode). Therefore, as long as the 2.4/5GHz uses same SSID, each devices (phone and detector) will connect with their respective band. For phone, especially iPhone, it will always pick the best connection either 5 or 2.4, while detector will only connect with 2.4. There is NO network traffics between detector other than Bluetooth if you so choose.
 

jfr0317

PSL +5
Intermediate User
Premium Member
Joined
May 10, 2011
Messages
339
Reaction score
709
Location
Houston
The wifi configuration tool in EL only pass the current hone connected Wi-Fi network SSID to the detector, and detector completes the setup include the authentication (where you supplied passcode). Therefore, as long as the 2.4/5GHz uses same SSID, each devices (phone and detector) will connect with their respective band. For phone, especially iPhone, it will always pick the best connection either 5 or 2.4, while detector will only connect with 2.4. There is NO network traffics between detector other than Bluetooth if you so choose.
Thanks. Let me ask you a different but somewhat related question. I have a wifi hotspot in two different cars. What is the best way to get the R360c to connect to the wifi hotspot of one car after having it set up and connecting to the other car? I can't change the SSID and password to match on either car.
 

HZ360C

Learning to Fly
Beginner User
Joined
Feb 19, 2020
Messages
92
Reaction score
157
If those are car built in hotspots? Most ones will allow you to customize the WiFi name and password to make it same. That you will be move from one to another without reconfigure. You may want to reference the owners manual for the limitation on change hotspot names.
 

Discord Server

Latest threads

Latest posts

Forum statistics

Threads
87,796
Messages
1,335,686
Members
22,112
Latest member
jreihsen
Top