Redline Software 360C Software Update 1.3 Is Available For Download

Cedar Electronics CTO

Manufacturer
General User
Manufacturer
Joined
Jun 11, 2020
Messages
6
Reaction score
104
All,

The latest version of Redline 360C software is now available for download. The release was slightly delayed by a few hours to test a bug fix that Vortex found when connecting to the Escort Live app that affected band segment settings. This should be corrected in this version.

Please provide any feedback to jSherbondy or myself.

Thanks for your patience.

John
 

Vortex

Making Videos
Observer
VIP
Premium Plus
Lifetime Premium
Corgi Lovers
Advanced User
Joined
Jul 19, 2012
Messages
21,478
Reaction score
56,699
Location
Washington State
Awesome, thank you! Time to go test. :)

What does the new K Notch setting do?
 

Rags

Tumbleweed
Advanced User
Joined
Oct 26, 2011
Messages
2,150
Reaction score
1,992
I bet it's a notch filter to filter out a known pesky BSM :)
Post automatically merged:

All,

The latest version of Redline 360C software is now available for download. The release was slightly delayed by a few hours to test a bug fix that Vortex found when connecting to the Escort Live app that affected band segment settings. This should be corrected in this version.

Please provide any feedback to jSherbondy or myself.

Thanks for your patience.

John
Great response time, I am impressed that you were able to so quickly identify the issue Vortex was seeing and implement it. If this works as expected and advertised, you will have earned a lot of respect.
 

Ram3

Learning to Fly
Beginner User
Joined
Jul 20, 2017
Messages
170
Reaction score
281
Vortex test results please! I am willing to repurchase again if it beats R7 performance.
 

Vortex

Making Videos
Observer
VIP
Premium Plus
Lifetime Premium
Corgi Lovers
Advanced User
Joined
Jul 19, 2012
Messages
21,478
Reaction score
56,699
Location
Washington State
hm, are you guys able to connect to Escort Live with your iPhone after the update? I'm unable to connect with my iPhone, even after deleting the detector in the app and trying to reconnect from scratch. It can see the detector when I try and recreate the connection, but it disappears from the app shortly after I try to connect and I never see a BT or PSL icon on the detector.

I am able to connect on Android, but it took longer than usual to create the connection initially. (and yeah, I fully disconnected and killed EL on Android, even shutting the phone off altogether, before trying to connect on iOS.) It seems no amount of power cycling the detector or iOS app resolves the issue. The iOS app even sometimes get stuck on the device list while looking for new detectors.

Oh well, off to go test the arrows and stuff.
 

jfr0317

PSL +5
Premium Plus
Lifetime Premium
Intermediate User
Joined
May 10, 2011
Messages
473
Reaction score
1,132
Location
Houston
hm, are you guys able to connect to Escort Live with your iPhone after the update? I'm unable to connect with my iPhone, even after deleting the detector in the app and trying to reconnect from scratch. It can see the detector when I try and recreate the connection, but it disappears from the app shortly after I try to connect and I never see a BT or PSL icon on the detector.

I am able to connect on Android, but it took longer than usual to create the connection initially. (and yeah, I fully disconnected and killed EL on Android, even shutting the phone off altogether, before trying to connect on iOS.) It seems no amount of power cycling the detector or iOS app resolves the issue. The iOS app even sometimes get stuck on the device list while looking for new detectors.

Oh well, off to go test the arrows and stuff.
Same for me - connected on Android. I then turned off the Android phone, power-cycled the R360c, and tried the iOS Escort Live app. It wouldn't connect. I tried deleting the device (R360c), and that didn't work either.
 

jdong

Premium Plus
Lifetime Premium
Advanced User
Joined
Jun 5, 2013
Messages
7,438
Reaction score
11,542
hm, are you guys able to connect to Escort Live with your iPhone after the update? I'm unable to connect with my iPhone, even after deleting the detector in the app and trying to reconnect from scratch. It can see the detector when I try and recreate the connection, but it disappears from the app shortly after I try to connect and I never see a BT or PSL icon on the detector.

I am able to connect on Android, but it took longer than usual to create the connection initially. (and yeah, I fully disconnected and killed EL on Android, even shutting the phone off altogether, before trying to connect on iOS.) It seems no amount of power cycling the detector or iOS app resolves the issue. The iOS app even sometimes get stuck on the device list while looking for new detectors.

Oh well, off to go test the arrows and stuff.

Just a blind guess, but have you tried going into your Bluetooth settings in iOS and forgetting the detector from there, and then going back into the app to pair it?

I had similar issues after flashing the bluetooth module on my MaxCi. It doesn't seem like the Escort Live app actually forgets pairings when you remove the detector from the app.
 

jfr0317

PSL +5
Premium Plus
Lifetime Premium
Intermediate User
Joined
May 10, 2011
Messages
473
Reaction score
1,132
Location
Houston
Just a blind guess, but have you tried going into your Bluetooth settings in iOS and forgetting the detector from there, and then going back into the app to pair it?

I had similar issues after flashing the bluetooth module on my MaxCi. It doesn't seem like the Escort Live app actually forgets pairings when you remove the detector from the app.
Just did as you suggested, and it now works! Thanks for the tip!!
 

Brazenbuck

Learning to Drive
General User
Joined
Jul 7, 2020
Messages
2
Reaction score
2
hm, are you guys able to connect to Escort Live with your iPhone after the update? I'm unable to connect with my iPhone, even after deleting the detector in the app and trying to reconnect from scratch. It can see the detector when I try and recreate the connection, but it disappears from the app shortly after I try to connect and I never see a BT or PSL icon on the detector.

I am able to connect on Android, but it took longer than usual to create the connection initially. (and yeah, I fully disconnected and killed EL on Android, even shutting the phone off altogether, before trying to connect on iOS.) It seems no amount of power cycling the detector or iOS app resolves the issue. The iOS app even sometimes get stuck on the device list while looking for new detectors.

Oh well, off to go test the arrows and stuff.

My device wouldn't connect to the iOS app after the firmware update. Following steps resolved the issue.

  • Removed device from list in iOS app
  • Shut down iOS app
  • Removed detector - phone BT pairing
  • Restarted iOS app
  • Re-paired detector
 

GoHawks63

Learning to Fly
Beginner User
Joined
Jan 11, 2014
Messages
82
Reaction score
119
I had to run an errand and drove by a speed cam in my sub that hadn't yet been stored. I saw good transition of the arrows as I drove by it.

Didn't encounter any LEOs in order to get range.

No issues connecting to EL from my iPhone (iPhone 11 Pro Max).
 

redhead2015

Learning to Fly
Premium Plus
Lifetime Premium
Beginner User
Joined
Apr 14, 2015
Messages
593
Reaction score
227
I wanted to know if you have to reset anything after doing update? I didn't see factory reset. I also like to know if it's better to run ka on and not do a seg 2,5,8? Can I please ask what k notch is I have off. Is anyone turning k band off and running bands 1,2,3 only 4 off?
 

L4D44

Learning to Fly
Beginner User
Joined
Dec 15, 2012
Messages
890
Reaction score
2,416
I wanted to know if you have to reset anything after doing update? I didn't see factory reset. I also like to know if it's better to run ka on and not do a seg 2,5,8? Can I please ask what k notch is I have off. Is anyone turning k band off and running bands 1,2,3 only 4 off?

It’s always recommended to FACTORY RESET after a firmware update and set up from scratch.
 

redhead2015

Learning to Fly
Premium Plus
Lifetime Premium
Beginner User
Joined
Apr 14, 2015
Messages
593
Reaction score
227
Do you know where to find that?
 

searay

Learning to Fly
Beginner User
Joined
Aug 8, 2013
Messages
132
Reaction score
324
I wanted to know if you have to reset anything after doing update? I didn't see factory reset. I also like to know if it's better to run ka on and not do a seg 2,5,8? Can I please ask what k notch is I have off. Is anyone turning k band off and running bands 1,2,3 only 4 off?

I am running Ka off with only 2,5,8 on and K band off with only 1,2,3 on and it's a very quiet ride!
 

redhead2015

Learning to Fly
Premium Plus
Lifetime Premium
Beginner User
Joined
Apr 14, 2015
Messages
593
Reaction score
227
Did you do factory reset after update? If so where is this located? What's k band notoch
 

redhead2015

Learning to Fly
Premium Plus
Lifetime Premium
Beginner User
Joined
Apr 14, 2015
Messages
593
Reaction score
227
thanks
Post automatically merged:

Did anyone turn on k band notch on? Is this safe to run?
 

Discord Server

Latest threads

Latest posts

Forum statistics

Threads
93,113
Messages
1,419,712
Members
23,698
Latest member
Extract0r
Top