Sleep issue Max360

Michael Smith

4Rings
Beginner User
Joined
Sep 1, 2018
Messages
61
Reaction score
69
I don't know if this is the so called sleep issue, but I have contacted Amazon to return this. I have had this for over 8 weeks and I have yet to see a ramp up of Ka when I pass a Ka source.
I have passed local LEO that my former Radenso alerted to and this has been silent. Just finished a road trip from Illinois into Wisconsin and passed both Illinois State sitting in the middle and one Wisconsin sitting in the middle, no alerts again. Today was the last one that convinced me this is not working, I had a red charger on my left and a BMW in front of me at a red light, the goes green, they both take off quickly but not racing each other, the charger judging by my following speed was up to about 55 mph when he hit the brakes, the Beamer kept going them a LEO came out of nowhere to get behind the BMW and pull him over. My Escort did not do a thing, I believe the charger was either alerted himself or saw the cop but I believe if no radar was present from the LEO he had no reason other than suspicion of speeding from the BMW. That mage me realize I cannot recall a single alert from KA with a slow steady ramp up yet from this thing, any KA I get pops out of nowhere one or two beeps then disappears.
 

Bocephus

Advanced User
Lifetime Premium Member
Joined
Apr 19, 2018
Messages
3,027
Reaction score
5,393
Location
FL
Sorry to hear that. Did you happen to do a system reset (don't quote me on the terminology)?
 

Michael Smith

4Rings
Beginner User
Joined
Sep 1, 2018
Messages
61
Reaction score
69
Sorry to hear that. Did you happen to do a system reset (don't quote me on the terminology)?
Other than powering up and powering down and the typical updates in my driveway from the wifi, It seems like it is normal operation but I think this is defective and I've been very lucky to say the least that I drive agressively with a heavy foot.
 

OBeerWANKenobi

This is not the car you're looking for.....
Moderator
Advanced User
Lifetime Premium Member
Joined
Mar 20, 2018
Messages
4,728
Reaction score
12,777
Location
Outer Rim - Hiding from 35.5 I/O
It is possible that there is a problem, however, LEO's in the wild are a poor test due to tremendous inconsistency. More LEO's are NOT running radar than are. You really need to test with a known radar source, preferably a police-grade radar gun, but a local Walgreens door opener will at least let you know that K band is functioning.

For Ka band, there are quite a few members, probably even some in your area, that have radar guns and one of them may be willing to help you out to test your detector.
 

Trinity

Learning to Fly
Beginner User
Joined
Sep 10, 2019
Messages
118
Reaction score
143
Doesn't sound like a sleeping issue to me. Maybe defective if you actually had legit sources. I'm guessing you have the 360c model and not the original 360 Max since you updated using WiFi.

Are you returning it for a replacement or going a different route now?


The no alerts from the state troopers could be because there using laser gun and it's a very small chance your radar detector would pick up the laser gun.
 
Last edited:

westwind77

Advanced User
Lifetime Premium Member
Joined
Dec 7, 2016
Messages
2,664
Reaction score
4,824
Just because you pass LEO does not mean they are running radar. I passed 3 locals today and silence. On the highway last weekend there were a few in the middle, again, silence. It alerted a couple LEO's on the far side with customers and a couple BSM's so it was working fine. The last situation you mentioned the LEO could have been shooting laser as well, and you would not have gotten an alert.

Does the unit alert to the typical K band door openers?
 

Michael Smith

4Rings
Beginner User
Joined
Sep 1, 2018
Messages
61
Reaction score
69
Doesn't sound like a sleeping issue to me. Maybe defective if you actually had legit sources. I'm guessing you have the 360c model and not the original 360 Max since you updated using WiFi.

Are you returning it for a replacement or going a different route now?


The no alerts from the state troopers could be because there using laser gun and it's a very small chance your radar detector would pick up the laser gun.
I'm about 99 percent sure this is defective, been using detectors for years and this is my 4th escort, but it's been over 8 weeks and I think I've had one ramp up. I have past several known areas close to home where LEO sit and always got the same warning from my Radenso.
I contacted Amazon and they are great when it comes to returns, new one is arriving today and I hope all is well this time.
 

Trinity

Learning to Fly
Beginner User
Joined
Sep 10, 2019
Messages
118
Reaction score
143
I'm about 99 percent sure this is defective, been using detectors for years and this is my 4th escort, but it's been over 8 weeks and I think I've had one ramp up. I have past several known areas close to home where LEO sit and always got the same warning from my Radenso.
I contacted Amazon and they are great when it comes to returns, new one is arriving today and I hope all is well this time.
I believe you. My first newer "escort" dual horn product was a Cobra dual pro 360 from Amazon and it was defective. I know something was wrong since I, myself ran detectors for awhile also. Something was very fishy with it. I ended up sending it back and got my a legit new escort Max 360 and it's been the best detector I brought.

The Cobra dual pro is really a escort Max 360 re branded as a Cobra with a few changes so I still consider it a escort in disguise and many others do to.

Return it for another 360c. You'll be happy. Hopefully your second time around with the 360c is great. Good luck
 

Michael Smith

4Rings
Beginner User
Joined
Sep 1, 2018
Messages
61
Reaction score
69
Just because you pass LEO does not mean they are running radar. I passed 3 locals today and silence. On the highway last weekend there were a few in the middle, again, silence. It alerted a couple LEO's on the far side with customers and a couple BSM's so it was working fine. The last situation you mentioned the LEO could have been shooting laser as well, and you would not have gotten an alert.

Does the unit alert to the typical K band door openers?
Yes I was still getting typical K band but the locals I passed are in the same spot every morning and the Radenso alerted every time.
 

RoadDogg

PSL +5
Intermediate User
Lifetime Premium Member
Joined
May 10, 2018
Messages
738
Reaction score
1,886
Location
Tennessee
When my Max360c was occasionally sleeping, it would not respond at all to K-band or Ka-band. When I suspected it was sleeping, I would drive by 4 or 5 K-band door openers that normally trigger a K-band alert to see if it would respond, and I would use my Bushnell K-band gun when I would get home. When it was sleeping, it would be silent to all of the above. I ended up buying a Pocket Radar (K-band), and a Stalker ATR, and my Max360c wouldn’t respond to either on my last sleeping incident about 8-10 weeks ago until power cycled. My R3 responded with no problem to both that same day. I sent my Max360c to Escort for service right after Thanksgiving.

I also ended up buying a Kustom Signals Golden Eagle (35.5), and I bought a separate K-band antenna to use with the Golden Eagle.

I hope this replacement unit works well for you and solves the issues you are having. If the suspected issues continue with your replacement unit (hopefully they won’t), you may want to look on the RDF marketplace or EBay for a used police radar gun. You can often find them for a decent price, and having a radar gun may help provide verification on your detector’s performance.




Sent from my iPhone using Tapatalk
 
Last edited:

Kennyc56

Ford Lover-I/O hater!
Advanced User
Lifetime Premium Member
Joined
Feb 22, 2018
Messages
3,482
Reaction score
9,780
Location
I/O Hell, Aka Eastern N.C.
When my Max360c was occasionally sleeping, it would not respond at all to K-band or Ka-band. When I suspected it was sleeping, I would drive by 4 or 5 K-band door openers that normally trigger a K-band alert to see if it would respond, and I would use my Bushnell K-band gun when I would get home. When it was sleeping, it would be silent to all of the above. I ended up buying a Pocket Radar (K-band), and a Stalker ATR, and my Max360c wouldn’t respond to either on my last sleeping incident about 8-10 weeks ago until power cycled. My R3 responded with no problem to both that same day. I sent my Max360c to Escort for service right after Thanksgiving.

I also ended up buying a Kustom Signals Golden Eagle (35.5), and I bought a separate K-band antenna to use with the Golden Eagle.

I hope this replacement unit works well for you and solves the issues you are having. If the suspected issues continue with your replacement unit (hopefully they won’t), you may want to look on the RDF marketplace or EBay for a used police radar gun. You can often find them for a decent price, and having a radar gun may help provide verification on your detector’s performance.




Sent from my iPhone using Tapatalk
You will be very glad that you picked up the radar guns! I can't imagine not having mine!
 
Last edited:

Michael Smith

4Rings
Beginner User
Joined
Sep 1, 2018
Messages
61
Reaction score
69
I don't know if this is the so called sleep issue, but I have contacted Amazon to return this. I have had this for over 8 weeks and I have yet to see a ramp up of Ka when I pass a Ka source.
I have passed local LEO that my former Radenso alerted to and this has been silent. Just finished a road trip from Illinois into Wisconsin and passed both Illinois State sitting in the middle and one Wisconsin sitting in the middle, no alerts again. Today was the last one that convinced me this is not working, I had a red charger on my left and a BMW in front of me at a red light, the goes green, they both take off quickly but not racing each other, the charger judging by my following speed was up to about 55 mph when he hit the brakes, the Beamer kept going them a LEO came out of nowhere to get behind the BMW and pull him over. My Escort did not do a thing, I believe the charger was either alerted himself or saw the cop but I believe if no radar was present from the LEO he had no reason other than suspicion of speeding from the BMW. That mage me realize I cannot recall a single alert from KA with a slow steady ramp up yet from this thing, any KA I get pops out of nowhere one or two beeps then disappears.
Got the replacement detector lastnight and was able to get set up and run it today. I had the typical false alerts back and forth to work that the GPS will filter I'm sure, but I passed two different Leo's and the detector ramped up perfectly with plenty of warning, these are the same I see and pass everyday and could not understand why I was not getting alerts from the other.
Driving home at highway speed had another ramp up with a plain taurus on the side with a customer, and later on an avenue got a steady ramp up alert from a sheriff going over a good hill at that with plenty of warning.
I believe the other was defective and am pleased so far with the replacement, thanks all for the responses
 

InsipidMonkey

Essential Monkey
Moderator
Advanced User
Premium Member
Joined
Mar 22, 2017
Messages
6,832
Reaction score
15,242
Location
New England
Glad the new unit is working properly! It's a good thing you knew enough to realize the original unit was defective, as the average user may not have known anything was wrong. Hopefully Amazon returns it to Escort for service and doesn't just resell it as "Used - Like New".
 

Discord Server

Latest threads

Forum statistics

Threads
83,387
Messages
1,266,945
Members
21,050
Latest member
Freddy379
Top