Connected but not really

Deacon

TXCTG
Advanced User
Premium Member
Joined
Nov 13, 2016
Messages
10,032
Reaction score
12,222
Location
Hill Country, TX
I almost never have V1Driver in the foreground. It’s usually Waze or something else. One thing I’ve noticed is that sometimes I’ll get alerts on the V1 that I know should be a lockout, or a Ka alert with no frequency announcement, etc. If I open V1Driver, such as to look at the frequency, it shows connected and quiet even if the alert is still ongoing. A telltale sign is even though V1Driver is open, the V1 itself doesn’t go dark. The quick way to fix it is to tap the Bluetooth area to disable it and then again to re-enable it, and it connects, announces “V1Driver” and all is fine.

It doesn’t happen often enough for me to really track down the source of the behavior very well. The one working theory I have is the power and connection cycle that occurs when inserting the key and starting the engine that way, as the V1 power is supplied with the key in the On position, but then when pressing further into the Start position all accessory power is automatically cut by the vehicle for a moment during starter engagement to get the engine running before being restored. This is very anecdotal, but I often use the remote start function, where it’s already running when I turn the key to the On position and doesn’t need to go through the Start power cycle, and it seems like it don’t ever experience the issue when that happens.

I wish I had better info to provide, but for now this is what I’ve got.
 

mswlogo

Premium RDF Member
Advanced User
Premium Member
Joined
Nov 1, 2014
Messages
3,438
Reaction score
3,258
Location
MA
You are not alone on this and it seems to have crept in. I have seen it too. It happens so infrequently it's been really hard to track down.

Are you running the Beta? or App Store release?

I have not changed code in that area but updates on the compiler forces some code changes and iOS updates can change timing on some things such that it may have exposed a "race condition" in my code.

Believe me, I am aware of it. At least it "fails safe", in that you get alerted".
 

Deacon

TXCTG
Advanced User
Premium Member
Joined
Nov 13, 2016
Messages
10,032
Reaction score
12,222
Location
Hill Country, TX
Are you running the Beta? or App Store release?
On my phone I run the beta.

It’s been happening for a while, occasionally, but I’m not sure I could tell you the first time I happened to notice it, how far back it goes. Maybe just a few months.
 

Discord Server

Latest threads

Latest posts

Forum statistics

Threads
77,445
Messages
1,180,131
Members
19,821
Latest member
Fascarz
Top