FW 1.10 has been released for the Max360c

Bossdad71

Manufacturer
Advanced User
Premium Member
Manufacturer
Joined
Jul 11, 2016
Messages
7,251
Reaction score
10,105
Location
Kansas running with the pack
Awesome, thanks for the heads up. I'm noticing the update is available with Escort Detector tools, but not yet over WiFi. I'm sure that'll be coming soon too though. Hopefully this finally resolves the lockup/sleeping issues altogether. Fingers crossed!
my wifi caught it yesterday while i was doing some bench testing. good stuff
 

Tingtang

Learning to Drive
General User
Joined
May 13, 2019
Messages
16
Reaction score
13
Location
Colorado
I was having random falses prior to the update too. Turned out to be my phone. Havent had any since update. At least I think its latest fw. Forgot how to check fw version . But speed limit displays on both bluetooth AND wifi now.

FYI... If you update to 1.10 via the tools, you will be prompted via wi-fi to update again. Don't do it, as doing so will downgrade you to 1.9.

So if the detector updated over wifi, dont use detector tools because it will ask again over wifi and revert back?
 

DrHow

Going “Plaid” ASAP (Tesla S) RDT refugee
Advanced User
Lifetime Premium Member
Joined
May 18, 2018
Messages
2,314
Reaction score
3,642
I was having random falses prior to the update too. Turned out to be my phone. Havent had any since update. At least I think its latest fw. Forgot how to check fw version . But speed limit displays on both bluetooth AND wifi now.




So if the detector updated over wifi, dont use detector tools because it will ask again over wifi and revert back?
Other way around how I read that advice.
 

BagNDrag

PSL +5
Intermediate User
Lifetime Premium Member
Joined
Feb 22, 2012
Messages
400
Reaction score
705
I was having random falses prior to the update too. Turned out to be my phone. Havent had any since update. At least I think its latest fw. Forgot how to check fw version . But speed limit displays on both bluetooth AND wifi now.




So if the detector updated over wifi, dont use detector tools because it will ask again over wifi and revert back?
The problems I was seeing have gone away. You are good to update however you choose, WiFi or by the tools.

Hold down MRK and MUTE while you power up to see the version number.

-Mark
 

RoadDogg

PSL +5
Intermediate User
Lifetime Premium Member
Joined
May 10, 2018
Messages
506
Reaction score
1,077
Location
Tennessee
Just updated my Max 360c to ver 1.10 and within a 30 mile drive I received 4 laser alerts and one of them I was not even moving and my OSP read 80 mph. Is anyone else having any issues with Laser alerts? Btw I am not having any Bth or WiFi issues just laser alerts.
I actually did have one laser false alarm the day after updating to firmware 1.10, but I haven’t had any since then. I have probably driven about 600-700 miles while using my Max360c under this new firmware. I also have recently sent my unit into Escort for service. The laser false alarms have not been an issue for me lately since getting it back from Escort, but I was averaging about 1 laser false per day using the Max360c on firmware 1.9 prior to sending my unit in for the silent lock up/sleeping issue and increased laser false alarms.


Sent from my iPhone using Tapatalk
 

RaggedEdge

RDForum owner and Rdtalk.org Founder
Administrator
Advanced User
Lifetime Premium Member
Joined
Mar 26, 2018
Messages
1,252
Reaction score
2,913
Location
Middle Tennessee
I have the samsung s10.
Same here. I know the Samsung's can cause falsing issues, it did to my Pro M. I'll run the 360c with my Samsung turned off for a while to see how that impacts the laser falsing.
 

Bossdad71

Manufacturer
Advanced User
Premium Member
Manufacturer
Joined
Jul 11, 2016
Messages
7,251
Reaction score
10,105
Location
Kansas running with the pack
Same here. I know the Samsung's can cause falsing issues, it did to my Pro M. I'll run the 360c with my Samsung turned off for a while to see how that impacts the laser falsing.
i notice it when im on the phone. if the phone is within idk maybe a foot of it or so, even right under it, it falses the entire time im on it
 

AnthonyL

Learning to Drive
General User
Joined
Sep 4, 2019
Messages
17
Reaction score
36
Hi All,
Since FW 1.10 update on max 360c I am getting at least 3 laser false alerts within a 30 mile drive to and from work. Also starting to notice that if my iPhone opens up with Face ID or just gets a signal of an email or text it triggers the laser. The other day I started my vehicle and my phone connected to apple car play while my max 360c turned on and within a few seconds it triggered 3 false laser alerts back to back and I was not even in drive yet. Then nothing for at least 20 miles then again. Weird sometimes I get them a lot and sometimes I get one or two within my drive. Tomorrow I am going to put my phone down by the cup holders in my 2018 Chevy Silverado and see if it makes a difference. When I use my MB E-350 I barley get more than one. It sure if being hooked up to my iPhone cord plugged into my USB port in my truck maybe triggers it more. Can’t get my finger on it yet. Will keep posting after trying different things. Thanks
 

AnthonyL

Learning to Drive
General User
Joined
Sep 4, 2019
Messages
17
Reaction score
36
Hi All,
Since FW 1.10 update on max 360c I am getting at least 3 laser false alerts within a 30 mile drive to and from work. Also starting to notice that if my iPhone opens up with Face ID or just gets a signal of an email or text it triggers the laser. The other day I started my vehicle and my phone connected to apple car play while my max 360c turned on and within a few seconds it triggered 3 false laser alerts back to back and I was not even in drive yet. Then nothing for at least 20 miles then again. Weird sometimes I get them a lot and sometimes I get one or two within my drive. Tomorrow I am going to put my phone down by the cup holders in my 2018 Chevy Silverado and see if it makes a difference. When I use my MB E-350 I barley get more than one. It sure if being hooked up to my iPhone cord plugged into my USB port in my truck maybe triggers it more. Can’t get my finger on it yet. Will keep posting after trying different things. Thanks
Quick update

I drove my Chevy to work today and I hooked my phone on the apple cord like usual and started my apple car play and my Max 360c booted up and was ready to go as usual. I put the phone in my armrest cup holders this time not on the dash magnet like usual which sits about a foot under my Max 360c and low and behold 30 mile trip not one laser false. I usually get from two to four in the same trip every day to and from work. I will drive home tonight and do it again to see if I get any but so far so good. I will post again to give an update.
 

AnthonyL

Learning to Drive
General User
Joined
Sep 4, 2019
Messages
17
Reaction score
36
Quick update

I drove my Chevy to work today and I hooked my phone on the apple cord like usual and started my apple car play and my Max 360c booted up and was ready to go as usual. I put the phone in my armrest cup holders this time not on the dash magnet like usual which sits about a foot under my Max 360c and low and behold 30 mile trip not one laser false. I usually get from two to four in the same trip every day to and from work. I will drive home tonight and do it again to see if I get any but so far so good. I will post again to give an update.
Just an update for the drive home tonight. 31 miles, kept the phone in the cup holder by the arm rest and no false lasers. I drove 62 miles round trip today and not one false with laser. Usually two to four a day, and today not one. Guess it’s my iPhone somehow giving off a signal. Will try a different spot tomorrow and see what happens again. Just some FYI for All.
 

ron topa

Road Terror- ICU watching
Beginner User
Premium Member
Joined
Jul 31, 2018
Messages
455
Reaction score
463
Location
Duluth, GA
thanks Anthony for your observations and updates. I to have an iPhone and experience falses on occasion. I have mine directly under my 360c, and will experiment myself. My falses I think are related to my BlackVue camera somehow. It sits next to my 360c about 3-4 inches to the right of it. I notice periodically it going nuts when my cam is rebooted while powering on. I have so many devices on in my car that its a wonder any of them work correctly, lol.
 

AnthonyL

Learning to Drive
General User
Joined
Sep 4, 2019
Messages
17
Reaction score
36
thanks Anthony for your observations and updates. I to have an iPhone and experience falses on occasion. I have mine directly under my 360c, and will experiment myself. My falses I think are related to my BlackVue camera somehow. It sits next to my 360c about 3-4 inches to the right of it. I notice periodically it going nuts when my cam is rebooted while powering on. I have so many devices on in my car that its a wonder any of them work correctly, lol.
Hi All well I put my iPhone back on the dash magnet and received 3 false laser signals this morning going to work. On the way home I put my phone back into the cup holders and no laser false at all on the way home. Guess it’s other tech stuff like our phones and Dash Cams causing some kind of interference that creates these laser alerts to go off. Like someone else wrote in one of the threads it can be a positive thing so we know that our RD is not sleeping. Lol. There’s always something.
 

ron topa

Road Terror- ICU watching
Beginner User
Premium Member
Joined
Jul 31, 2018
Messages
455
Reaction score
463
Location
Duluth, GA
My 360c never had falses until FW ver 1.9 and now its worse with 1.10! Im so disappointed. This issue was never a concern with my 360c. Now Im in the same boat as others that have the problem. Ive been a user of Escort for over 30 years and never doubted for once the quality and accuracy of their products. Now I HAVE TO RELY ON MY R3. This really stinks. Its to much money to spend for an annoyance like this never mind it being embarrassing as hell for passer bys to see my unit going off as I pass by the Shell gas station! Time for a follow up FW update, and I mean Quickly!
 

Brainstorm69

TXCTG 2016 MOTY
Advanced User
Lifetime Premium Member
Joined
May 23, 2015
Messages
9,318
Reaction score
19,941
Location
Lone Star State
My 360c never had falses until FW ver 1.9 and now its worse with 1.10! Im so disappointed. This issue was never a concern with my 360c. Now Im in the same boat as others that have the problem. Ive been a user of Escort for over 30 years and never doubted for once the quality and accuracy of their products. Now I HAVE TO RELY ON MY R3. This really stinks. Its to much money to spend for an annoyance like this never mind it being embarrassing as hell for passer bys to see my unit going off as I pass by the Shell gas station! Time for a follow up FW update, and I mean Quickly!
An unfortunate example of "if it ain't broke don't fix it" when it comes to Escort fw updates since Escort will not allow users to go back to previous fw. It's similar with my Max 360. It had never falsed to laser before updating to fw 1.11. After updating, it had a couple of laser falses in the space of a 2 or 3 days. I'm glad I don't have to use it as my daily and mainly use it for testing purposes.
 

Discord Server

Latest threads

Latest posts

Forum statistics

Threads
78,334
Messages
1,192,654
Members
19,977
Latest member
iunyan
Top