R7 Motorcycle mode?

BMW rider

Learning to Fly
Beginner User
Joined
Sep 4, 2019
Messages
82
Reaction score
91
Location
Midwest
I would post pics but embarrassed of how dirty my bike looks. Living in Idaho, I'm trying to get in all the "wind therapy" I can before winter settles in. I think all of you understand but whatever gets posted on the inter-web is there for good lol.
Depends on the bike ... if it's a GS/GSA, they are supposed to always be dirty. When I traded my '16 R1200GSA in for a '19 R1250GSA, the general manager at the dealer commented "you don't wash it ... nice!"
 

aleaddict

Learning to Drive
General User
Joined
Nov 27, 2018
Messages
36
Reaction score
42
Location
Eagle, ID
Haha... yup. It's a '17.5 GS Rallye. I'll get it washed tomorrow and post pics of my cockpit. Love the R1250 GS/GSA with TFT but its taken almost two years to get the bike setup just the way I like it. Only thing lacking is a set of TPX jammers ;)
 

BMW rider

Learning to Fly
Beginner User
Joined
Sep 4, 2019
Messages
82
Reaction score
91
Location
Midwest
@aleaddict How are you getting your R7 audio alerts up into your helmet?
 

aleaddict

Learning to Drive
General User
Joined
Nov 27, 2018
Messages
36
Reaction score
42
Location
Eagle, ID
I have a Shoei Neotec2 with Sena SRL headset. I'm planning on purchasing the Sena SM-10 and using the 3.5mm jack as a conduit. Reviews are mixed and I've read all the posts, including yours, here and elsewhere. Hoping the SM-10 plays nicely with my SRL. My phone is an iPhone X. To answer your question though, right not I have volume set to 9... one more than 8 (Spinal Tap reference).
 

firstsage

Learning to Fly
Beginner User
Lifetime Premium Member
Joined
Apr 15, 2016
Messages
180
Reaction score
98
I have a Shoei Neotec2 with Sena SRL headset. I'm planning on purchasing the Sena SM-10 and using the 3.5mm jack as a conduit. Reviews are mixed and I've read all the posts, including yours, here and elsewhere. Hoping the SM-10 plays nicely with my SRL. My phone is an iPhone X. To answer your question though, right not I have volume set to 9... one more than 8 (Spinal Tap reference).
So right now you are just using the bear speaker?
On the SM-10, check Amazon. Under the Used & New, you can find some good deals.
I'll update this thread with how my testing goes. I have a Google Pixel 3 XL with the PT. The setup I want is: Connected to DMC group, phone for music mostly (i turn on DND while riding so I don't have to deal with spam calls) and the SM10 connected. I'll let you know if the audio will mix like I am hoping.
 

aleaddict

Learning to Drive
General User
Joined
Nov 27, 2018
Messages
36
Reaction score
42
Location
Eagle, ID
Quick evening bump...

Ordered the TaoTronics TT-BA07 wireless 2-in-1 adaptor. In a word: FAIL :(

The TT is set in transmit mode (Tx). I tried pairing it to the Nav VI and was only successful twice out of 100 times. Its on a charge now so maybe 101 is my lucky number... otherwise I'm going to plan B and ordering the SM-10. (Note: tried pairing to my iPhone with same results in Tx mode but was immediately recognized in Rx mode. Bad unit?.. idk)

While fumbling through the interweb I stumbled across this video. @BMW rider this may provide some clues to resolving your issues.

 

firstsage

Learning to Fly
Beginner User
Lifetime Premium Member
Joined
Apr 15, 2016
Messages
180
Reaction score
98
Quick evening bump...

Ordered the TaoTronics TT-BA07 wireless 2-in-1 adaptor. In a word: FAIL :(

The TT is set in transmit mode (Tx). I tried pairing it to the Nav VI and was only successful twice out of 100 times. Its on a charge now so maybe 101 is my lucky number... otherwise I'm going to plan B and ordering the SM-10. (Note: tried pairing to my iPhone with same results in Tx mode but was immediately recognized in Rx mode. Bad unit?.. idk)

While fumbling through the interweb I stumbled across this video. @BMW rider this may provide some clues to resolving your issues.

I'll have my helmet tonight, but have a quick trip to TX Friday to Saturday evening. So I'll either be able to do testing tonight or on Sunday with the new(ish) SM-10. I'll let you know what I hear. :)
 

BMW rider

Learning to Fly
Beginner User
Joined
Sep 4, 2019
Messages
82
Reaction score
91
Location
Midwest
Quick evening bump...

Ordered the TaoTronics TT-BA07 wireless 2-in-1 adaptor. In a word: FAIL :(

The TT is set in transmit mode (Tx). I tried pairing it to the Nav VI and was only successful twice out of 100 times. Its on a charge now so maybe 101 is my lucky number... otherwise I'm going to plan B and ordering the SM-10. (Note: tried pairing to my iPhone with same results in Tx mode but was immediately recognized in Rx mode. Bad unit?.. idk)

While fumbling through the interweb I stumbled across this video. @BMW rider this may provide some clues to resolving your issues.

Thanks. I watched that video and set up my Bluetooth jungle initially as he described. The challenge is that it leaves no open Bluetooth receivers to accept the R7 audio.


Sent from my iPhone using Tapatalk Pro
 

aleaddict

Learning to Drive
General User
Joined
Nov 27, 2018
Messages
36
Reaction score
42
Location
Eagle, ID
This tread has made me more determined than ever to solve this stubborn BT puzzle. No two setups are the same but hopefully between myself, @firstsage and @BMW rider we can help other members (including guests) integrate all their gizmos and doo-hickies with their whatchamacallits using BT pairing.
 

firstsage

Learning to Fly
Beginner User
Lifetime Premium Member
Joined
Apr 15, 2016
Messages
180
Reaction score
98
Well my buddy forgot to bring me my helmet... So I won't have my PT until next week when I go up north....
Testing pushed back until next Saturday.
 

beaky

Learning to Drive
General User
Joined
Oct 17, 2019
Messages
6
Reaction score
2
Hi all.

I have a PT Bold, and having similar issues connecting 2 bluetooth devices, and hearing audio from both.
My setup is Android_Phone <> BMW Navigator 6 <<>> PT Bold <<>> Sena SM10 < Radar

Channel 1 and 2 referred to are the main bluetooth device channels, not the rider A, rider B channels.

Phone, Nav 6, and PT Bold all work fine, but as soon as I introduce another Bluetooth device, and I've tried lots, audio is either channel 1 or channel 2. Even with parallel audio streaming switched on.
I haven't manage to find a way to get the radar to interrupt the Nav while music is playing.

I have tried numerous combinations:

Nav (as phone) <PT> SM10 (as phone)
Nav (as phone) <PT> SM10 (as GPS)
Nav (as GPS) <PT> SM10 (as GPS)
Nav (as GPS) <PT> SM10 (as phone)

Then all above, with SM10 on channel 1, and Nav on channel 2.

The best I got was SM10 (as phone) <PT> Nav (as GPS).
At least when I played music from the NAV, it played. When I stopped music, I could play music from the SM10.
If I played audio from the SM10, and as soon as I started music on the Nav, it would take over.
Stop the music on the Nav, and audio on the SM10 kicked back in.
This is kind of what I want, except opposite to what I need.

As above, I tried this with Nav (as phone) <PT> SM10 (as GPS), but the SM10 would appear to hold the audio connection and would not let music from the Nav be heard.

I want the Nav to play music (and navigation instructions), then the SM10 to cut in with Radar alert noise. With the audio from the Nav coming back in when the alert from the SM10 is over.
No matter what configuration, I could not get this to work.

All manner of resets, re-pairing etc, and I haven't found a solution yet.

Hoping someone has some hints, or has worked out a solution.

Thanks,
Beaky
 

BMW rider

Learning to Fly
Beginner User
Joined
Sep 4, 2019
Messages
82
Reaction score
91
Location
Midwest
Hi all.

I have a PT Bold, and having similar issues connecting 2 bluetooth devices, and hearing audio from both.
My setup is Android_Phone <> BMW Navigator 6 > PT Bold > Sena SM10 < Radar

Channel 1 and 2 referred to are the main bluetooth device channels, not the rider A, rider B channels.

Phone, Nav 6, and PT Bold all work fine, but as soon as I introduce another Bluetooth device, and I've tried lots, audio is either channel 1 or channel 2. Even with parallel audio streaming switched on.
I haven't manage to find a way to get the radar to interrupt the Nav while music is playing.

I have tried numerous combinations:

Nav (as phone) SM10 (as phone)
Nav (as phone) SM10 (as GPS)
Nav (as GPS) SM10 (as GPS)
Nav (as GPS) SM10 (as phone)

Then all above, with SM10 on channel 1, and Nav on channel 2.

The best I got was SM10 (as phone) Nav (as GPS).
At least when I played music from the NAV, it played. When I stopped music, I could play music from the SM10.
If I played audio from the SM10, and as soon as I started music on the Nav, it would take over.
Stop the music on the Nav, and audio on the SM10 kicked back in.
This is kind of what I want, except opposite to what I need.

As above, I tried this with Nav (as phone) SM10 (as GPS), but the SM10 would appear to hold the audio connection and would not let music from the Nav be heard.

I want the Nav to play music (and navigation instructions), then the SM10 to cut in with Radar alert noise. With the audio from the Nav coming back in when the alert from the SM10 is over.
No matter what configuration, I could not get this to work.

All manner of resets, re-pairing etc, and I haven't found a solution yet.

Hoping someone has some hints, or has worked out a solution.

Thanks,
Beaky
I’ve reached out to Cardo Systems multiple times seeking to solve this exact issue and all I get in response is crickets. I believe at one point someone there said the Packtalk Bold and SM10 don’t play well together. My experience is that no Bluetooth dongles play well with the PB, I’ve tried 3 others with no success. I keep hoping it’s something that they could fix with a firmware update.


Sent from my iPhone using Tapatalk Pro
 

beaky

Learning to Drive
General User
Joined
Oct 17, 2019
Messages
6
Reaction score
2
@BMW rider I agree. I raised it with Cardo, and got a call from a distributor in Australia within 30 minutes.
Great response time, but basically he couldn't help.
Claimed Sena kit does not play nicely with Cardo, surely that's mutual?
Anyway, I said I had tried other BT transmitters, and the comment was he didn't think the PB was designed to work like that.
Surely that's part of the whole point in having 2 device channels?
Likewise, hoping Cardo fix in a firmware update. Mine's on the latest v5.2 at present.
 

firstsage

Learning to Fly
Beginner User
Lifetime Premium Member
Joined
Apr 15, 2016
Messages
180
Reaction score
98
I think part of the issue is Daisy chaining multiple items on the same channel.
Does your set up work if you take the NAV out of the picture?

Sent from my Pixel 3 XL using Tapatalk
 

beaky

Learning to Drive
General User
Joined
Oct 17, 2019
Messages
6
Reaction score
2
Thanks, I just tried taking the Nav out of the setup.
So, Phone (as a phone) <> PB <> SM10 (as a GPS).
Same issue. I can play music from the phone, but audio from the SM10 will not cut in.
Stop music on phone, audio can then be heard from SM10.

Interestingly, I tried swapping out the SM10 with the Nav.
Phone (as phone) <> PB <> Nav (as GPS)
This works flawlessly. Play music from phone, then play music or instructions from Nav and it cuts in and stops the music from the phone.

Seems maybe some BT protocol difference between SM10 and the Nav.
I tried a Avantree Priva III. Same issue as with the SM10.
Or, the PB identifies these BT transmitters differently, perhaps as they don't have the BT Hands Free (HFP) profile?
 

BMW rider

Learning to Fly
Beginner User
Joined
Sep 4, 2019
Messages
82
Reaction score
91
Location
Midwest
Thanks, I just tried taking the Nav out of the setup.
So, Phone (as a phone) <> PB <> SM10 (as a GPS).
Same issue. I can play music from the phone, but audio from the SM10 will not cut in.
Stop music on phone, audio can then be heard from SM10.

Interestingly, I tried swapping out the SM10 with the Nav.
Phone (as phone) <> PB <> Nav (as GPS)
This works flawlessly. Play music from phone, then play music or instructions from Nav and it cuts in and stops the music from the phone.

Seems maybe some BT protocol difference between SM10 and the Nav.
I tried a Avantree Priva III. Same issue as with the SM10.
Or, the PB identifies these BT transmitters differently, perhaps as they don't have the BT Hands Free (HFP) profile?
I have an old Sena 20S that has been sitting on a garage shelf for well over a year. I updated the firmware to 2.0.1 and tried experimenting with it and the SM10 as I recall they used to play "nice" with each other. I tried the following pairing scenarios, but unfortunately, the SM10 <> 20S pairing didn't integrate like I had hoped.
TFT <> iPhone (data only for BMW Connected app)​
iPhone <> Nav VI (music & phone calls)​
Nav VI <> 20S paired as mobile phone 1 (GPS directions & iPhone music/calls)​
20S <> SM10 paired as mobile phone 2 and also as GPS (for R7 audio alerts)​

This is making my head hurt as instinctively it should work because I I'm 95% sure I had it functional in a similar configuration before except the music came from an iPod into the SM10 vs. from the iPhone through the GPS:
Screenshot 2019-10-19 11.10.36.png


So for right now, I'm back to my antique V1 and a Marc Parnes visual alert on the motorcycle and the R7 in my car.
 

beaky

Learning to Drive
General User
Joined
Oct 17, 2019
Messages
6
Reaction score
2
I've ordered a cheap BT transmitter that includes the HFP profile.
I think it has to travel around the world at least 3 times before I receive it, so likely to be a while before I can test it out.
I read on another forum, that priorities from a headset perspective go something like HFP, Intercom, then A2DP.
Anyway, I'll post again when I can check this out.
 

BMW rider

Learning to Fly
Beginner User
Joined
Sep 4, 2019
Messages
82
Reaction score
91
Location
Midwest
Anxious to hear if it works


Sent from my iPhone using Tapatalk Pro
 

beaky

Learning to Drive
General User
Joined
Oct 17, 2019
Messages
6
Reaction score
2
I can't report any success with this.

BT transmitter I received would not pair, with anything, not just the PB. So probably it's faulty, and I'm chasing the supplier for refund/replacement.

I did manage to find another BT transmitter that supports HFP. Only it needs pairing every time you switch it on, or switch the PB off. The BT transmitter would not remember the pairing. Not ideal.
This didn't work either. Once connected, the BT transmitter would hold the connection to the PB, and only audio from the BT transmitter could be heard.

Still searching for an answer on this.
 

BMW rider

Learning to Fly
Beginner User
Joined
Sep 4, 2019
Messages
82
Reaction score
91
Location
Midwest
For what it's worth, I was talking earlier this week to Cardo Systems tech support about a problem with the plate the Packtalk Bold clips into. While I had him on the line, I asked about options to get radar detector audio into the headset via Bluetooth and he didn't think it was possible.
 

Discord Server

Latest threads

Forum statistics

Threads
82,010
Messages
1,244,783
Members
20,761
Latest member
iLikeCoolTech
Top