R7 not turning on

scooby2

Learning to Drive
General User
Joined
Apr 21, 2019
Messages
12
Reaction score
30
Location
NW Chicago burbs
Driving to work today my R7 went blank. I tested the cigarette lighter (12v port) and that seems fine and the fuse in the cigarette charger looks fine. Is there anything else to reset or check? This is my first Uniden detector and I was very happy with it until now.

Thanks!
 

user

PSL +5
Intermediate User
Lifetime Premium Member
Joined
Apr 3, 2019
Messages
393
Reaction score
598
Unplug the rj45 and then plug it back in again and try it. I had trouble at that plug in on my R3. Worth a try.
 

auskip07

Advanced User
Lifetime Premium Member
Joined
Feb 5, 2019
Messages
868
Reaction score
1,203
Age
36
Location
Atlanta Georgia
is it within warranty?
 

Bocephus

Formerly gmcv893
Advanced User
Lifetime Premium Member
Joined
Apr 19, 2018
Messages
2,143
Reaction score
3,636
Location
FL
Has to be as they haven't even been out for a year.
 

auskip07

Advanced User
Lifetime Premium Member
Joined
Feb 5, 2019
Messages
868
Reaction score
1,203
Age
36
Location
Atlanta Georgia
I would hope so.

Would it be safe to test with my V1 cable to see if its the R7 or the charge cable?
you dont have anything to lose .
 

knight_man

I wanna go fast
Intermediate User
Joined
Aug 12, 2018
Messages
541
Reaction score
719
Can the Uniden cord power a USB device? Was there something plugged into it already? (Might have overdrawn).

I don’t have mine handy, did your Uniden plug unscrew at the end that plugs in (check that internal fuse).

Also, if your R7 got hot, try holding it in front of the AC vent for a minute or so and cool off the internals.

You might try to perform a recovery reflash when you have access to a computer and your included microUSB cable. If the PC doesn’t see it (be sure you use the R7 specific program) it could be d-e-d.

Good luck! Let us know what you come up with. Uniden warranty claim on my R1 was very easy and painless, btw, if you have to go that route.
 

Kennyc56

Ford Lover-I/O hater!
Advanced User
Lifetime Premium Member
Joined
Feb 22, 2018
Messages
2,883
Reaction score
7,336
Location
I/O Hell, Aka Eastern N.C.
Your V1 cable will work fine. If it still doesn't work with the V1 cable, try the cable and detector in another car. Also try turning the power switch on the R7 on and off just for the hell of it.
 

user

PSL +5
Intermediate User
Lifetime Premium Member
Joined
Apr 3, 2019
Messages
393
Reaction score
598
things like this makes me miss the quality of the V1s
Understand but let’s not overreact. One R7 not turning on isn’t a trend. I realize there have been a loose screw and stuff, but for the number built it doesn’t seem bad to me at all.
 

BlueV1

.
Advanced User
Lifetime Premium Member
Joined
Feb 8, 2016
Messages
3,860
Reaction score
7,462
Location
Western NC
Our sample of units is limited to RDF.
 

Brainstorm69

TXCTG 2016 MOTY
Advanced User
Lifetime Premium Member
Joined
May 23, 2015
Messages
9,515
Reaction score
20,297
Location
Lone Star State
I'm sure you can get Uniden to replace the cord under warranty if necessary.
 
Last edited:

Discord Server

Latest threads

Forum statistics

Threads
79,369
Messages
1,208,246
Members
20,126
Latest member
Frosty
Top