Silent Ride muted a legit alert... No GPS Fix!

Nagorg

If a frog had wings...
Intermediate User
Lifetime Premium Member
Joined
Jul 14, 2017
Messages
274
Reaction score
221
Location
Texas
I happened to notice a muted KA alert (legit) over the weekend, thankfully due to an initial alert sound that happened prior to being muted for "Silent Ride". I was at first baffled but soon realized that my phone had no GPS fix and JBV1 saw my speed as 0 miles per hour.

So my phone had a GPS problem and a reboot fixed that issue. But this made me wonder if it might be possible to cause Silent Ride to be disabled when there is no GPS fix...

Is there already such a feature and I am just overlooking it? I found an option to mute all alerts on no GPS fix which is opposite of what I'm thinking... Not sure why you'd want to mute all alerts in that scenario personally but there may be a legit reason for this.

Thoughts??
 

LouG

Intermediate User
Joined
Jan 2, 2014
Messages
2,555
Reaction score
2,620
Which is why I exclude Ka from silent ride. And probably validates MV's distrust of GPS lockouts
 

InsipidMonkey

Premium Monkey
Advanced User
Premium Member
Joined
Mar 22, 2017
Messages
5,829
Reaction score
11,569
Location
New England
Is there already such a feature and I am just overlooking it? I found an option to mute all alerts on no GPS fix which is opposite of what I'm thinking... Not sure why you'd want to mute all alerts in that scenario personally but there may be a legit reason for this.
Just disable "Mute Before GPS Fix", or exclude Ka from speed-based muting.

I have mute before GPS fix enabled to prevent alerting to stationary locked-out signals when I start my car (eg parked in front of an automatic door).
 

SquirrelMaster

Has a subscription with CHP
SysOp
Advanced User
Lifetime Premium Member
Joined
Dec 3, 2015
Messages
2,696
Reaction score
5,118
Location
Liberal California
It's a good thing you were vigilant!
Gotta be careful when there's more things in the chain that can go wrong...

Some gps status monitoring would be a very basic thing to implement, especially in an app that runs on such a powerful device.

Have you noticed this happen before (with your phone's GPS?) what kind of phone do you have?
 

Kennyc56

Ford Lover-I/O hater!
Advanced User
Lifetime Premium Member
Joined
Feb 22, 2018
Messages
2,633
Reaction score
6,387
Location
I/O Hell, Aka Eastern N.C.
Having any type of gps function or lockout involved in Ka band alerts is a guaranteed way to have your day ruined in a hurry! I agree with MV! I don't trust gps either!
 

Nagorg

If a frog had wings...
Intermediate User
Lifetime Premium Member
Joined
Jul 14, 2017
Messages
274
Reaction score
221
Location
Texas
Just disable "Mute Before GPS Fix", or exclude Ka from speed-based muting.
I dont have that feature enabled. Good tip on excluding Ka from Silent Ride..

Have you noticed this happen before (with your phone's GPS?) what kind of phone do you have?
This is a Samsung Galaxy J7 El Cheapo. (More expensive that Walmart burners though..) It has problems from time to time that require a reboot but those usually cause connection problems to begin with and are very noticeable. Cant says I've noticed the GPS fix problem before.

On Silent Ride band exclusions, this situation could play out for K band too. Might as well turn off Silent Ride. Anyway, since its such a nice feature it just makes sense to me that a "No GPS Fix Disable" safeguard wouldnt be a terrible idea.
 

Nagorg

If a frog had wings...
Intermediate User
Lifetime Premium Member
Joined
Jul 14, 2017
Messages
274
Reaction score
221
Location
Texas
Sorry for the trouble! Was the GPS icon red?
No need to apologize johnboy! Yes, it was red (I'm pretty sure). The speed color was orange. Dont think the GPS icon was orange; it certainly wasn't green.
 

johnboy00

Geaux Tigers!
Advanced User
Lifetime Premium Member
Joined
Sep 6, 2016
Messages
3,846
Reaction score
7,255
Location
Raleigh, NC
No need to apologize johnboy! Yes, it was red (I'm pretty sure). The speed color was orange. Dont think the GPS icon was orange; it certainly wasn't green.
I've never had a GPS issue with any of my devices, so I wasn't aware of any weaknesses in GPS state detection w.r.t. Silent Ride. I'll have this fixed in the next update (Wednesday night).
 

Nagorg

If a frog had wings...
Intermediate User
Lifetime Premium Member
Joined
Jul 14, 2017
Messages
274
Reaction score
221
Location
Texas
I've never had a GPS issue with any of my devices, so I wasn't aware of any weaknesses in GPS state detection w.r.t. Silent Ride. I'll have this fixed in the next update (Wednesday night).
Yeah, I cant say its common. But since it happened I thought it was worth mentioning and suggesting that "safeguard" feature. Hopefully there is no conflict with the existing feature to mute before GPS fix. Maybe a switch between behaviors or separate toggles for each? (They could both be "off" but toggling either feature would turn off the other if enabled?)

As always, thanks for your response on this forum and for JBV1! Its made V1 Great again! :)
 

johnboy00

Geaux Tigers!
Advanced User
Lifetime Premium Member
Joined
Sep 6, 2016
Messages
3,846
Reaction score
7,255
Location
Raleigh, NC
Yeah, I cant say its common. But since it happened I thought it was worth mentioning and suggesting that "safeguard" feature. Hopefully there is no conflict with the existing feature to mute before GPS fix. Maybe a switch between behaviors or separate toggles for each? (They could both be "off" but toggling either feature would turn off the other if enabled?)

As always, thanks for your response on this forum and for JBV1! Its made V1 Great again! :)
I'll be adding a time limit to the mute before GPS fix logic so that option can still function, but it won't mute indefinitely if that fix never comes.
 

Nagorg

If a frog had wings...
Intermediate User
Lifetime Premium Member
Joined
Jul 14, 2017
Messages
274
Reaction score
221
Location
Texas
@johnboy00 , I just wanted to confirm that this safeguard feature did work exactly as expected. I had another occurrence of no GPS fix and JBV1 showing 0 mph even though I was driving ~75'ish. However, this time I still received alerts with no silent ride muting! A reboot of my El Cheapo phone restored GPS.

Anyway, just wanted to pass on some positive UAT feedback... Thanks again for your continued work on JBV1!
 

johnboy00

Geaux Tigers!
Advanced User
Lifetime Premium Member
Joined
Sep 6, 2016
Messages
3,846
Reaction score
7,255
Location
Raleigh, NC
@johnboy00 , I just wanted to confirm that this safeguard feature did work exactly as expected. I had another occurrence of no GPS fix and JBV1 showing 0 mph even though I was driving ~75'ish. However, this time I still received alerts with no silent ride muting! A reboot of my El Cheapo phone restored GPS.

Anyway, just wanted to pass on some positive UAT feedback... Thanks again for your continued work on JBV1!
Thanks for letting me know!
 

Discord Server

Latest threads

Latest posts

Forum statistics

Threads
77,507
Messages
1,180,981
Members
19,827
Latest member
BeverlyCollier
Top