Intellicord

J6379

Learning to Drive
General User
Joined
Jan 11, 2019
Messages
4
Reaction score
11
I just saw where this can be used on the CR97. Is anyone using it/thoughts? It would be great if the button worked like the one on the R3. Thanks
 

RoadDogg

PSL +5
Intermediate User
Lifetime Premium Member
Joined
May 10, 2018
Messages
550
Reaction score
1,211
Location
Tennessee
I just saw where this can be used on the CR97. Is anyone using it/thoughts? It would be great if the button worked like the one on the R3. Thanks
I have seen it available, but I haven’t bought one. I also have a R3 and a Max 360c with the button, but I don’t really use the button on those detector’s cords.


Sent from my iPhone using Tapatalk
 

J6379

Learning to Drive
General User
Joined
Jan 11, 2019
Messages
4
Reaction score
11
Thanks for the reply. My reason is I'd like to at least be able to mute on the occasion the detector seems to lock on a freq and does not let go right away. Reaching to the detector is more of a reach then I like just to mute which I would use a lot till I find a setting to were the detector is not always going off.
 

RoadDogg

PSL +5
Intermediate User
Lifetime Premium Member
Joined
May 10, 2018
Messages
550
Reaction score
1,211
Location
Tennessee
Thanks for the reply. My reason is I'd like to at least be able to mute on the occasion the detector seems to lock on a freq and does not let go right away. Reaching to the detector is more of a reach then I like just to mute which I would use a lot till I find a setting to were the detector is not always going off.
I also have that problem too with the CR97 latching on to a signal and not “letting go” with the detector still alerting long distances after passing a radar source. I have tried to “factory reset” it numerous times, but that doesn’t seem to help much. Oftentimes I will have to unplug the detector and plug it back in to get it back quiet again (or hit the on off button to power cycle it). What settings do you use now? TFSR on or off? What filter levels are you running on X/K and Ka? Do you run the FDSr on or off?


Sent from my iPhone using Tapatalk
 

Marty K

Always Driving Vigilantly
Intermediate User
Premium Member
Joined
Nov 27, 2018
Messages
485
Reaction score
1,072
Location
Missouri
What @RoadDogg said - I can confirm so, as I have had the same glitch several times. Same "solution". I am just disappointed of the fact that Whistler does not participate here, and also they have had only 1 firmware update since the 97 has been out...
 

RoadDogg

PSL +5
Intermediate User
Lifetime Premium Member
Joined
May 10, 2018
Messages
550
Reaction score
1,211
Location
Tennessee
What @RoadDogg said - I can confirm so, as I have had the same glitch several times. Same "solution". I am just disappointed of the fact that Whistler does not participate here, and also they have had only 1 firmware update since the 97 has been out...
I agree as I wish Whistler would have more involvement in the forum. Another firmware update soon would be good too. I had to power cycle mine last night as it latched onto a K band signal for several minutes. Fortunately it hasn’t been a persistent issue for me, but it does happen occasionally. On a side note, the other day I thought my detector was latching onto signal after passing an officer running 35.5, but shortly after I (within a mile or 1.5 miles I encountered another officer running 35.5) as it was obvious to me from the signal ramp up, so I always look around a lot to make sure there isn’t something else out there causing my CR97 to keep alerting. Most of my “latching on” issues have involved K-band signals.


Sent from my iPhone using Tapatalk
 

Marty K

Always Driving Vigilantly
Intermediate User
Premium Member
Joined
Nov 27, 2018
Messages
485
Reaction score
1,072
Location
Missouri
I agree as I wish Whistler would have more involvement in the forum. Another firmware update soon would be good too. I had to power cycle mine last night as it latched onto a K band signal for several minutes. Fortunately it hasn’t been a persistent issue for me, but it does happen occasionally. On a side note, the other day I thought my detector was latching onto signal after passing an officer running 35.5, but shortly after I (within a mile or 1.5 miles I encountered another officer running 35.5) as it was obvious to me from the signal ramp up, so I always look around a lot to make sure there isn’t something else out there causing my CR97 to keep alerting. Most of my “latching on” issues have involved K-band signals.


Sent from my iPhone using Tapatalk
I have had generic Ka (no frequency) "latching on" at full strength, in addition to K.
I have had encounters where there is a legit radar source, but it gets "overwritten" by a stronger BSM signal from a vehicle (or vehicles) close by, which sucks. In such case you cannot really tell where the source is until you eventually get a visual, because you don't get the ramp up/down indication. I think this can be considered a glitch, and no matter the signal strength of multiple sources, the legit one (known police frequency) should always be displayed (alerted to) as the primary/current source...
 

NOTKTS

Learning to Fly
Beginner User
Joined
Oct 30, 2018
Messages
98
Reaction score
218
Location
Long Island/NY
I found with FDSR engaged, the 97 won't do the lock and hold to a signal. With Fdsr off I see what you are seeing with respect to an occasional hiway lock on. I am running FDsR, xk at 2, ka at 1, TFSR off, autofilter to 40 mph but Ka max now and it doesn't seem to miss anything or make me nervous. I feel confident with it this way for 10 to 15 above psl. It seems very reactive. Running it in city mode. There is no automute unless FDsR is engaged. It will default to volume setting 1 otherwise with autoquiet and FDsR off. It won't silence. Maybe its a patent thing? I would like to see a firmware update for the lock on and something about the k/ka mixup to make this a better unit. I run FDsR to prevent ka's from being possibly ignored as k's in bsm traffic. I see if it id's a bsm as ka with FDsR, it corrects it after a second or 2. Its lightweight, I find the display very readable in all lighting and the user interface is better than my Escort Redline or my R3.
 

yellowtibby

Shifter ZR4's number one fan.
Intermediate User
Joined
Dec 15, 2011
Messages
415
Reaction score
249
Location
Idaho and Connecticut
I just purchased a CR 97 with an intellicord yesterday and the cord works great with it.
 

Discord Server

Latest threads

Forum statistics

Threads
79,965
Messages
1,216,689
Members
20,243
Latest member
abseis
Top