Shoutout to Escort Customer Service!!! (1 Viewer)

Idahorenegade

Learning to Drive
General User
Joined
Jul 26, 2018
Messages
8
Reaction score
17
Awards
0
I have seen quite a few negative comments concerning Escort's customer service, figured I'd share my experience, which was anything but.

I picked up a Max360 roughly 6 weeks ago. I really like the unit-the automuting of door openers, etc is awesome-my R3 drove me nuts-took several repeats of lockouts to make it block a false site (over a distance). Love the arrows-great tool for identifying where the threat is coming from. The range doesn't compare with the R3-but it's more than adequate. And the R3s range, without arrows, I found annoying. More than once I picked up traps in areas with rolling hills 2 or more miles away, they would come and go and I'd think they were behind me, only to drive up on them. The Max is nice-on a day without traps, the daily commute is silent-could never say that with the R3. And Escort Live, in spite of it's faults, I find pretty useful-can't wait to see the new version when it's out for Android.

Anyway to the relevant story, after a few weeks one of the arrow LEDs quit working. To be honest, it was probably my fault. I dropped it putting it on the bike, kind of caught it against my leg, but still impacted the ground. A day or so later I noticed the LED out, but everything worked otherwise. Emailed Escort about the problem, had an RMA number and shipping instructions the same day. I sent the unit out last Friday morning, 2nd day. It was delivered back to my house today about noon-a one-week turn including shipping both ways. Not only did the correct the problem, but they also sent me a new power adapter and windshield mount. I had been thinking about buying one anyway just to keep one on the bikes (the windshield mount I'll try on my Roadmaster-I use a RAM magnetic mount on the KTM).

Anyway-as far as I'm concerned, this was outstanding service and puts me at ease. Some of the negatives I'd seen had me a little concerned.
 
Last edited:

mattguy10

Keep it under a hundred
Advanced User
Premium Member
Joined
Oct 5, 2017
Messages
931
Reaction score
1,316
Awards
0
Same thing happened to my 360 when I owned one. IIRC, it was the right arrow that quit illuminating. I didn’t drop mine though, it just quit working. They did the same for me. Fixed the arrow, sent back the unit with a new cord and mount. I was very pleased!
 

OBeerWANKenobi

This is not the car you're looking for.....
Advanced User
Premium Member
Acceptus
Joined
Mar 20, 2018
Messages
3,483
Reaction score
8,690
Awards
0
Location
Right Behind You! (Wisconsin)
I've heard lately that their customer service has been improving and it does seem they are listening to enthusiasts a little bit more readily lately. Hopefully this continues in a positive direction because more competition is always better for us as customers and enthusiasts!

Their forum is basically on lockdown though so it's lucky that Escort users still have a great place to talk about Escort at RDF!
 

Jbwiljr

Learning to Drive
General User
Joined
Nov 23, 2018
Messages
49
Reaction score
98
Awards
0
I also had a positive experience what Escort’s customer service. After the 1.8 update my 360c was as wonky as it gets. All kinds of false and phantom alerts. I sent it in and got it back in less than 2 weeks start to finish. They tweaked some settings and my 360c has performed flawlessly ever since.
 

Heywood

Learning Something New, Still Dying Stupid
Advanced User
Premium Member
Joined
May 12, 2016
Messages
3,195
Reaction score
5,591
Awards
0
Location
Alberta Canada
The customer service rep I’ve dealt with was great.

The repair department has been terrible.

So much so that after having my R-Ex 4 times now since December 2018, they are now going to replace it.

Long story short. It started with a “Check FR” message, and the last repair was a bad LNA. They’ve had it more than me since December.
 

FunkyDoc

Learning to Drive
General User
Joined
Sep 19, 2018
Messages
46
Reaction score
95
Awards
0
Echo the other positive sentiments about good CS from Escort. Returned their dashcam when it resulted in difficulties in my GT-360 acquiring GPS signal on the Blendmount. Was testing it and giving it the benefit of the doubt to see if over time GPS signal acquisition improved- but lost track of the warranty period. Despite the fact that it was over the return period by 2-3 days, they honestly couldn't have been better and set up the RMA. YMMV, but it was nothing but a positive experience for me.
 

Spearscrue

Learning to Fly
Beginner User
Joined
Jun 13, 2017
Messages
105
Reaction score
79
Awards
0
Location
Downriver MI
I have never dealt with Escort on their forum, which alot of people seem to have a problem with but have dealt with their customer service over the phone and thru email for alot of years, I can say that my experience has always been positive with communication and with their repairs. I also own a Max 360 and can say it's probably my favorite detector, I also own a Pro M and a R7, I used to own a R3 and had it dialed in to be the quietest it could be but it still never shut up it was so bad that I ended up selling it.

Sent from my ONEPLUS A5010 using Tapatalk
 

eric15178

If you ain't 1st you're last-Ricky Bobby
Beginner User
Joined
May 4, 2018
Messages
161
Reaction score
102
Awards
0
Location
wisconsin
I've always had decent people on the phones the few times I've called them, professional, friendly, etc...

Think the "bad customer service rap" comes more from their ignoring and claiming there was no lock up issue on the 360's, not listening or recognizing the seriousness of needing auto jtk on their jammers, and lot of repeat/rebadged detectors.

So far liking my max 2, and they've been decent when I've had to call on the phone
 

ron topa

Road Terror- ICU watching
Beginner User
Joined
Jul 31, 2018
Messages
244
Reaction score
195
Awards
0
Location
Duluth, GA
I also had a positive experience what Escort’s customer service. After the 1.8 update my 360c was as wonky as it gets. All kinds of false and phantom alerts. I sent it in and got it back in less than 2 weeks start to finish. They tweaked some settings and my 360c has performed flawlessly ever since.
ive just sent my ZR5 and 360c both in for service. There appears to be a communication problem between the 2 units there by them not seeing each other when installed. Bryan has seen me through the troubleshooting from start to this point. Hopefully they can fix my units within a week or two. Im using ver 1.8 and its been flakey since that last update via wireless updating.
I feel naked -can I say that here?- without my units. So using my solo 4 on the rear window and my Uni** R3 on the front Im anxiously awaiting my real toys return. Ill keep a post here to update the progress of my two toys.
 

Kennyc56

Ford Lover, I/O Hater!
Advanced User
Premium Member
Joined
Feb 22, 2018
Messages
2,126
Reaction score
4,811
Awards
0
Location
Eastern North Carolina
Glad to hear that they took care of your problem! It's great to hear anything good about Escort!
 
Last edited:

Users Who Are Viewing This Thread (Users: 0, Guests: 0)

Unregistered User Ad


ATTENTION: Want ads to disappear? Register for an account here - it's free and NO ADS ARE DISPLAYED TO REGISTERED MEMBERS! Thanks!

Donation drives

RDF Server & License Fees (JUNE 2019) (ACTIVE)

This donation drive covers the server and licensing fees for RDF for the month of June 2019...
Goal
$241.00
Earned
$375.00
This donation drive ends in

Latest threads

Latest posts

Social Group Activity

Forum statistics

Threads
83,126
Messages
1,244,015
Members
19,313
Latest member
myet01
Top