Uniden R7 Issues... Please no BS Just Issues Only Please!

knight_man

I wanna go fast
Intermediate User
Joined
Aug 12, 2018
Messages
516
Reaction score
681
Not sure this is an issue by definition of the thread (it is a problem for me) so mods do as you need. This may be a 'feature request'.

When I power off the detector and lock the car, detector stays off until my car applies power to the 12v socket (at random, and definitely when I unlock the car). It would be helpful if the unit would ignore that and stay powered off until I physically turn it back on. I come back to the vehicle to a nearly dead battery constantly.

Luckily I drive a stick and I can jump the car. This will be a bigger issue when it gets colder again, both because the battery will be weaker and also because I am not looking forward to pushing my car around a frozen parkinglot.
 

Got Jeep

Just another Two weeks....
Advanced User
Lifetime Premium Member
Joined
Dec 2, 2017
Messages
2,407
Reaction score
4,207
Location
Metro Detroit , MI
That's a new one on me. Haven't heard of random power to the socket.
I would recommend a hard wire install.
 

knight_man

I wanna go fast
Intermediate User
Joined
Aug 12, 2018
Messages
516
Reaction score
681
That's a new one on me. Haven't heard of random power to the socket.
I would recommend a hard wire install.
The power on the plug cycles with the doors unlocking, for sure. It also appears to cycle at random, because I constantly find my detector turned on (very east to see at night).

As I define this better I think I am asking for a feature; set the power restore action. For example your computer can be told to stay off or turn itself on when power is provided. Last state, power on, stay off, wait a minute then turn on, etc.

Yep, feature request...sorry about that. Mods can blow away my posts if this is hogging up this thread.
 

Raptor001

Learning to Drive
General User
Joined
Jan 6, 2016
Messages
7
Reaction score
1
Feature Request: Create an option where you can reverse the R7's display and arrows so you can read the display in the rearview mirror when the detector is mounted on the rear windshield and then the rear antenna arrow would be the front antenna since the detector is facing out the rear. Some type of mirror view option.
 

aim4squirrels

Currently edging...
Advanced User
Lifetime Premium Member
Joined
Jul 21, 2015
Messages
2,768
Reaction score
4,523
Location
DFW Texas
Feature Request: Create an option where you can reverse the R7's display and arrows so you can read the display in the rearview mirror when the detector is mounted on the rear windshield and then the rear antenna arrow would be the front antenna since the detector is facing out the rear. Some type of mirror view option.
tenor (1).gif
 

lageass

Manufacturer
Beginner User
Manufacturer
Joined
Jan 1, 2018
Messages
78
Reaction score
50
Sometimes the R7 signal is intermittent and the R3 signal is weak to strong. There's also the GPS problem, some R7 sometimes can't locate.
 

Tootiefrootie

Learning to Drive
General User
Joined
Oct 10, 2019
Messages
8
Reaction score
15
I tried searching for this “issue”, but thought I’d share it here:

When either Speed or Spd+Compass is selected, that exact label or title shows up on the top left side of the display right? Well, mine does, but then doesn’t. Meaning - it goes in and out, and when it goes out, what I mean is that there is no title or label displayed in that top left box. I don’t think it alter functionality by any means, but it just annoys me. My R3 doesn’t do that, nor did my first R7. (This is my 2nd one).

Anyone else having this issue? (@Bossdad71 )
 

Brainstorm69

TXCTG 2016 MOTY
Advanced User
Premium Member
Joined
May 23, 2015
Messages
9,316
Reaction score
19,929
Location
Lone Star State
I tried searching for this “issue”, but thought I’d share it here:

When either Speed or Spd+Compass is selected, that exact label or title shows up on the top left side of the display right? Well, mine does, but then doesn’t. Meaning - it goes in and out, and when it goes out, what I mean is that there is no title or label displayed in that top left box. I don’t think it alter functionality by any means, but it just annoys me. My R3 doesn’t do that, nor did my first R7. (This is my 2nd one).

Anyone else having this issue? (@Bossdad71 )
Asked and answered. Intentional to prevent burn-in.
 

r3MI

Learning to Fly
Beginner User
Lifetime Premium Member
Joined
Dec 6, 2017
Messages
429
Reaction score
485
Location
Michigan
Feature Request: Create an option where you can reverse the R7's display and arrows so you can read the display in the rearview mirror when the detector is mounted on the rear windshield and then the rear antenna arrow would be the front antenna since the detector is facing out the rear. Some type of mirror view option.
:megashifty:
 

leesrt

Mature Speeder
Beginner User
Joined
Feb 3, 2015
Messages
567
Reaction score
745
Location
Florida
Just sent my R7 back to Uniden last week. The rear antenna acted like it was dead. After multiple test with good signals it was impossible to get the rear antenna to show an alert. It was basically an R3.
Post automatically merged:

Not sure this is an issue by definition of the thread (it is a problem for me) so mods do as you need. This may be a 'feature request'.

When I power off the detector and lock the car, detector stays off until my car applies power to the 12v socket (at random, and definitely when I unlock the car). It would be helpful if the unit would ignore that and stay powered off until I physically turn it back on. I come back to the vehicle to a nearly dead battery constantly.

Luckily I drive a stick and I can jump the car. This will be a bigger issue when it gets colder again, both because the battery will be weaker and also because I am not looking forward to pushing my car around a frozen parkinglot.
You do know the RD has a power saver option right?
 
Last edited:

knight_man

I wanna go fast
Intermediate User
Joined
Aug 12, 2018
Messages
516
Reaction score
681
Just sent my R7 back to Uniden last week. The rear antenna acted like it was dead. After multiple test with good signals it was impossible to get the rear antenna to show an alert. It was basically an R3.
Post automatically merged:


You do know the RD has a power saver option right?
Power save just wasn’t doing it for me. I would have preferred that the unit did not power on until the power button was physically activated again. Power save doesn’t stop the detector from random power events at the plug triggering the power up sequence then drawing for another hour at a time while my car is parked.

I have since moved to taking the unit down every time I exit the vehicle for this and climate (heat) related issues. PITA, really. Also, now I am recrimping On a replacement RJ11 every few months.
 

gdates

Learning to Drive
General User
Joined
Sep 11, 2019
Messages
3
Reaction score
1
I'm on my second R7. I returned the first one because of gps failure multiple times daily and the unit kept forgetting or deleting my mute memory locations.

On R7 number two, no gps errors so far, but it has forgotten or lost my mute memory settings twice within a three week stretch.
Zero percent chance that I'm accidentally deleting them myself.
 

mattguy10

Keep it under a hundred
Advanced User
Lifetime Premium Member
Joined
Oct 5, 2017
Messages
1,462
Reaction score
1,951
Location
Southern RI
I'm on my second R7. I returned the first one because of gps failure multiple times daily and the unit kept forgetting or deleting my mute memory locations.

On R7 number two, no gps errors so far, but it has forgotten or lost my mute memory settings twice within a three week stretch.
Zero percent chance that I'm accidentally deleting them myself.
IIRC, the lockout radius isn’t very large on the R Series, and due to the sensitivity of them, sometimes you have to set multiple lockouts for the same false alert. Is this maybe the case here? I haven’t seen any reports of the detectors simply forgetting lockouts that were set. This of course only applies to when the detector has GPS connectivity and hasn’t reported a GPS error.
 

KnightHawk

Learning to Drive
General User
Joined
Apr 26, 2018
Messages
332
Reaction score
324
Location
Somewhere Out There
First encounter of this kind. Got an I/O Ka band and arrows where pointing to the sides but voice alert said rear with full bars on strength meter for about 4-5 seconds and then silent. There was a full size truck Dodge Ram in front of me and both of us on a complete stop while truck was waiting to make it clear to make a left turn. Road was curving to the left while we where at a complete stop. Looked around and could not have visual on LEO. Road then was clear and proceeded with caution. 15-20 sec later on a straight road, then I/O full strength with arrows pointing rear verified by voice. Looked at my RVM, saw LEO about a quarter mile behind me and had his radar remained in C/O. Still keeping an eye on him from my RVM to check if he was gaining on me. Few seconds later, I saw the blue lights. He caught one of the drivers going the opposite direction. Just love the R7 when it locked on LEO's radar. When the R7 gives you a full strength signal even if you could not see LEO, ALWAYS proceed with caution. My guess is that with the R7, the arrow indicators goes first and as always the voice comes later. My thinking is that, by the time the voice was to say the direction, it already had a full locked on to the rear. Anyway, just wanted to share what happened today.
 

Discord Server

Latest threads

Forum statistics

Threads
78,272
Messages
1,191,948
Members
19,963
Latest member
HNEAL211
Top