Escort Customer Service.

Heywood

Learning Something New, Still Dying Stupid
Premium Member
Advanced User
Intermediate User
Beginner User
General User
Newly Registered
Joined
May 12, 2016
Messages
2,500
Reaction score
3,788
Location
Alberta Canada
Rating - 0%
0   0   0
So unfortunately my Redline Ex just started giving me the Check FR message.

It was only purchased July 16/ 2018. Kind of disappointed that it didn’t last considering I rarely use it, but it is what it is.

Although I was waiting in que for close to 30 minutes, once I got through, I talked to a service rep named Mike.

He was great and helped my return seamlessly.

I also told him of my troubles when trying to get the free updates for the database since this was a new detector. I first registered the Max when they came out. I had to phone in to change the subscription when I had my Max360.

I asked if he could activate it for me over on his end for the Redline Ex. Being in Canada, some of the option to change always require a zip code. The Escort site doesn’t recognize Canadian Postal codes.

Mike was gracious enough to give me 3 years to the data base for my troubles. He asked for my serial number and activated it from his end.

I thought that was great, and I appreciate it.

I just wanted to give credit where credit was due.


Sent from my iPhone using Tapatalk
 

Revglent

The Rollin Reverend
Premium Member
General User
Newly Registered
Joined
Aug 10, 2016
Messages
42
Reaction score
43
Location
Colorado Springs
Rating - 0%
0   0   0
@Heywood that's good to hear. I've had to call Escort customer service twice concerning my original max, and I was fortunate to get excellent customer service as well. They provided repairs (after warranty), upgraded the firmware and provided me some accessories all on their dime. I'm now ready to pull the trigger on a 360 (non connected).
 

The Only Sarge

7 decades of hauling ass
General User
MFG/Vendor
Newly Registered
Joined
Dec 27, 2014
Messages
7,163
Reaction score
13,066
Location
South Texas
Rating - 0%
0   0   0
Well I'll chime in :)
In the past week I installed a 360c/ZW5 combo in the Jeep.
I couldn't get the Detector Tools Pro to connect via Windows 10. Nice lady @ Escort said she did not know but would get an engineer to call me back which he did. We had a great conversation.He was very knowledgeable and professional as well. The lady then called me back to make sure all was well. Now that is customer service.

Now on the flip side....
I posted my question of ERF and it sat there unanswered for days until Larry came along wit a short terse "DTPro doesnt support ZW5" and that was it.

I really think their forum does them more harm than any good .......IMHO. I would just trash it (the forum) and rely on the obviously great customer service folks they have answering the calls.
 

westwind77

Premium Member
Premium Member
Advanced User
Intermediate User
Beginner User
General User
Newly Registered
Joined
Dec 7, 2016
Messages
1,700
Reaction score
2,530
Rating - 0%
0   0   0
Now on the flip side....
I posted my question of ERF and it sat there unanswered for days until Larry came along wit a short terse "DTPro doesnt support ZW5" and that was it.
.
Well....that was after he blew off your question to start with and said 'there were no updates for the ZW5' - purposely ignoring your issue connecting. Only when you pushed and repeated yourself saying it will not connect was he forced to tell you they released a product which they cannot even update at this point in time. He did not even say they are working on it or it will be included soon.

Their forum could really benefit them as a company but I see so many unhappy people there, and it is not from any issues they have, it is from the lack of response or the 'blow off' they get from the 'official company rep' there.

Some days he seems to be in a good mood and will actually engage with members, but usually it seems to be just one or two line form responses which never fully answer the questions/issues addressed.
 

The Only Sarge

7 decades of hauling ass
General User
MFG/Vendor
Newly Registered
Joined
Dec 27, 2014
Messages
7,163
Reaction score
13,066
Location
South Texas
Rating - 0%
0   0   0
Yes I agree he is the weak link in the store front.
 

fitz4321

Running With Scissors
Premium Member
Advanced User
Intermediate User
Beginner User
General User
Newly Registered
Joined
Dec 12, 2015
Messages
1,850
Reaction score
2,990
Location
Bay Area, CA
Rating - 0%
0   0   0
I’ll also jump in. Regardless of my low opinion Escort’s decisions up top, I’ll speak positive about my experience with CS earlier this year. I got a very cheep used Redline O. When I called Escort for the RDR/segmentation update the guy I spoke to was super cool and helpful. I had no hold time as I was the first caller in the morning.
 

Kennyc56

Ford Freak
Premium Member
Advanced User
Intermediate User
Beginner User
General User
Newly Registered
Joined
Feb 22, 2018
Messages
1,455
Reaction score
3,025
Location
Eastern NC
Rating - 0%
0   0   0
It’s good to hear ANYTHING good about Escort these days! Thank’s for posting some good news for a change! I haven’t had any dealings with them for quite awhile now, but when I sent my Redline in for an update and repairs I got top notch service! My ole’Redline is still kicking @ss BTW!
 

Super Dave

I'm invisible
Premium Member
Intermediate User
Beginner User
General User
Newly Registered
Joined
Jun 1, 2014
Messages
552
Reaction score
658
Location
Kentucky
Rating - 0%
0   0   0
I’ve said for a long time their forum only highlights problems.
 

Andrew21

"All Blade, All The Time"
Administrator
Premium Member
Advanced User
Intermediate User
Beginner User
General User
Newly Registered
Joined
Oct 31, 2010
Messages
10,982
Reaction score
8,851
Location
Long Island
Rating - 100%
5   0   0
Well, for one, I'm OKAY with the CS with Escort.

I called in to get my Sti-R Plus module fixed. They took it in July and I didn't hear back from them till a few weeks ago when I had to call them. The guy said, sure, we'll get this out for you. They placed a hold on my credit card for the repair $49.99.

Six months later, still no module (I forget, I'm SO busy). I called back and told the lady what happened (Angela, very very nice). She said she'll get it out asap. Two days later, the module was delivered.

Now here's one small downside. There's a grommet which is supposed to be sandwiched in between the module. They left it hanging out there. I have to open then and put the grommet in place.

The upside? They never charged me a dime :) Since it took 6 months to get something repaired I think they felt bad about it. j
 

Phillip Fox

pjfox23
Premium Member
General User
Newly Registered
Joined
Nov 23, 2018
Messages
12
Reaction score
9
Rating - 0%
0   0   0
Currently looking to purchase (and send back, dread "check receiver wiring") a 9500ci receiver head to Escort. Can't get anyone on the phone. Can't get a response to email. That's my experience. Been happening for a month now. And no, I am not going to wait on hold for 40 minutes. That's crazy.
 

fishing66

PSL +15
Advanced User
Intermediate User
Beginner User
General User
Newly Registered
Joined
Sep 1, 2012
Messages
3,035
Reaction score
4,361
Rating - 0%
0   0   0
Currently looking to purchase (and send back, dread "check receiver wiring") a 9500ci receiver head to Escort. Can't get anyone on the phone. Can't get a response to email. That's my experience. Been happening for a month now. And no, I am not going to wait on hold for 40 minutes. That's crazy.
I am very sorry to hear of this. An installed detector is a blessing and a curse.....you get a concealed detector and don't have to deal with LEOs or thieves seeing a windshield mount. The downside is if/when the unit needs service.....and the manufacturer has gone radio-silent. You could take a chance and send the receiver to them via Priority Mail with delivery confirmation and see what happens. At the very least, nothing will happen if you don't send the defective receiver back.

Not to rub salt in a wound, but there are reps from other installed detector manufacturers who are on this site every day, working hard to earn our trust and our business. Escort has shown us all we need to see and it ain't good......
 

Duffer5

Learning to Fly
Beginner User
General User
Newly Registered
Joined
Nov 25, 2018
Messages
75
Reaction score
158
Rating - 0%
0   0   0
I am very sorry to hear of this. An installed detector is a blessing and a curse.....you get a concealed detector and don't have to deal with LEOs or thieves seeing a windshield mount. The downside is if/when the unit needs service.....and the manufacturer has gone radio-silent. You could take a chance and send the receiver to them via Priority Mail with delivery confirmation and see what happens. At the very least, nothing will happen if you don't send the defective receiver back.

Not to rub salt in a wound, but there are reps from other installed detector manufacturers who are on this site every day, working hard to earn our trust and our business. Escort has shown us all we need to see and it ain't good......
Yup. Status Quo. Something is broken in Escort land. I have seen this when a company is in a downward spiral on revenue and all efforts go to find a buyer / exit. Once a giant now a mere afterthought because they elected to ignore their customers.
 

Phillip Fox

pjfox23
Premium Member
General User
Newly Registered
Joined
Nov 23, 2018
Messages
12
Reaction score
9
Rating - 0%
0   0   0
Yup. Status Quo. Something is broken in Escort land. I have seen this when a company is in a downward spiral on revenue and all efforts go to find a buyer / exit. Once a giant now a mere afterthought because they elected to ignore their customers.
Very true. I do want to give a shout out to Jake and the folks at Rebel Radar. They actually responded to my emails with FREE advice, and are willing to sell me a 9500ci receiver if I need one. Way better customer service and not even the manufacture of the device!!!

I honestly can appreciate what the OP says, but this is NOT my experience.

Can you provide any additional insight like when is a good time to call? How did you actually get through without a 40+ minute hold?
 
Last edited:

Heywood

Learning Something New, Still Dying Stupid
Premium Member
Advanced User
Intermediate User
Beginner User
General User
Newly Registered
Joined
May 12, 2016
Messages
2,500
Reaction score
3,788
Location
Alberta Canada
Rating - 0%
0   0   0
I honestly can appreciate what the OP says, but this is NOT my experience.

Can you provide any additional insight like when is a good time to call? How did you actually get through without a 40+ minute hold?
Lol. Well it was at least 30 minutes.
9:30 am MST. On a Monday. I think I mentioned it at the start of the post?

I did not enjoy the hold time, but once through, they were helpful.

My issue wasn’t really a debatable one where it was something I might of done. I had the receipt and everything you’d expect you would need for a warranty exchange or repair.

Pretty hard to argue when the R-Ex was silent and had a “Check FR” blasting from the display.

Like I said, not happy it has to be repaired so soon and after very little use.
I didn’t like the amount of time I had to spends on hold.
I don’t care for how I can’t update my profile online and have to call in due to being a Canuck.

Just wanted to give credit to the Escort CS representative I did talk to. He was professional, courteous, understood my 2 issues, and added on a couple of years of Escort live updates for the data base.


Sent from my iPhone using Tapatalk
 

Heywood

Learning Something New, Still Dying Stupid
Premium Member
Advanced User
Intermediate User
Beginner User
General User
Newly Registered
Joined
May 12, 2016
Messages
2,500
Reaction score
3,788
Location
Alberta Canada
Rating - 0%
0   0   0
Update Jan 1 2019

Well I received my R-Ex back from Escort December 27th or 28th. Took it for a test drive and found that it wasn't alerting to any normal false location that I had locked out before.

I decided to take out my Bushnell and try it out. Hit and miss it would work. Took it for a drive on a spot where there are multiple K band speed signs that always set it off. There was one hit that stayed on forever. 23.112. Stayed on and seemed to stay locked in with no change in frequency or signal strength. Parked and watched it do that for about 3 minutes.

Took it home and tried updating the FW and the Database. Went out to try it again. Put the Put the R3 beside it to make sure it wasn't my gun.

The R-Ex didn't pick up a single hit and the R3 showed them all. 24.121, 24.099, 34.736, 35.538.

The repair invoice stated that the antenna was replaced and updated the FW.....why the FW I don't know. It was already at 1.12 when it went in and 1.12 when it came back.

Nice note. Professionally Tuned and calibrated to meet or exceed factory specs....LMAO Serviced Dec.13/18..

How nice. To make it even better, as I was sitting there checking the stupid thing, a nice big snow buildup from my roof of my truck, slid down onto my hot windshield in one big piece.....guess what happens when cold snow has a giant slide on to hot windshield…… contraction followed by a crack. PERFECT.

It's gotta go back again. Hope they do something about the $21.00 it costs me to ship it
 
Last edited:

Choose Life

35.5 hater R3 Day One User
Premium Member
Advanced User
Intermediate User
Beginner User
General User
Newly Registered
Joined
Jan 14, 2017
Messages
7,697
Reaction score
8,778
Location
Charlotte North Carolina
Rating - 0%
0   0   0
Sorry that happened to you
Its the time expenditure more than anything

Also the reason they gave you 3 years of the database (and anyone else that calls in) is to give escort live more users to keep it relevant when everyone uses waze (for free)
Also Ill wait 10mins on hold
But thats it
Anymore than that imo the company needs to hire more phone techs

I hope you can get your detector fixed
As you know this is why we dont like Escort
Will tell a man his detector is fixed and exceeds factory specs
When in actuality
Not only does it not work
They never tested the damn thing after the repair to begin with

Sorry again
They totally suck
 

Heywood

Learning Something New, Still Dying Stupid
Premium Member
Advanced User
Intermediate User
Beginner User
General User
Newly Registered
Joined
May 12, 2016
Messages
2,500
Reaction score
3,788
Location
Alberta Canada
Rating - 0%
0   0   0
Ya. It’s gotta go back in. I’m talking to the same service rep right now as I’m typing this.

They don’t offer courier service for international customers, so it’s another $21.00 to send it in.

At least they sent me a 2nd smart cord and another sticky mag mount. I never sent them that stuff.

It is what it is. He’s going to put a rush in it and it’s going to the manager in the back to see what was missed and why.

Probably the same guy that fixed it.

At least I don’t have the “Check FR” message anymore.

Next is a new front windshield. That’s the worst part. If I didn’t have to go out and test it, that wouldn’t have happened.


Sent from my iPhone using Tapatalk
 

Heywood

Learning Something New, Still Dying Stupid
Premium Member
Advanced User
Intermediate User
Beginner User
General User
Newly Registered
Joined
May 12, 2016
Messages
2,500
Reaction score
3,788
Location
Alberta Canada
Rating - 0%
0   0   0
I bet detections are disabled. I can’t remember how to re enable but you could ask about that. There’s a combination of buttons to push.
I’ve never heard of that.

I’d be totally besides myself if this was my DD. I’d say it probably doesn’t have more that 80 hours on it. I only use it for testing, comparisons and the odd jaunts in the rotation with the others.

No matter. That’s what warranty is for. Maybe I’ll get a 3rd power cord and 3rd sticky mag mount.

Just before it stopped, it was locked up at 24.112 on Speed sign #3 on my course. It didn’t even register speed sign 1 or 2. Speed sign 4 there was no change on the frequency or signal strength. Stayed fixated on the same frequency on a known false door opener between 4 & 5 before totally giving up the ghost.

Kind of throws the disable theory out the window.

So it tried to read a signal and blew itself up. It was extremely hot too. Way too hot.

You know the course Kasher.


Sent from my iPhone using Tapatalk
 

KASHER1979

Administrator
Administrator
Security Attaché
Premium Member
Advanced User
Newly Registered
Joined
Apr 15, 2013
Messages
13,149
Reaction score
9,951
Rating - 100%
2   0   0
I’ve never heard of that.

I’d be totally besides myself if this was my DD. I’d say it probably doesn’t have more that 80 hours on it. I only use it for testing, comparisons and the odd jaunts in the rotation with the others.

No matter. That’s what warranty is for. Maybe I’ll get a 3rd power cord and 3rd sticky mag mount.

Just before it stopped, it was locked up at 24.112 on Speed sign #3 on my course. It didn’t even register speed sign 1 or 2. Speed sign 4 there was no change on the frequency or signal strength. Stayed fixated on the same frequency on a known false door opener between 4 & 5 before totally giving up the ghost.

Kind of throws the disable theory out the window.

So it tried to read a signal and blew itself up. It was extremely hot too. Way too hot.

You know the course Kasher.


Sent from my iPhone using Tapatalk
Yea sounds like that’s not it. I can’t remember which button combinations or it would at least maybe be worth a try. But it sounds like you’ll just have to send it in again.
 

Donation drives

RDF Server & License Fees (Jan/Feb 2019)

This donation drive covers the server and licensing fees for RDF for the months of January and February 2019...
Goal
$795.00
Earned
$620.00
This donation drive ends in

Latest threads

Social Group Activity

Forum statistics

Threads
78,190
Messages
1,163,186
Members
17,986
Latest member
911turbodreams
Top