Technical and customer support

UnidenSupport

Learning to Fly
Beginner User
Manufacturer/Vendor
Joined
Oct 16, 2018
Messages
343
Reaction score
1,590
Just bought my r1 last week Is it maybe possible for a unit to maybe not have range that it should? Sometimes I'll leave it on hwy when I get into town and notice when I get near some traffic lights it just starts to k band . Maybe it's far away? Idk it really shouts at me passing under them. I was in a parking lot with a independent and Canadian tire in Carleton place Ontario, and it k banded, guessing it was the door openers.. But then a random Ka band went off.. Hwy to Ottawa was to my right. Went back to the spot and was just k again.. Maybe I cop was around? Been passing cops and it hasn't gone off . Gussing bc the rdd was off. Tips? Or info on the unit just ask
This could be perfectly fine and as suggested, there may be a setting issue. That being said, it is possible for defects to cause reduced range. I would suggest starting a thread with your location, firmware version, and what all of your settings are at, along with any suspected issues, and the good people here will get you sorted. feel free to private message me with questions as well.
 

Unidenjunky

Learning to Drive
General User
Joined
Nov 4, 2018
Messages
34
Reaction score
25
This could be perfectly fine and as suggested, there may be a setting issue. That being said, it is possible for defects to cause reduced range. I would suggest starting a thread with your location, firmware version, and what all of your settings are at, along with any suspected issues, and the good people here will get you sorted. feel free to private message me with questions as well.
Ty :)
 

dmajikmyke

Learning to Drive
General User
Joined
May 30, 2018
Messages
14
Reaction score
16
Hi UnidenSupport. Love my detector, but after only a few months the screen started to go crazy. Here are a few pics of what it looked like. I just sent it back and you guys should have it Monday (11/26/18). Just wanted to add pics so you guys can see what I meant on the paperwork for return to describe what was happening. Pics are always better than words and wish there was some way to send those with the return ticket. Thanks and keep up the good work!!
 

Attachments

zMarih0e

Learning to Drive
General User
Joined
Nov 10, 2018
Messages
9
Reaction score
1
@UnidenSupport

The plastic tab that holds the insertion part of the RJ-45 part of the cable has broken, so now the cable just slides in and out of the radar detector which is a nuisance. Some help please
 

Brilliant

Learning to Drive
General User
Joined
Nov 24, 2018
Messages
24
Reaction score
18
As far as I know, a computer guy with an RJ45 crimper should be able to change the connector for you.

It should be a simple cut, splice and match the same cable colours in the connector
 

benzr

Been there done that !! Original V1 user !!
Advanced User
Joined
Apr 23, 2012
Messages
4,855
Reaction score
5,521
Location
FLA

UnidenSupport

Learning to Fly
Beginner User
Manufacturer/Vendor
Joined
Oct 16, 2018
Messages
343
Reaction score
1,590
Hi UnidenSupport. Love my detector, but after only a few months the screen started to go crazy. Here are a few pics of what it looked like. I just sent it back and you guys should have it Monday (11/26/18). Just wanted to add pics so you guys can see what I meant on the paperwork for return to describe what was happening. Pics are always better than words and wish there was some way to send those with the return ticket. Thanks and keep up the good work!!
Update the firmware to see if that helps, I doubt it will. looks like there is a connection problem with the screen, if not a full on screen failure, and that will need to be sent in for repair.

As far as I know, a computer guy with an RJ45 crimper should be able to change the connector for you.

It should be a simple cut, splice and match the same cable colours in the connector
You could probably do that, or get a warranty replacement for the part if under warranty. Who am I to deny the industriousness of any user though?
 

dmajikmyke

Learning to Drive
General User
Joined
May 30, 2018
Messages
14
Reaction score
16
Update the firmware to see if that helps, I doubt it will. looks like there is a connection problem with the screen, if not a full on screen failure, and that will need to be sent in for repair.


If you read my post, it says that I already sent it in and as of yesterday you have it. And I did update firmware, on recovery mode, several times. Just wanted to send you pics of the screen so that you could relay them to your guys at the repair department so that they could see my issue.
 
Last edited:

UnidenSupport

Learning to Fly
Beginner User
Manufacturer/Vendor
Joined
Oct 16, 2018
Messages
343
Reaction score
1,590
If you read my post, it says that I already sent it in and as of yesterday you have it. And I did update firmware, on recovery mode, several times. Just wanted to send you pics of the screen so that you could relay them to your guys at the repair department so that they could see my issue.
I'll be honest, I can't read and I just look at pictures.
 

UnidenSupport

Learning to Fly
Beginner User
Manufacturer/Vendor
Joined
Oct 16, 2018
Messages
343
Reaction score
1,590
Come on, you don’t give yourself enough credit.

Your good with emoji’s as well.
Lol (jk).


Sent from my iPhone using Tapatalk
Yeah, i'm great with emoji's. you're right. :3)
 

keefrto

Loving Alberta's response to cameras. #not
Beginner User
Lifetime Premium Member
Joined
Nov 30, 2018
Messages
160
Reaction score
138
Location
Alberta, Canada
Hi Uniden support, i cant understand why each time i put a "mark" on a camera i see on the road travelling one way and when i am coming back on the other side of the road, another photo radar for example is further down the road, i try and mark that one but my R3 deletes the previous marked photo radar spot? cheers for any guidance
 

UnidenSupport

Learning to Fly
Beginner User
Manufacturer/Vendor
Joined
Oct 16, 2018
Messages
343
Reaction score
1,590
Hi Uniden support, i cant understand why each time i put a "mark" on a camera i see on the road travelling one way and when i am coming back on the other side of the road, another photo radar for example is further down the road, i try and mark that one but my R3 deletes the previous marked photo radar spot? cheers for any guidance
Hello, are you still in range of the other mark? if you are in range of one mark and hit the mark button, it will delete the previous one. I suspect as long as you are only hitting the button and not holding it, you may just be in the GPS range of the previous one.
 

Kennyc56

Ford Lover-I/O hater!
Advanced User
Lifetime Premium Member
Joined
Feb 22, 2018
Messages
2,637
Reaction score
6,409
Location
I/O Hell, Aka Eastern N.C.

keefrto

Loving Alberta's response to cameras. #not
Beginner User
Lifetime Premium Member
Joined
Nov 30, 2018
Messages
160
Reaction score
138
Location
Alberta, Canada
Hello, are you still in range of the other mark? if you are in range of one mark and hit the mark button, it will delete the previous one. I suspect as long as you are only hitting the button and not holding it, you may just be in the GPS range of the previous one.
Ah i didnt realise that there was a range, i will try again and this time hold it for longer then it should work or if ist within a certain range it wont change anyway?
 

Hyadum

In the shadows
General User
Joined
Jan 7, 2016
Messages
11
Reaction score
3
Location
Bucharest Romania
Hello guys,

I want to leave some hopefully constructive criticism about Uniden purchasing and delivery.
I'm not from the US, but I have been visiting for 2 weeks, and with this occasion I wanted to purchase a Uniden RD. I made Order #11781 (March 3, 2019). The estimated shipping date was one week (kind of a long time, but I understand you are busy with the R7 logistics now).
After 10 days and no emails and no tracking number, I contacted the support team to ask about the ETA for the delivery and AWB.
Only then have they shipped the radar detector, with the ETA after I was leaving the US. I had to cancel the order.

I'm a bit disappointed with the slow response and action from the warehouse team. My order was for an older product that was supposed to be in stock, but it took them 10 days to get it from the shelf into the courier car.
My next window will be in June, so I hope by then things will have changed for the better.

Regards,
Hyadum
 
Last edited:

UnidenSupport

Learning to Fly
Beginner User
Manufacturer/Vendor
Joined
Oct 16, 2018
Messages
343
Reaction score
1,590
Hello guys,

I want to leave some hopefully constructive criticism about Uniden purchasing and delivery.
I'm not from the US, but I have been visiting for 2 weeks, and with this occasion I wanted to purchase a Uniden RD. I made Order #11781 (March 3, 2019). The estimated shipping date was one week (kind of a long time, but I understand you are busy with the R7 logistics now).
After 10 days and no emails and no tracking number, I contacted the support team to ask about the ETA for the delivery and AWB.
Only then have they shipped the radar detector, with the ETA after I was leaving the US. I had to cancel the order.

I'm a bit disappointed with the slow response and action from the warehouse team. My order was for an older product that was supposed to be in stock, but it took them 10 days to get it from the shelf into the courier car.
My next window will be in June, so I hope by then things will have changed for the better.

Regards,
Hyadum
I completely understand your complaint. Currently orders over a certain price point must be manually approved as they are all flagged by our system as a fraud risk. This is something That ends up causing issues like this, but I have been told that we cannot change it at this time. As a public service announcement, I would recommend anyone ordering something that is a high-priced item to call us to make sure it get's approved as quickly as possible.
 

Discord Server

Latest threads

Forum statistics

Threads
77,536
Messages
1,181,588
Members
19,832
Latest member
radardetectorguy
Top