GT-1 - Just Received

seve760

Learning to Drive
General User
Newly Registered
Oct 11, 2014
35
50
#1
Out of curiosity, I ordered a GT1 to see if it really is "supercharged" like the folks from the Escort video interview claimed. Well, it's not even close. I received it yesterday and it's going back tomorrow. Thankfully, Escort is paying the return shipping. Anyway, first off, the IVT is useless. In fact the BSM's in my CX-5 set off the detector every 20 - 30 seconds, even with AutoScan enabled. My R1 works just fine in my car. In fact, I also have a GT-360, well I mean Escort service has it for a second time in a month for lock up issues, but when it was working, the IVT worked well. ( I was originally going to return it, but decided keep it and see if they could fix the lockups) Anyway, back to the GT1. Secondly, I was getting 35.8XX falsing. So I decided to seg it out since there were 10 options according to the manual. WRONG! The menu only allows you to get to segment 7 and goes right into the next options, Laser and TSR etc. I called Escort yesterday afternoon,and of course the guy had no idea of what the problem could be. In fact, he sounded like he didn't even know what the GT1 was, he kept saying do you mean GT7? He put me on hold for several minutes and assured me someone from Product Development would get back to me first thing this morning (10/2/18). Well here it is well past dinner time and I'm still waiting. Another annoying thing was when I would hit the mute button during an alert that was on automute to silence it, the automute feature would disengage, and the next alert would be a full set volume. Since this thing was no where near worth it's selling price, I did the return procedure thru ebay and Escort got right back to me with a return label, which was very impressive. Now all they need to do is redesign the GT1. Hope this info helps. Later, got to get up early.
 

Super Dave

I'm invisible
Premium Member
Intermediate User
Beginner User
General User
Newly Registered
Jun 1, 2014
502
577
Kentucky
#2
I can never tell what segment they are trying to sell to sometimes with these detectors they add on randomly.
 

InsipidMonkey

Premium Monkey
Premium Member
Advanced User
Intermediate User
Beginner User
General User
Acceptus
Newly Registered
Mar 22, 2017
4,645
8,009
New England
#3
Disappointing, but not unexpected. Thanks for taking one for the team and sharing your experiences with it!
At least it sounds like Escort has the return process down :)
 

seve760

Learning to Drive
General User
Newly Registered
Oct 11, 2014
35
50
#4
Disappointing, but not unexpected. Thanks for taking one for the team and sharing your experiences with it!
At least it sounds like Escort has the return process down :)
Your welcome. You are right, they do have the return process down. They received my return last Friday (10/5) and I received notification today (10/8/18) that I received my refund. Can't really ask for quicker turnaround than that. I also received an email today saying that my GT360 is on it's way to me (for the second time) from their service dept. Should have it tomorrow according to the tracking#. Can't wait to see how long before it locks up again.(lol). Maybe if it does, I can use the lemon law, you know, like for cars. if it's sent in for service for the same thing 3 times and it's not fixed, they have to but it back. LOL, just kidding, wishful thinking though.
 

SaintJMV04

Learning to Drive
General User
Newly Registered
Aug 31, 2018
10
5
#5
Out of curiosity, I ordered a GT1 to see if it really is "supercharged" like the folks from the Escort video interview claimed. Well, it's not even close. I received it yesterday and it's going back tomorrow. Thankfully, Escort is paying the return shipping. Anyway, first off, the IVT is useless. In fact the BSM's in my CX-5 set off the detector every 20 - 30 seconds, even with AutoScan enabled. My R1 works just fine in my car. In fact, I also have a GT-360, well I mean Escort service has it for a second time in a month for lock up issues, but when it was working, the IVT worked well. ( I was originally going to return it, but decided keep it and see if they could fix the lockups) Anyway, back to the GT1. Secondly, I was getting 35.8XX falsing. So I decided to seg it out since there were 10 options according to the manual. WRONG! The menu only allows you to get to segment 7 and goes right into the next options, Laser and TSR etc. I called Escort yesterday afternoon,and of course the guy had no idea of what the problem could be. In fact, he sounded like he didn't even know what the GT1 was, he kept saying do you mean GT7? He put me on hold for several minutes and assured me someone from Product Development would get back to me first thing this morning (10/2/18). Well here it is well past dinner time and I'm still waiting. Another annoying thing was when I would hit the mute button during an alert that was on automute to silence it, the automute feature would disengage, and the next alert would be a full set volume. Since this thing was no where near worth it's selling price, I did the return procedure thru ebay and Escort got right back to me with a return label, which was very impressive. Now all they need to do is redesign the GT1. Hope this info helps. Later, got to get up early.
Holy cow, totally agree with you. Performance of the GT-1 was terrible. I ordered from Amazon and it is going straight back without hesitation after only using it for one day. I like that it had a micro-USB... more modern port, but no support and horrible performance in regards to detection, I found it to be awful...