My Uniden R3 Display Problem? (1 Viewer)

The Mighty Four Banger

Time efficient
Intermediate User
Joined
May 25, 2018
Messages
528
Reaction score
543
Awards
0
Location
Texas
Honestly, Uniden needs to get their auto shutoff game down pack. The GPS chip keeps saying the car is moving and it can take up to 2 hours until auto shutoff.
Maybe they could have a threshold, it counts anything under 2 mph as 0.
 

Stkrdknmibalz

PTM Pacos Ahead!
Advanced User
Premium Member
Joined
Dec 6, 2016
Messages
3,523
Reaction score
1,283
Awards
0
Location
IGLOO
Burned in display, very common

Posted from my Spaceship ¯\_(ツ)_/¯
 

leog68

Learning to Drive
General User
Joined
Mar 25, 2016
Messages
13
Reaction score
2
Awards
0
Something doesn't look right where the speed is displayed on the far left. It's taken me a while to update my unit, so that was just recently done. Any thoughts?
Sorry for the comment on this old post. Known problem with screen burn out on Uniden R1and R3 Uniden should recall and fix them!
 

sdrawkcaB

Defender of Light
Advanced User
Lifetime Premium Member
Joined
Mar 6, 2018
Messages
3,887
Reaction score
7,579
Awards
0
Location
Here
Sorry for the comment on this old post. Known problem with screen burn out on Uniden R1and R3 Uniden should recall and fix them!
It's an issue with all OLED equipped detectors. Escort, Beltronics, Uniden, and etc. The real fix would be getting a higher quality display unit + additional movement of the elements on the screen continuously, but then we'd likely pay even more money for our detectors.
 

leog68

Learning to Drive
General User
Joined
Mar 25, 2016
Messages
13
Reaction score
2
Awards
0
It's an issue with all OLED equipped detectors. Escort, Beltronics, Uniden, and etc. The real fix would be getting a higher quality display unit + additional movement of the elements on the screen continuously, but then we'd likely pay even more money for our detectors.
More likely than not.
 

Deadhead1971

Instant-On Survivor
Advanced User
Premium Member
Joined
Dec 7, 2014
Messages
2,918
Reaction score
4,441
Awards
0
Location
Central NC
Sorry for the comment on this old post. Known problem with screen burn out on Uniden R1and R3 Uniden should recall and fix them!
What’s the purpose of this vague post? Are you just making a statement or are you experiencing this problem? If so, post a pic.

I don’t know how widespread this is. My R1 is a year and 4 months old with no issues- yet.
 

Up All Night

Lifetime RDF Contributor
Advanced User
Lifetime Premium Member
Joined
Nov 27, 2015
Messages
3,166
Reaction score
3,140
Awards
0
Location
Cleveland, OH
The newer FW addresses the issue and drives the displays less robustly.

Posted from my SM-J337P using the RDF Mobile App!
 

Jag42

USA TMG a-15 Dealer & Rep & TXCTG Rd tester
Advanced User
Premium Member
Manufacturer/Vendor
Joined
Jun 13, 2011
Messages
8,989
Reaction score
17,249
Awards
0
On the R7, speed/comp and other words and numbers disappear every 20-30 sec to prevent burn in.
 

The WiZard

Premium RDF Member
Intermediate User
Premium Member
Joined
Sep 24, 2011
Messages
281
Reaction score
158
Awards
0
Location
CT
What’s the purpose of this vague post? Are you just making a statement or are you experiencing this problem? If so, post a pic.

I don’t know how widespread this is. My R1 is a year and 4 months old with no issues- yet.
There is a thread on the forum here somewhere where there are many units affected by burn-in. Mine included.
 

Deadhead1971

Instant-On Survivor
Advanced User
Premium Member
Joined
Dec 7, 2014
Messages
2,918
Reaction score
4,441
Awards
0
Location
Central NC
There is a thread on the forum here somewhere where there are many units affected by burn-in. Mine included.
Saw the post months ago, I was asking the poster what’s up. He never said he was having an issue.
 

Kennyc56

Ford Lover, I/O Hater!
Advanced User
Lifetime Premium Member
Joined
Feb 22, 2018
Messages
2,484
Reaction score
5,978
Awards
0
Location
Eastern North Carolina
I have a small problem with a R1 I bought used a while back which is different than typical screen burn in. This detector is killer and works just as good as the one I bought brand new. The issue is the only color I can run is red. Blue, purple and all of the rest of the colors are all washed out. Red however still looks like brand new! So of course, I'm running it in dark mode on 1.48 and when I get an alert it lights up just fine on red. Has anyone else had this issue? I'm running dark mode on all 3 of my R1's now. The R1 with the issue is a very early model that might have came out before they updated the screens on the R series detectors, I don't know if that has anything to do with this or not. Amber still looks pretty good as well.
 
Last edited:

goodtimes40

Premium RDF Member
Intermediate User
Premium Member
Joined
Jun 29, 2012
Messages
506
Reaction score
279
Awards
0
Location
Port St. Lucie, Fl
Burn in and and yellowing. Where is your radar det. located and how long did you have it for?

It's either prolonged sun's UV exposure or simply ageing oled displays. If it's later we will be seeing more of those issues soon. If not it's UV rays.

Remember when Plasma tvs had burn in issues with same image being displayed. Ya that's the same thing as RD display is OLED. Current tvs have shifting pixels similar to screen saver and obviously RD does not have none of that so hence this issue. It still could be UV rays or both.

If you don't care for displaying compass for direction then perhaps dark mode would help also but i use compass quite often.
So what's the solution to the problem be to maybe run miles per hour for so long and then switch to Compass and just keep rotating would that solve the problem do you think so it doesn't burn in any one spot for too long or is it just a matter of time until it burns in. And it is now set to automatic dimmer so I believe it does its own thing I'm not sitting there adjusting the timer and brightness and other words I think the radar automatically does it now I'm still getting used to it I've only had it less than 3 weeks
 

leog68

Learning to Drive
General User
Joined
Mar 25, 2016
Messages
13
Reaction score
2
Awards
0
What’s the purpose of this vague post? Are you just making a statement or are you experiencing this problem? If so, post a pic.

I don’t know how widespread this is. My R1 is a year and 4 months old with no issues- yet.
This is common with this type of display, and not just Uniden. These displays should be recalled.
 

dereileak

Learning to Drive
General User
Joined
Jul 23, 2019
Messages
17
Reaction score
9
Awards
0
OLED burn in isn’t actually the pixels getting stuck, but more of how they wear out certain pixels more then the ones arounds them

From: Here's what you need to know about OLED screen burn-in


“What's colloquially called "burn-in" is actually, with OLED, uneven aging. They don't "burn in" as much as they "burn down." The candle that burns twice as bright burns half as long, right? OLED pixels very, very slowly get dimmer as they're used. In most cases this isn't an issue since you're watching varied content and all the pixels, on average, get used the same amount. But if you're only watching one thing, that one thing could cause uneven wear. Visually, and in the vernacular, this wear is called "burn-in." Uneven wear is more accurate, but also a lot more syllables.”
 

Users Who Are Viewing This Thread (Users: 0, Guests: 0)

Unregistered User Ad


ATTENTION: Want ads to disappear? Register for an account by clicking here - it's free and NO ADS ARE DISPLAYED TO REGISTERED MEMBERS! Thanks!

Donation drives

RDF Server & License Fees (AUGUST 2019) (ACTIVE)

This donation drive covers the server and licensing fees for RDF for the month of August 2019...
Goal
$541.00
Earned
$190.00
This donation drive ends in

Latest threads

Latest posts

Social Group Activity

Forum statistics

Threads
76,551
Messages
1,166,603
Members
19,674
Latest member
gwing
Top