Redline problems..

Discussion in 'Escort' started by playersnoopy, Nov 4, 2011.

  1. playersnoopy

    playersnoopy PSL +5 Intermediate User

    Messages:
    170
    Likes Received:
    32
    Joined:
    Aug 17, 2011
    So just recently my Redline has started acting up. When I first turn it on; sometimes it will give a full alert Ka and be stuck in it until I restart. I tried not restarting it once and it will even give off a second alert at times around 34.7 Ka and I drove about 20 miles like that just to see. After restart I've detected normal alerts in Ka but worried it may not be working sometimes. The settings I have it on is only Ka band alerts, POP on... I just recently turned POP off just to see. Anyone else ever had this hapen?
     
  2. EscortRadar

    EscortRadar Official Escort Representative General User

    Messages:
    1,083
    Likes Received:
    1,991
    Joined:
    Jul 27, 2011
    I would call us to set up servicing it. That is not normal behavior.
     
  3. Akosikojak

    Akosikojak PSL +15 Advanced User

    Messages:
    3,509
    Likes Received:
    403
    Joined:
    May 31, 2011
    Location:
    North Cackalacky
    Yep, sounds like your RL is sick, time to send it back to the Escort Docs for a fix :(
     
  4. Nazar

    Nazar ήσυχο ολοκληρωτής Advanced User Premium Member

    Messages:
    8,817
    Likes Received:
    2,724
    Joined:
    Aug 9, 2011
    Location:
    ¿Dónde crees que yo esté? no estaré ahí.
    try a reset first,,, if that doesn't work - send it in....

    reset fixes a number of querks
     
  5. playersnoopy

    playersnoopy PSL +5 Intermediate User

    Messages:
    170
    Likes Received:
    32
    Joined:
    Aug 17, 2011
    :( I was afraid of that... I'll give a call later next week... hope it doesn't cost a fortune x.X
     
  6. playersnoopy

    playersnoopy PSL +5 Intermediate User

    Messages:
    170
    Likes Received:
    32
    Joined:
    Aug 17, 2011
    that was the first thing I tried after I restarted.... did it again a few weeks later. Now I'm down to driving PSL+5 just in case -.-
     
  7. OpenRoad

    OpenRoad Must go faster Advanced User Premium Member

    Messages:
    14,357
    Likes Received:
    11,876
    Country:
    United States
    Joined:
    May 17, 2011
    Location:
    Surf City ---------------> Santa Cruz <-------
    Here is a vid of mine acting up (I posted this before, but if you've not seen it, sounds similar to yours, but on Ka band - mine flipped out on K-band)
    It did this the next day, so I drove around the block a few times, same weak and bogus K alert. Sent it back, they fixed the antenna, so far good as gold since.

    [video=youtube;7QNoSDeOKiA]http://www.youtube.com/watch?v=7QNoSDeOKiA[/video]
     
  8. playersnoopy

    playersnoopy PSL +5 Intermediate User

    Messages:
    170
    Likes Received:
    32
    Joined:
    Aug 17, 2011
    mine does a full blazing alert non stop... I have video of it... I guess I can upload it later. I can't duplicate it though... just random, and only on start up. My only guess is initial calibration at start up is way off or something. I just need it fixed before my next trip in January... I can drive slow til then x.X
     
  9. OpenRoad

    OpenRoad Must go faster Advanced User Premium Member

    Messages:
    14,357
    Likes Received:
    11,876
    Country:
    United States
    Joined:
    May 17, 2011
    Location:
    Surf City ---------------> Santa Cruz <-------
    Yeah, then it's time to send it to home base for repair. It's likely an antenna issue, IMHO.
     
  10. Akosikojak

    Akosikojak PSL +15 Advanced User

    Messages:
    3,509
    Likes Received:
    403
    Joined:
    May 31, 2011
    Location:
    North Cackalacky
    That's a long time Bro, DANG!!!
     
  11. OpenRoad

    OpenRoad Must go faster Advanced User Premium Member

    Messages:
    14,357
    Likes Received:
    11,876
    Country:
    United States
    Joined:
    May 17, 2011
    Location:
    Surf City ---------------> Santa Cruz <-------
    Agreed, I'd fix it now. Escort also gives you a repair warranty of (I am pretty sure) 6 months.
     
  12. KaPro

    KaPro multiple signals detected Advanced User

    Messages:
    828
    Likes Received:
    110
    Joined:
    Oct 29, 2010
    Location:
    Endless Mountains
    ^^^ Correct!!
     
  13. Akosikojak

    Akosikojak PSL +15 Advanced User

    Messages:
    3,509
    Likes Received:
    403
    Joined:
    May 31, 2011
    Location:
    North Cackalacky
    [video=youtube;FvW6_-TP5cs]http://www.youtube.com/watch?v=FvW6_-TP5cs[/video] ;)
     
  14. milkman

    milkman Premium Member Advanced User Premium Member

    Messages:
    9,054
    Likes Received:
    2,550
    Country:
    United States
    Joined:
    Dec 6, 2010
    Location:
    Missouri
    X3 The Redline is one of the Best RD when working properly!
     
  15. playersnoopy

    playersnoopy PSL +5 Intermediate User

    Messages:
    170
    Likes Received:
    32
    Joined:
    Aug 17, 2011
    Just dropped my Redline off at the post office... I'm kinda sad now :(
    Really hard driving so slow x.X

    $79.99 fee for service, $10 for shipping
    I like how the cust rep said if you send in the windshield mount they'll replace the suction cups... hope I don't get back a still faulty RL with nice suction cups :p
     
  16. kadafrogg

    kadafrogg PSL +15 Advanced User

    Messages:
    854
    Likes Received:
    124
    Country:
    United States
    Joined:
    Jul 28, 2011
    Location:
    west columbia sc
    my redline will alert to k band like that for a while then go full blast running a sti-r plus and its silent called escort and told them i wanted to send it in and what it was doing guy wouldnt take it told me i couldnt run stir-plus with it and thats what was giving me false k band.
     
  17. milkman

    milkman Premium Member Advanced User Premium Member

    Messages:
    9,054
    Likes Received:
    2,550
    Country:
    United States
    Joined:
    Dec 6, 2010
    Location:
    Missouri
    $80 fee for service. That to me is awfully damn high!
     
  18. playersnoopy

    playersnoopy PSL +5 Intermediate User

    Messages:
    170
    Likes Received:
    32
    Joined:
    Aug 17, 2011
    Yeah a little on the steep side I think too... at first he said $59.99 and quickly changed that to $79.99 I'm guessing it's $59.99 for lower models. $80 for a $500 product is a bit much unless the thing was completely non functional.
     
  19. hiddencam

    hiddencam Premium Member Advanced User Premium Member

    Messages:
    9,720
    Likes Received:
    17,177
    Country:
    United States
    Joined:
    Oct 29, 2010
    I'd expect a service + RDR & Band segmentation for that! haha

    But seriously, they've got you by the balls with a grin on their faces; whoever is prepared to hand over 500 bucks to buy the device is sure as shyte gonna be highly motivated to pay 80 bucks to get it back to working order. I know I would be if it crapped out on me; cuz the Redline is a BEAST!
     
  20. playersnoopy

    playersnoopy PSL +5 Intermediate User

    Messages:
    170
    Likes Received:
    32
    Joined:
    Aug 17, 2011
    Well... I get my redline back today.... damn you UPS hurry up!!! I want to go out!
     

Currently Active Users Viewing This Thread: 0 (Users: 0, Guests: 0)

Show Sidebar