12V Power Cord Went Out for CR-90? Any Ideas for Fix or Replacement?

Discussion in 'Whistler' started by Wahoo King, Nov 3, 2015.

  1. Wahoo King

    Wahoo King Learning to Fly Beginner User

    Messages:
    55
    Likes Received:
    33
    Joined:
    Jul 24, 2014
    Location:
    SE FL
    I purchased the unit July 2014. The cord for was working last night but not today. Fuse looks good an tightened everything back up, no power. Thankfully I have an older cord but was using ti for my XTR-695SE in another vehicle. Looks like a replacement can be ordered from Whistler but thought I would post the question here in case anyone has a better suggestion. The newer cord has the advantage of having a USB input. I may try to pry the modular piece apart but that may destroy it. Thanks for any suggestions you may have. Looked online a bit and there may be a universal replacement that would work with the RD. And yes I still like the unit quite a bit.
     
  2. myblkrat

    myblkrat Learning to Drive General User

    Messages:
    40
    Likes Received:
    6
    Joined:
    Nov 16, 2011
    Location:
    SW Missouri
    if you know how to solder its a possible easy fix. The ground wire broke off the board. simply cut/strip/solder back on. This what happened to the one I had.
     
  3. Wahoo King

    Wahoo King Learning to Fly Beginner User

    Messages:
    55
    Likes Received:
    33
    Joined:
    Jul 24, 2014
    Location:
    SE FL
    I took the modular piece apart, nothing looks missing, both red/white wires are attached to the board...very strange....I even switched out the fuse from the older cord but that made no difference. I guess I will just throw it in a drawer.
     
  4. myblkrat

    myblkrat Learning to Drive General User

    Messages:
    40
    Likes Received:
    6
    Joined:
    Nov 16, 2011
    Location:
    SW Missouri
    does the USB part work? That will at least tell you that the power from the lighter is getting into the plug and that part is working.
     
  5. Wahoo King

    Wahoo King Learning to Fly Beginner User

    Messages:
    55
    Likes Received:
    33
    Joined:
    Jul 24, 2014
    Location:
    SE FL
    No it does not...tried it with my cell phone charger cord, no go. If there was power the little blue light would normally come on, that was my first indication there was a problem...lucky I still have the old cord but very odd and of course this is an accessory part so it is not covered under the 2 year warranty.

    Well, just took it apart one more time and now notice the little metal clip piece has a black wire that is not attached to the board..can you let me know where this wire should be soldered to? This has to be the issue.
     
    Last edited: Nov 5, 2015
  6. myblkrat

    myblkrat Learning to Drive General User

    Messages:
    40
    Likes Received:
    6
    Joined:
    Nov 16, 2011
    Location:
    SW Missouri
    ground wire location.

    If this worked you can see where the black wire goes to on the board.
     
    Wahoo King likes this.
  7. Wahoo King

    Wahoo King Learning to Fly Beginner User

    Messages:
    55
    Likes Received:
    33
    Joined:
    Jul 24, 2014
    Location:
    SE FL
    Thanks that is a great picture....not much surface area to solder but after multiple attempts finally got it back in, problem was the white wire came undone on the other side as you heated everything up. Precarious to say the least but put it all back together and it works again!
     
    Last edited: Nov 6, 2015
  8. myblkrat

    myblkrat Learning to Drive General User

    Messages:
    40
    Likes Received:
    6
    Joined:
    Nov 16, 2011
    Location:
    SW Missouri
    glad your up and running again!
     
  9. BhamGuy

    BhamGuy PSL +10 Advanced User

    Messages:
    786
    Likes Received:
    654
    Country:
    United States
    Joined:
    Oct 24, 2015
    For what it's worth, my cord went bad on my CR-90 recently. Checked the warranty, and saw that it is a two year warranty. Called the company, described the problem (light didn't light up, and the USB outlet didn't provide any power) and they said they'd send me a new one.

    I have some issues with the device, but great customer service. (I did have to email them a copy of my invoice where I bought it last December. )

    Sent from my SM-G900T using Tapatalk
     
  10. Wahoo King

    Wahoo King Learning to Fly Beginner User

    Messages:
    55
    Likes Received:
    33
    Joined:
    Jul 24, 2014
    Location:
    SE FL
    I also called them and was told that was an accessory and was not covered under the warranty....guess you got lucky. Am using the unit in another car as I test out my new Uniden.
     
  11. BhamGuy

    BhamGuy PSL +10 Advanced User

    Messages:
    786
    Likes Received:
    654
    Country:
    United States
    Joined:
    Oct 24, 2015
    I haven't gotten lucky yet. I sent the receipt via email to the guy I spoke with at Whistler, and he was supposed to send me confirmation of shipping via email before it shipped.

    That was two weeks ago, and I have no replacement cord or email yet. I followed up a minute ago, and will let you know.

    The cost of a replacement cord isn't that much, but I would not accept the company's explanation that it is an accessory. It was part of the device that was sold, and it is not excluded by the warranty that I read. May not be worth the trouble, but I am following up with him nonetheless.

    Will let you know.

    Sent from my SM-G900T using Tapatalk
     
  12. Wahoo King

    Wahoo King Learning to Fly Beginner User

    Messages:
    55
    Likes Received:
    33
    Joined:
    Jul 24, 2014
    Location:
    SE FL
    Thanks for the follow up, hope you get yours...it is odd they would not cover it IMHO but whatever....I paid almost $200 for the unit, you would think that would be covered.
     
  13. BhamGuy

    BhamGuy PSL +10 Advanced User

    Messages:
    786
    Likes Received:
    654
    Country:
    United States
    Joined:
    Oct 24, 2015
    I just received an email from their customer service manager that said that he thought the order had already been placed but it had not. He claims he has ordered another one and is sending it Priority Mail.

    I sent him two follow up emails after not hearing anything for two weeks, and it will be 3 weeks before I receive it even if he is telling me the truth, but it does appear that he intends to follow through.

    Sent from my SM-G900T using Tapatalk
     
    Last edited: Dec 1, 2015
  14. BhamGuy

    BhamGuy PSL +10 Advanced User

    Messages:
    786
    Likes Received:
    654
    Country:
    United States
    Joined:
    Oct 24, 2015
    I received my new cord. Works perfectly with it. It was a little delay, but can't complain with them shipping it out without me having to return the unit first.
     
  15. jim vielbig

    jim vielbig Learning to Drive General User

    Messages:
    2
    Likes Received:
    0
    Country:
    United States
    Joined:
    May 3, 2018
    I did the same today after reading your post. My CR 90 is ~ 5 months out of warranty with a DOA power cord. Whistler is sending a new one, free of charge.
    Thanks for the tip!
     
  16. Leon Chocron

    Leon Chocron Learning to Drive General User

    Messages:
    30
    Likes Received:
    22
    Country:
    United States
    Joined:
    Mar 4, 2018
    We can fix it for you at no cost as long as you pay for the shipping, thanks

    Leo