Beltronics Stir Plus Radar Decetor still not working right

kvideo

Learning to Fly
Beginner User
General User
Newly Registered
Sep 13, 2012
178
37
St. Louis, Missouri
#1
Hello,

My problem is I have a stir plus r.d. and the module where you control the power and the mute button, those two buttons work fine the four buttons on the side of that module where the volume control and sensitivity is that is not working. I already sent that module device to escort and they say the module device is working for them. I need help, don't know what I need to tell my installer to take out so I can send it in to have it be replace. One installer from escort suggested that the gps is not working. It is working. So I need help guys. Please and Thank You.
 

Stalker

Learning to Drive
General User
Newly Registered
Jun 29, 2017
17
5
#2
Hey mate did you get an answer on this? Mi e is doing this now. Brand new control module same thing.

Perhaps the earth or something else...

Anyone got any ideas?

--- DOUBLEPOST MERGED ---

Weird thing is it worked when I put the new module in but now it’s not...

If I press the mark & brt it marks, press the send an vol together it adjusts from city to highway etc.

Sometimes when I press the mark button it changes brightness setting.

Tried on 2 new controllers with same results.
 

Stalker

Learning to Drive
General User
Newly Registered
Jun 29, 2017
17
5
#3
Anyone?


Sent from my iPhone using Tapatalk
 

Stalker

Learning to Drive
General User
Newly Registered
Jun 29, 2017
17
5
#4
Did an update all. Now it is saying front last alert. Rear laser alert and no gps.

Used latest version of detector tools.

Is bel software this ****?


Sent from my iPhone using Tapatalk
 

Stalker

Learning to Drive
General User
Newly Registered
Jun 29, 2017
17
5
#5
well still nothing....not even from escort...so dissapointed in their lack of care for their customers