2014 Mazda 3 ultimate CJR install. (1 Viewer)

CJR238

-CMS Article Admin-
Administrator
Advanced User
Lifetime Premium Member
The Pen Is My Sword
Joined
Oct 30, 2010
Messages
27,239
Reaction score
18,293
Awards
0
Location
CT- 4Runner - ALP - V1/RedLine/Waze
i'd really like to see your front sensor placement, but the pictures don't link.

i have a 15 mazda 6 and was looking to see if there's a better way to adhere them than i have now.
Odd, not sure why you can't see the pictures. They are all there for me.

So ideally you should use the brackets I was able to mount my sensors right on the grill with double-sided tape. Didn't require much effort leveling them.

Sent from my XT1080 using Tapatalk
 

speedycakeremix

Learning to Drive
General User
Joined
Aug 13, 2015
Messages
5
Reaction score
0
Awards
0
did you mount it on the top or underside of the slat? and you mean you didn't end up using the brackets?
 

CJR238

-CMS Article Admin-
Administrator
Advanced User
Lifetime Premium Member
The Pen Is My Sword
Joined
Oct 30, 2010
Messages
27,239
Reaction score
18,293
Awards
0
Location
CT- 4Runner - ALP - V1/RedLine/Waze
did you mount it on the top or underside of the slat? and you mean you didn't end up using the brackets?
Nope, didn't use the brackets. The darn Mazda3 is all riveted so we couldn't take the nose of the car off to mount easily. Luckily the grill slots were semi level so i just mounted them on top of the slats and leveled a bit. Don't mount from under the slats unless the head can stick out a bit.

Lets see if this picture comes up for you.

IMG_20140812_114111_zpsfk6xv96g.jpg


IMG_20140812_114315_zpsfyb2zzff.jpg
 

speedycakeremix

Learning to Drive
General User
Joined
Aug 13, 2015
Messages
5
Reaction score
0
Awards
0
so i noticed... even had to run the cables up through the hood lock opening cause i couldn't see any other way to pass the radiator.

and nope, sorry nothing. I'll try moving mine to see if that can help level them.

thanks mate
 

CJR238

-CMS Article Admin-
Administrator
Advanced User
Lifetime Premium Member
The Pen Is My Sword
Joined
Oct 30, 2010
Messages
27,239
Reaction score
18,293
Awards
0
Location
CT- 4Runner - ALP - V1/RedLine/Waze
so i noticed... even had to run the cables up through the hood lock opening cause i couldn't see any other way to pass the radiator.

and nope, sorry nothing. I'll try moving mine to see if that can help level them.

thanks mate
I have to say the Mazda's have the tightest fit and finish i have ever seen on any car i have ever owned/worked on. And that includes Acura, Mercedes, Tesla, and many American cars.
 

CJR238

-CMS Article Admin-
Administrator
Advanced User
Lifetime Premium Member
The Pen Is My Sword
Joined
Oct 30, 2010
Messages
27,239
Reaction score
18,293
Awards
0
Location
CT- 4Runner - ALP - V1/RedLine/Waze
Had my second ALP head fail on me the other day. I was pretty bummed to have another head fail, but the ALP's are much more sophisticated than other jammers and do warn of a failing head so at least i knew. I guess it can be a double edge sword.

The first head fail was my rear head, which was a huge pain since it requires taking apart my whole hatch and we know how that goes. That one went within my 2 year warranty so it was covered. Thank you BRD for helping me out with that one.

Second head died at year 3. Was a front head so no issue removing it and confirming it was dead. No warranty though so i was stuck and couldn't not even afford to replace it with a BRD discount. Thought i was going to have to bring out my old LI's or run with just 1 head. But luckily for this awesome forum and great community one of RDF's awesome members gave me a loaner!

One thing i noticed between my 2014 head and the new heads is the seal around the lens is different. The old heads really didn't have a seal, more like they were just glued together. The new heads clearly have some kind of waterproof rubber grommet which should handle temperature changes and water better. I'm guessing this was discussed at some point, i just must have missed it. Been out of the loop with forum Admin stuff for a while.

I took comparison pictures:

2014 head:
9Man6wCh.jpg


2016 head:

vg5cO4Vh.jpg



All installed and looking good!

FnJvdP3h.jpg
 
Last edited:

Users Who Are Viewing This Thread (Users: 0, Guests: 0)

Unregistered User Ad


ATTENTION: Want ads to disappear? Register for an account by clicking here - it's free and NO ADS ARE DISPLAYED TO REGISTERED MEMBERS! Thanks!

Donation drives

RDF Server & License Fees (AUGUST 2019) (ACTIVE)

This donation drive covers the server and licensing fees for RDF for the month of August 2019...
Goal
$541.00
Earned
$145.00
This donation drive ends in

Latest threads

Latest posts

Social Group Activity

Forum statistics

Threads
84,730
Messages
1,269,066
Members
19,636
Latest member
yvnrg1981
Top